Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-04-04, 12:47 PM   #1
LeperMessiah
Registered User
 
Join Date: Jun 2004
Posts: 5
Default Resolution problem

First off all, I know there are other posts with this problem as well, but none of the (very few) solutions they found are working for me.

The thing is that I have a 17" LCD screen, capable of displaying 1280x1024 with a vertical sync at 75Hz and horisontal at 80 KHz. The funny thing is that I cant choose 1280x1024, but only 1280x960. The problem goes away as soon as I disable 3d acceleration.

I have tried removing all other resolutions from my XF86Config file, so that only 1280x1024 was possible, but never the less, it still used 1280x960.

My XF86Config file:

# /.../
# SaX generated XFree86 config file
# Created on: 2004-06-04T16:30:24+0200.
#
# Version: 4.8
# Contact: Marcus Schaefer <sax@suse.de>, 2002
#
# Automatically generated by [ISaX] (4.8)
# PLEASE DO NOT EDIT THIS FILE!
#
Section "Files"
FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/local"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/URW"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
FontPath "/usr/X11R6/lib/X11/fonts/PEX"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/kwintv"
FontPath "/usr/X11R6/lib/X11/fonts/truetype"
FontPath "/usr/X11R6/lib/X11/fonts/uni:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/CID"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
InputDevices "/dev/ttyS0"
InputDevices "/dev/ttyS1"
InputDevices "/dev/ttyS2"
InputDevices "/dev/ttyS3"
InputDevices "/dev/ttyS4"
InputDevices "/dev/ttyS5"
InputDevices "/dev/ttyS6"
InputDevices "/dev/ttyS7"
InputDevices "/dev/ttyS8"
InputDevices "/dev/psaux"
InputDevices "/dev/logibm"
InputDevices "/dev/sunmouse"
InputDevices "/dev/atibm"
InputDevices "/dev/amigamouse"
InputDevices "/dev/atarimouse"
InputDevices "/dev/inportbm"
InputDevices "/dev/gpmdata"
InputDevices "/dev/mouse"
InputDevices "/dev/usbmouse"
InputDevices "/dev/adbmouse"
InputDevices "/dev/input/mice"
InputDevices "/dev/input/event0"
InputDevices "/dev/pointer0"
InputDevices "/dev/pointer1"
InputDevices "/dev/pointer2"
InputDevices "/dev/pointer3"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail"
Option "RandR" "on"
EndSection

Section "Module"
Load "dbe"
Load "type1"
Load "speedo"
Load "freetype"
Load "extmod"
Load "glx"
Load "v4l"
EndSection

Section "InputDevice"
Driver "Keyboard"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "dk"
Option "XkbModel" "pc104"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "7"
Option "Device" "/dev/input/mice"
Option "Name" "Autodetection"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Option "CalcAlgorithm" "CheckDesktopGeometry"
DisplaySize 320 240
HorizSync 31-80
Identifier "Monitor[0]"
ModelName "1280X1024@75HZ"
VendorName "--> LCD"
VertRefresh 50-75
UseModes "Modes[0]"
EndSection

Section "Modes"
Identifier "Modes[0]"
Modeline "1280x1024" 114.54 1280 1360 1496 1712 1024 1025 1028 1062
#Modeline "1280x1024" 134.72 1280 1368 1504 1728 1024 1025 1028 1068
#Modeline "1024x768" 73.89 1024 1080 1192 1360 768 769 772 799
EndSection

Section "Screen"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1280x1024"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection

Section "Device"
BoardName "GeForce4 MX 420"
BusID "1:0:0"
Driver "nvidia"
Identifier "Device[0]"
Screen 0
Option "Rotate" "off"
VendorName "NVidia"
EndSection

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection

Any ideas ???
LeperMessiah is offline   Reply With Quote
Old 06-04-04, 01:17 PM   #2
SuLinUX
 
SuLinUX's Avatar
 
Join Date: Sep 2003
Location: UK
Posts: 847
Default Re: Resolution problem

Are you saying that you cannot select 1280x1024 in sax2 or you can but the test dont work?
__________________
AthlonXP 2600+ / nForce2 Asus A7N8X-X / PNY GeForce FX5900 Ultra / 1024Mb Samsung Ram /nForce Sound / Hansol 920D Plus 19" monitor / Lite-On 32x12x40 / 2x Maxtor HD 40Gb/80Gb / nVidia 7174 driver / Gnome 2.10.1 / Kernel 2.6.11.9 / Slackware 10.0
SuLinUX is offline   Reply With Quote
Old 06-04-04, 01:45 PM   #3
LeperMessiah
Registered User
 
Join Date: Jun 2004
Posts: 5
Default Re: Resolution problem

In sax2 i can select 1280x1024, but when testing the settings, it displays 1280x960. In the KDE settings, I cannot go any higher than 1280x960.
LeperMessiah is offline   Reply With Quote
Old 06-04-04, 02:08 PM   #4
SuLinUX
 
SuLinUX's Avatar
 
Join Date: Sep 2003
Location: UK
Posts: 847
Default Re: Resolution problem

Weird, try LCD 1600x1200@60Hz(or what ever Hz) and then set the resolutions in sax2, use the screen resize & rotate utility via the kmenu or kde.
__________________
AthlonXP 2600+ / nForce2 Asus A7N8X-X / PNY GeForce FX5900 Ultra / 1024Mb Samsung Ram /nForce Sound / Hansol 920D Plus 19" monitor / Lite-On 32x12x40 / 2x Maxtor HD 40Gb/80Gb / nVidia 7174 driver / Gnome 2.10.1 / Kernel 2.6.11.9 / Slackware 10.0
SuLinUX is offline   Reply With Quote
Old 06-04-04, 02:30 PM   #5
LeperMessiah
Registered User
 
Join Date: Jun 2004
Posts: 5
Default Re: Resolution problem

I tried 1400x1050 and 1600x1200, but I still cant choose any higher than 1280x960
LeperMessiah is offline   Reply With Quote
Old 06-06-04, 06:26 AM   #6
draagyn
Registered User
 
draagyn's Avatar
 
Join Date: May 2004
Posts: 23
Default Re: Resolution problem

Your resolution doesn't match your display size.
Omit:
DisplaySize 320 240
under Section "Monitor"
Should work fine without it. If it doesn't, are you sure your monitor isn't meant to only display widescreen?
Good luck, and hopefully this helps!
draagyn is offline   Reply With Quote
Old 06-06-04, 06:46 PM   #7
LeperMessiah
Registered User
 
Join Date: Jun 2004
Posts: 5
Default Re: Resolution problem

I tried first removing the DisplaySize line, that didtn't work. I then tried measuring my screen with a ruler, and inserting thoose values instead. Neither did that work. Im am very certain that the screen is capable of displaying 1280x1024. All I need to do, is change driver nvidia to driver nv.....but I want 3d.

Anyway, thanks for the suggestion, but sadly that didnt solve it.
LeperMessiah is offline   Reply With Quote
Old 06-07-04, 10:13 AM   #8
UncleZeiv
Registered User
 
Join Date: Feb 2004
Posts: 15
Default Re: Resolution problem

Have you tried to disable EDID polling? Should be an option named something like "IgnoreEDID" or "NoDDC".
By the way, I have a similar problem with my toshiba notebook. "IgnoreEDID" + module options used to work some time ago, but newer versions of the driver somehow broke this feature for secondary video modes. So now I have to use an older version (4363).
__________________
--
phoenix foundation
UncleZeiv is offline   Reply With Quote

Old 06-12-04, 06:41 PM   #9
LeperMessiah
Registered User
 
Join Date: Jun 2004
Posts: 5
Thumbs up Re: Resolution problem

UncleZeiv....if you were here, I'd kiss you!

I inserted a line with "Option "IgnoreEDID"", under "Section "Monitor"", and now it works.

Ceeeeeeeeeelebraate good times, come on!
LeperMessiah is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
[Regression] "6 little screens" problem is back with 302.07 (AU0-8428 pannel) mile-igad NVIDIA Linux 6 06-26-12 08:10 AM
Opinions on 1280x1024 resolution skipparoo NVIDIA GeForce 7, 8, And 9 Series 103 06-22-12 11:38 PM
HDMI overscan fix for multiple resolutions + Zod Engine Problem. cheechr1 NVIDIA Linux 0 06-11-12 02:27 PM
30.82 and 40.41 resolution + monitor OSD. Max3D NVIDIA Windows Graphics Drivers 2 09-05-02 02:15 AM
Nvidia Go on laptop, black border within XFree86 problem raxip NVIDIA Linux 3 07-31-02 10:58 AM

All times are GMT -5. The time now is 11:36 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.