Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-05-04, 09:54 PM   #1
John5788
Registered User
 
Join Date: May 2004
Posts: 9
Default Low FPS in Americas Army

My computer specs:
Pentium 4 2.0GHz
1024MB PC2700 DDR
Chaintech GeForce FX5900XT
Gentoo 2004.1 w/ 2.6.5-r1 kernel source

my fps in america's army is simply horrible. in any resolution and any settings i choose, i only get average 20 fps. even in 24bit or 16bit still 20 fps. but my glxgear scores at 8000-9000 in either depth mode too. so whats going on? and yes i do have my power connector plugged into the card. i also did try using AGPGART and the normal nvidia agp. any suggestions why its so slow?
John5788 is offline   Reply With Quote
Old 06-06-04, 12:40 AM   #2
whig
550Ti
 
Join Date: Jan 2004
Location: New Zealand
Posts: 854
Default Re: Low FPS in Americas Army

Did you also experiment with different NvAGP values? Look in the nv docs about this.
whig is offline   Reply With Quote
Old 06-06-04, 12:52 AM   #3
John5788
Registered User
 
Join Date: May 2004
Posts: 9
Default Re: Low FPS in Americas Army

i did, i mentioned that i switched between AGPGART and the original NV AGP driver. AGP gives _slightly_ more fps in glxgears, about 300 more, but doesnt show difference in AA
John5788 is offline   Reply With Quote
Old 06-06-04, 05:14 AM   #4
whig
550Ti
 
Join Date: Jan 2004
Location: New Zealand
Posts: 854
Default Re: Low FPS in Americas Army

Next try: disable tls if you are using it... search this forum "tls". And try other games - are they poor performers too?
whig is offline   Reply With Quote
Old 06-06-04, 02:47 PM   #5
John5788
Registered User
 
Join Date: May 2004
Posts: 9
Default Re: Low FPS in Americas Army

winex and cstrike.
John5788 is offline   Reply With Quote
Old 06-06-04, 03:56 PM   #6
John5788
Registered User
 
Join Date: May 2004
Posts: 9
Default Re: Low FPS in Americas Army

can you point me to a good thread about this? i cant find anything..
John5788 is offline   Reply With Quote
Old 06-06-04, 06:03 PM   #7
whig
550Ti
 
Join Date: Jan 2004
Location: New Zealand
Posts: 854
Default Re: Low FPS in Americas Army

Some methods for disabling tls:

http://www.nvnews.net/vbulletin/show...t=tls+ldconfig

It would be wise to note what you need to do if you want to back-out.
whig is offline   Reply With Quote
Old 06-06-04, 09:41 PM   #8
John5788
Registered User
 
Join Date: May 2004
Posts: 9
Default Re: Low FPS in Americas Army

ok so just basically remove the tls directory right? im using xorg and not xfree right now.
John5788 is offline   Reply With Quote

Old 06-06-04, 11:37 PM   #9
whig
550Ti
 
Join Date: Jan 2004
Location: New Zealand
Posts: 854
Default Re: Low FPS in Americas Army

Yep, although I would
Code:
ldd `which glxgears`
tar zcvpf ~/tls-backup.tgz tls
rm -r tls
ldconfig
ldd `which glxgears`
where tls is where the libraries are.
whig is offline   Reply With Quote
Old 06-07-04, 08:09 PM   #10
John5788
Registered User
 
Join Date: May 2004
Posts: 9
Default Re: Low FPS in Americas Army

it doesnt seem like im using tls.

Code:
john5788@john5788 john5788 $ ldd `which glxgears`
        linux-gate.so.1 =>  (0xffffe000)
        libGL.so.1 => /usr/X11R6/lib/libGL.so.1 (0x4000a000)
        libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x4cc10000)
        libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x4cb28000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x4cc2b000)
        libm.so.6 => /lib/libm.so.6 (0x4cbed000)
        libc.so.6 => /lib/libc.so.6 (0x4c9f9000)
        libGLcore.so.1 => /usr/lib/opengl/nvidia/lib/libGLcore.so.1 (0x40067000)
        libdl.so.2 => /lib/libdl.so.2 (0x4cb23000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x4c9e3000)
and i even did a locate tls, results here:

Code:
john5788@john5788 john5788 $ locate tls
/var/cache/edb/dep/dev-tcltk/tls-1.4.1
/var/cache/edb/dep/dev-tcltk/tls-1.5.0
/var/cache/edb/dep/app-crypt/qca-tls-1.0
/var/cache/edb/dep/net-libs/gnutls-1.0.4
/var/cache/edb/dep/net-libs/gnutls-0.8.10
/var/cache/edb/dep/net-libs/gnutls-0.8.12
/var/cache/edb/dep/net-misc/tlsproxyd-0.0.2
/var/cache/edb/dep/dev-java/puretls-0.94_beta4
/usr/lib/gaim/ssl-gnutls.la
/usr/lib/gaim/ssl-gnutls.so
/usr/lib/perl5/site_perl/5.8.2/i686-linux/asm/ioctls.ph
/usr/lib/perl5/site_perl/5.8.2/i686-linux/bits/ioctls.ph
/usr/src/linux-2.6.5-gentoo-r1/arch/x86_64/ia32/tls32.c
/usr/src/linux-2.6.5-gentoo-r1/include/asm-m68knommu/ioctls.h
/usr/src/linux-2.6.5-gentoo-r1/include/asm-sh/ioctls.h
/usr/src/linux-2.6.5-gentoo-r1/include/asm-um/ioctls.h
/usr/src/linux-2.6.5-gentoo-r1/include/asm-parisc/ioctls.h
/usr/src/linux-2.6.5-gentoo-r1/include/asm-x86_64/ioctls.h
/usr/src/linux-2.6.5-gentoo-r1/include/asm-alpha/ioctls.h
/usr/src/linux-2.6.5-gentoo-r1/include/asm-arm26/ioctls.h
/usr/src/linux-2.6.5-gentoo-r1/include/asm-h8300/ioctls.h
/usr/src/linux-2.6.5-gentoo-r1/include/asm-ppc64/ioctls.h
/usr/src/linux-2.6.5-gentoo-r1/include/asm-sparc/vfc_ioctls.h
/usr/src/linux-2.6.5-gentoo-r1/include/asm-sparc/ioctls.h
/usr/src/linux-2.6.5-gentoo-r1/include/asm-i386/ioctls.h
/usr/src/linux-2.6.5-gentoo-r1/include/asm-cris/ioctls.h
/usr/src/linux-2.6.5-gentoo-r1/include/asm-ia64/ioctls.h
/usr/src/linux-2.6.5-gentoo-r1/include/asm-m68k/ioctls.h
/usr/src/linux-2.6.5-gentoo-r1/include/asm-mips/ioctls.h
/usr/src/linux-2.6.5-gentoo-r1/include/asm-s390/ioctls.h
/usr/src/linux-2.6.5-gentoo-r1/include/asm-v850/ioctls.h
/usr/src/linux-2.6.5-gentoo-r1/include/asm-arm/ioctls.h
/usr/src/linux-2.6.5-gentoo-r1/include/asm-ppc/ioctls.h
/usr/src/linux-2.6.5-gentoo-r1/include/asm-sparc64/ioctls.h
/usr/include/asm/ioctls.h
/usr/include/bits/ioctls.h
/usr/include/openssl/tls1.h
/usr/portage/metadata/cache/dev-tcltk/tls-1.4.1
/usr/portage/metadata/cache/dev-tcltk/tls-1.5.0
/usr/portage/metadata/cache/app-crypt/qca-tls-1.0
/usr/portage/metadata/cache/net-libs/gnutls-1.0.4
/usr/portage/metadata/cache/net-libs/gnutls-0.8.10
/usr/portage/metadata/cache/net-libs/gnutls-0.8.12
/usr/portage/metadata/cache/net-misc/tlsproxyd-0.0.2
/usr/portage/metadata/cache/dev-java/puretls-0.94_beta4
/usr/portage/dev-tcltk/tls
/usr/portage/dev-tcltk/tls/Manifest
/usr/portage/dev-tcltk/tls/files
/usr/portage/dev-tcltk/tls/files/digest-tls-1.4.1
/usr/portage/dev-tcltk/tls/files/digest-tls-1.5.0
/usr/portage/dev-tcltk/tls/tls-1.5.0.ebuild
/usr/portage/dev-tcltk/tls/tls-1.4.1.ebuild
/usr/portage/dev-tcltk/tls/ChangeLog
/usr/portage/dev-tcltk/tls/metadata.xml
/usr/portage/app-crypt/qca-tls
/usr/portage/app-crypt/qca-tls/Manifest
/usr/portage/app-crypt/qca-tls/files
/usr/portage/app-crypt/qca-tls/files/digest-qca-tls-1.0
/usr/portage/app-crypt/qca-tls/ChangeLog
/usr/portage/app-crypt/qca-tls/qca-tls-1.0.ebuild
/usr/portage/mail-mta/qmail/files/1.03-r8/qmail-1.03-starttls-smtp-auth.patch
/usr/portage/mail-mta/qmail/files/1.03-r9/qmail-1.03-starttls-smtp-auth.patch
/usr/portage/mail-mta/qmail/files/1.03-r10/tls-patch.txt
/usr/portage/mail-mta/qmail/files/1.03-r10/tls.patch.bz2
/usr/portage/mail-mta/qmail/files/1.03-r14/auth-after-tls-only.patch
/usr/portage/mail-mta/qmail/files/1.03-r14/qmail-1.03-accept-5xx.tls.patch
/usr/portage/mail-mta/qmail/files/1.03-r14/qmail-pop3d-stat.tls.patch
/usr/portage/mail-mta/qmail/files/1.03-r14/nullenvsender-recipcount.tls.patch
/usr/portage/mail-mta/ssmtp/files/starttls.diff
/usr/portage/mail-mta/qmail-ldap/files/tls.patch.bz2
/usr/portage/mail-mta/qmail-ldap/files/1.03-r4/tls.patch.bz2
/usr/portage/sys-devel/gcc/files/3.2.1/gcc32-tls-reload-fix.patch
/usr/portage/sys-devel/binutils/files/2.13/binutils-2.13.90.0.16-stt_tls.patch
/usr/portage/sys-devel/binutils/files/2.13/binutils-2.13.90.0.16-tls-strip.patch
/usr/portage/sys-devel/binutils/files/2.13/binutils-2.13.90.0.18-ppc64-tls1.patc                              
h
/usr/portage/sys-devel/binutils/files/2.13/binutils-2.13.90.0.18-ppc64-tls2.patc                              
h
/usr/portage/sys-devel/binutils/files/2.14/binutils-2.14.90.0.7-tls-section-alig                              
nment.patch
/usr/portage/net-libs/libsoup/files/libsoup-1.99.26-gnutls_1.0.patch
/usr/portage/net-libs/loudmouth/files/loudmouth-0.15-gnutls_1.0.patch
/usr/portage/net-libs/gnutls
/usr/portage/net-libs/gnutls/gnutls-0.8.10.ebuild
/usr/portage/net-libs/gnutls/Manifest
/usr/portage/net-libs/gnutls/files
/usr/portage/net-libs/gnutls/files/digest-gnutls-0.8.10
/usr/portage/net-libs/gnutls/files/digest-gnutls-0.8.12
/usr/portage/net-libs/gnutls/files/digest-gnutls-1.0.4
/usr/portage/net-libs/gnutls/gnutls-0.8.12.ebuild
/usr/portage/net-libs/gnutls/ChangeLog
/usr/portage/net-libs/gnutls/gnutls-1.0.4.ebuild
/usr/portage/net-libs/gnutls/metadata.xml
/usr/portage/net-misc/tlsproxyd
/usr/portage/net-misc/tlsproxyd/Manifest
/usr/portage/net-misc/tlsproxyd/files
/usr/portage/net-misc/tlsproxyd/files/digest-tlsproxyd-0.0.2
/usr/portage/net-misc/tlsproxyd/tlsproxyd-0.0.2.ebuild
/usr/portage/net-misc/tlsproxyd/ChangeLog
/usr/portage/dev-java/puretls
/usr/portage/dev-java/puretls/Manifest
/usr/portage/dev-java/puretls/files
/usr/portage/dev-java/puretls/files/digest-puretls-0.94_beta4
/usr/portage/dev-java/puretls/puretls-0.94_beta4.ebuild
/usr/portage/dev-java/puretls/ChangeLog
/usr/portage/dev-java/puretls/metadata.xml
/usr/portage/licenses/puretls
/windowsxp/WINDOWS/srchasst/srchctls.dll
/windowsxp/WINDOWS/system32/mstlsapi.dll
/windowsxp/WINDOWS/system32/dllcache/ntlsapi.dll
/windowsxp/WINDOWS/system32/dllcache/mstlsapi.dll
/windowsxp/WINDOWS/system32/dllcache/srchctls.dll
/windowsxp/WINDOWS/system32/ntlsapi.dll
/windowsxp/WINDOWS/system32/rastls.dll
/windowsxp/WINDOWS/ServicePackFiles/i386/rastls.dll
what else could be laggying it up?
John5788 is offline   Reply With Quote
Old 06-08-04, 12:06 AM   #11
whig
550Ti
 
Join Date: Jan 2004
Location: New Zealand
Posts: 854
Default Re: Low FPS in Americas Army

Not tls then. See if you get this:
Code:
$ cat /proc/driver/nvidia/agp/status 
Status:          Enabled
Driver:          AGPGART
AGP Rate:        8x
Fast Writes:     Enabled
SBA:             Enabled
And I'm running out of ideas
whig is offline   Reply With Quote
Old 06-08-04, 08:34 AM   #12
John5788
Registered User
 
Join Date: May 2004
Posts: 9
Default Re: Low FPS in Americas Army

Code:
$  cat /proc/driver/nvidia/agp/*
Fast Writes:     Supported
SBA:             Supported
AGP Rates:       8x 4x 
Registers:       0x1f000e1b:0x1f000302
Host Bridge:     VIA Technologies, Inc. VT8374 P4X400 Host Controller/AGP Bridge
Fast Writes:     Not Supported
SBA:             Supported
AGP Rates:       8x 4x 
Registers:       0x1f000a0b:0x1f000b0a
Status:          Enabled
Driver:          AGPGART
AGP Rate:        8x
Fast Writes:     Disabled
SBA:             Enabled
i disabled fast writes on purpose, they dont make any difference for me, just system stability issues. how much FPS do you get in the first training level with the marksmanship stuff?
John5788 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
America's Army is really, really... malachi1313 Gaming Central 15 07-02-08 10:18 AM
My UT2003 Tweak Guide DXnfiniteFX Gaming Central 48 10-30-02 11:59 PM
UT2003 demo impressions Crake Gaming Central 241 09-28-02 07:37 AM
Americas Army sniper patch is out! malachi1313 Gaming Central 10 08-08-02 07:42 AM
low fps why??? nipster Benchmarking And Overclocking 4 08-07-02 02:35 PM

All times are GMT -5. The time now is 11:39 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.