Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-17-02, 09:24 PM   #1
aklayman
Guest
 
Posts: n/a
Question kernel install works, but GLX doesn't

hello all!

i've been fiddling with this for far too long and i'm at a big loss.

compiled the kernel module from the tarball just fine. Did a make from the GLX and that went off without a hitch as well

I startx, it flickers twice but i see the NVIDIA logo and i'm all excited! UT baby.

Except, whenever i try and run something that uses openGL, from XMMS plugins to Tuxracer to UT, i get the error that...

"Couldn't open required GL library /usr/X11R6/lib/libGL.so.1.2!"

typing "locate libGL" shows me /usr/X11R6/lib/libGLwrapper.so.0.1.6
/usr/X11R6/lib/libGL.so.1
/usr/X11R6/lib/libGLU.so.1
/usr/X11R6/lib/libGLU.so.1.3.403

Do i need to create a symbolic link or something here to make it find so.1.3.blah for so.1.2? I'm at a loss Any help you can give is greatly greatly incredibly appreciated

Incidentally, i have a Gforce 3, not 2 as it says to the left...maybe that's indicative of something?
  Reply With Quote
Old 10-18-02, 01:10 AM   #2
Andy Mecham
l33t master
 
Join Date: Jul 2002
Location: Santa Clara, CA
Posts: 1,163
Default

If the GLX package installed correctly, it should have moved the GL libraries in /usr/X11R6/lib aside, and copied libGL.so.1.0.3123 and friends into /usr/lib. Are there any libGL.* files in /usr/lib? If not, can you do a make install in the GLX directory again as root?

--andy
__________________
Andy Mecham
NVIDIA Corporation
Andy Mecham is offline   Reply With Quote
Old 10-18-02, 01:30 AM   #3
aklayman
Guest
 
Posts: n/a
Default

Quote:
Originally posted by Andy Mecham
If the GLX package installed correctly, it should have moved the GL libraries in /usr/X11R6/lib aside, and copied libGL.so.1.0.3123 and friends into /usr/lib. Are there any libGL.* files in /usr/lib? If not, can you do a make install in the GLX directory again as root?

--andy
Yes, there's a libGL.1.0.3123 right there, and all his closest buddies .

when i try and run an openGL program (like tuxracer), it crashes out saying that it needs .so.1.2
  Reply With Quote
Old 10-18-02, 06:42 AM   #4
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Either recompile the programs that are hardcoded to look in /usr/X11R6/lib, or just symlink it like you were saying.

If you go the symlink route, run /sbin/ldconfig as root afterward.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 10-18-02, 06:18 PM   #5
aklayman
Guest
 
Posts: n/a
Default

Worked like a charm, thanks

thank you all for your help!
  Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
[BUG] nvidia crashes kernel with 'Xid 13' and attempted to yield the CPU while atomic rockob NVIDIA Linux 36 09-26-12 07:48 AM
upgrade to xorg server 1.13 damaged Geforce 7300 GT KDE NVIDIA Linux 2 09-07-12 08:04 AM
Fatal upgrade: from bad (8800 GTS) to worse 9GTX 560 Ti) ssnyder NVIDIA Linux 1 07-01-12 08:14 PM
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 04:51 AM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM

All times are GMT -5. The time now is 12:13 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.