Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-17-04, 09:19 PM   #1
Biocorporation
Treadstone
 
Join Date: Jun 2004
Posts: 7
Default 2.6.7 kernel and driver trouble

I seem to be having trouble with 2.6.7 and the lastest nvidia driver.
I used my old config from my 2.6.6 kernel and did a make oldconfig all all went find.
Rebooted installed driver run startx and the computer froze. So I recompiled with 4KB stacks, with the same result.
I then got the sources again from kernel.org. I also tried compiling with agpgart and without (using 8kb stacks).
All of these fails.

Any ideas ? Remember that I am using 2.6.6 now and its fine.

Regards

Biocorporation
Biocorporation is offline   Reply With Quote
Old 06-17-04, 10:41 PM   #2
LordMorgul
Electrical Engineer
 
LordMorgul's Avatar
 
Join Date: Dec 2002
Location: San Luis Obispo, CA
Posts: 872
Default Re: 2.6.7 kernel and driver trouble

Do not use 4Kb stacks or Register Parameters. If you use the minion.de patches you may be able to use Register Parameters.. maybe not.
__________________
"..the triumph of evil is for good men to do nothing." (Edmond Burke)
nVIDIA video driver RPMs for Fedora :: see yum repo at livna.org.
LordMorgul is offline   Reply With Quote
Old 06-18-04, 01:09 AM   #3
Biocorporation
Treadstone
 
Join Date: Jun 2004
Posts: 7
Default Re: 2.6.7 kernel and driver trouble

Quote:
Originally Posted by LordMorgul
Do not use 4Kb stacks or Register Parameters. If you use the minion.de patches you may be able to use Register Parameters.. maybe not.
Well I sure am not using 4KB stacks, as said above. What are Register Parameters ?? I dont know what they are.

Thanks for the reply.

Biocorporation
Biocorporation is offline   Reply With Quote
Old 06-18-04, 02:14 AM   #4
nomego
Registered User
 
Join Date: Jun 2004
Posts: 1
Default Re: 2.6.7 kernel and driver trouble

I have a problem with any kernel newer than 2.6.5.

Don't have CONFIG_4KSTACKS or CONFIG_REGPARM set.

The kernel doesn't completely panic, but the graphics are blanked.
I can post the output of dmesg later today.

Video card: GeForce4 MX 440
Driver versions tested: 5238 (with minion.de via-patch), 5336, 5341
Distribution: Gentoo
Video BIOS revision: 04.18.20.07.00
Processor: Athlon-XP 1600+
0000:00:01.0 PCI bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333 AGP]

Last edited by nomego; 06-18-04 at 02:24 AM.
nomego is offline   Reply With Quote
Old 06-18-04, 05:11 AM   #5
Biocorporation
Treadstone
 
Join Date: Jun 2004
Posts: 7
Default Re: 2.6.7 kernel and driver trouble

Quote:
Originally Posted by nomego
I have a problem with any kernel newer than 2.6.5.
Don't have CONFIG_4KSTACKS or CONFIG_REGPARM set.
I dont have either of those options set. As I said, I have it working fine in 2.6.6 but something has changed in 2.6.7, I am almost totally sure, as I am using the same config (run via oldconfig)

Biocorporation
Biocorporation is offline   Reply With Quote
Old 06-18-04, 02:25 PM   #6
onyxsoft
Registered User
 
Join Date: Mar 2004
Posts: 9
Default Re: 2.6.7 kernel and driver trouble

What version nvidia drivers are you using? Which video card?

I am using 5336 with kernel 2.6.7 with no problems. Using a 4200ti (or was it a 5200FX Ultra). I forget which one is in that machine. When I did a make oldconfig, I answered the 4K Stacks question with N. I also disabled CONFIG_REGPARM.
onyxsoft is offline   Reply With Quote
Old 06-18-04, 04:09 PM   #7
Subdino
Registered User
 
Join Date: Mar 2004
Location: France
Posts: 1
Default Re: 2.6.7 kernel and driver trouble

I'm not sure resister args are the problem... I'm runing a 2.6.6 using them, and my 5336 runs fine. But I also have a porblem with 2.6.7 from kernel.org : the screen shows some random & incorrect lines, the keyboard responds (numock,...) but the screen doesn't reacts (haven't tried to blind type a soft reboot).
Subdino is offline   Reply With Quote
Old 06-18-04, 11:36 PM   #8
Biocorporation
Treadstone
 
Join Date: Jun 2004
Posts: 7
Default Re: 2.6.7 kernel and driver trouble

Quote:
Originally Posted by onyxsoft
What version nvidia drivers are you using? Which video card?
I am using the x86-1.0-5336-pkg driver with a GF FX5600, I again just checked my config i have both 4KB stacks and CONFIG_REGPARM DISABLED

I am really lost on this one, might just see what 2.6.8 can bring !

Biocorporation
Biocorporation is offline   Reply With Quote

Old 06-19-04, 12:12 PM   #9
uberpenguin
BISCUIT HAMMER
 
Join Date: Apr 2003
Location: Georgia, USA
Posts: 18
Send a message via AIM to uberpenguin Send a message via Yahoo to uberpenguin
Default Re: 2.6.7 kernel and driver trouble

Quote:
Originally Posted by Biocorporation
Any ideas ? Remember that I am using 2.6.6 now and its fine.
Not sure if my problem is related or not, but the latest version of the NVIDIA drivers + any 2.6 kernel is incredibly unstable for me; my system will hard lock usually every 2 or 3 hours. I've always had this sort of hard-locking problem, but with the old drivers it was confined to about once a month.

-uberpenguin
uberpenguin is offline   Reply With Quote
Old 06-19-04, 07:43 PM   #10
RLNave
Registered User
 
Join Date: Mar 2004
Posts: 22
Default Re: 2.6.7 kernel and driver trouble

I recently built the 2.6.7 kernel with the 4K_STACK and REG_PARAM option set to n. I got a clean build and am now running with the nvidia driver. Of course my card is an older TNT2. Perhaps the newer cards do not work as well.

I
RLNave is offline   Reply With Quote
Old 06-19-04, 07:45 PM   #11
RLNave
Registered User
 
Join Date: Mar 2004
Posts: 22
Default Re: 2.6.7 kernel and driver trouble

I recently built the 2.6.7 kernel with the 4K_STACK and REG_PARAM option set to n. I got a clean build and am now running with the nvidia driver. Of course my card is an older TNT2. Perhaps the newer cards do not work as well.

I am running Fedora Core 2 with all updates released to date.
However, I have substituted a kernel built from source from www.kernel.org
RLNave is offline   Reply With Quote
Old 06-20-04, 07:28 PM   #12
Toril
Registered User
 
Join Date: Dec 2003
Location: Syracuse, NY
Posts: 14
Default Re: 2.6.7 kernel and driver trouble

I too am having similar problems. I recently upgraded UT2004 to the latest patches (even the new 3236.1 that just came out today) and it crashes immidiately. Notice, I can use X just fine, but the minute I change modes it locks the entire machine up. I had to turn off my xscreensaver as well. If I even so much as preview the "busyspheres" rss_glx screensaver, it locks up in a matter of seconds. I am not using 4k stacks or CONFIG_REGPARM in the kernel. I think the recent DOS exploit patch has a direct, adverse effect on the 5336 drivers. The oddest thing too, I recently upgraded to Slackware 10rc1 (from a "current" snapshot of May 25th, 2004) and it worked once flawlessly, enough for me to try it and exit (UT2004 that is). Now it locks up immidiately upon changing screenmodes... (my norm desktop is 1280x1024, it switches to 1024x768 for the game).

The last time it worked I was on that May 25th current snapshot, and kernel 2.6.6 with the DOS vulnerability... now it no longer works in either a patched 2.6.6 or 2.6.7
__________________
Athlon XP 2400+ / ECS K7S5A & Honeyx Bios / Nvidia GeForce3 Ti500 / 768 meg RAM / 220 gigs HD / Dual Boot XP Pro & modified Slackware Linux 10 with 2.6.xx kernel

Last edited by Toril; 06-21-04 at 02:42 PM.
Toril is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mageia 2 Cannot Install 71.86.15 for Riva TNT/TNT2 kbulgrien NVIDIA Linux 3 06-29-12 08:27 AM
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 04:51 AM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
Lucid rt kernel can't load latest nvidia driver module, but generic does. marcod NVIDIA Linux 0 05-02-12 06:23 AM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM

All times are GMT -5. The time now is 11:54 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.