Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-29-04, 12:11 PM   #1
asinkecualo
Registered User
 
Join Date: Jun 2004
Posts: 3
Exclamation NVIDIA driver not loading

Hi,

I've installed latest kernel-2.6.7-2mdk. I'm trying compiling latest NVIDIA driver (from NVIDIA: NVIDIA-Linux-x86-1.0-5336-pkg1.run) against this kernel and I get an error message like this:

Code:
-> Kernel module compilation complete.
ERROR: Unable to load the kernel module 'nvidia.ko'.  This is most likely
       because the kernel module was built using the wrong kernel source files.
       Please make sure you have installed the kernel source files for your
       kernel; on Red Hat Linux systems, for example, be sure you have the
       'kernel-source' rpm installed.  If you know the correct kernel source
       files are installed, you may specify the kernel source path with the
       '--kernel-source-path' commandline option.
-> Kernel module load error: insmod: error inserting './usr/src/nv/nvidia.ko':
   -1 Invalid module format
I've installed the right source package. The module is correctly compiled, but the error is when trying to insert the module:

Code:
# modprobe nvidia
FATAL: Error inserting nvidia (/lib/modules/2.6.7-2mdk/kernel/drivers/video/nvidia.ko): Invalid module format
This problem is happening in all kernels from 2.6.5 I've tried.

Anyone more has this problem?
asinkecualo is offline   Reply With Quote
Old 06-29-04, 03:47 PM   #2
asinkecualo
Registered User
 
Join Date: Jun 2004
Posts: 3
Default Re: NVIDIA driver not loading

OK, everything is corrected now.

If you use a precompiled kernel, be sure you're compiling NVIDIA module with the same compiler kernel was. I explain. If the kernel was compiled using gcc-3.4 you must use gcc-3.4 to compile the module.

You can check if this is your situation looking at the last line of dmesg when trying to load module.
asinkecualo is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-02-02 12:58 AM
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 02:44 PM
Error messages... HELP!!!! Imperito NVIDIA Linux 3 09-24-02 11:46 PM
GForce drivers installed...but dont work tomfullery NVIDIA Linux 6 09-22-02 09:23 AM
Need help to get the X to work on my Acer TravelMate 630 knchee NVIDIA Linux 16 09-19-02 11:16 PM

All times are GMT -5. The time now is 02:34 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.