Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-30-04, 04:22 AM   #1
kwisatz
Registered User
 
Join Date: Jun 2004
Posts: 6
Question OpenGL freezes/lags every 4 seconds

Hi folks,

I'm using Fedora Core 2 on a DELL Inspiron 8600 containing a Geforce FX5650 graphics card.
Using Nvidia Driver 5336 and a self-compiled 2.6.7 kernel.

Now I don't have any problems running X with the nvidia driver, but every opengl application (ut2004, xscreensaver) freezes for half a second every 4 seconds. I do also have very low framerates.

Any ideas?

Attached my xorg.conf
Attached Files
File Type: txt xorg.conf.txt (5.1 KB, 108 views)
kwisatz is offline   Reply With Quote
Old 06-30-04, 06:57 AM   #2
andyrock
Registered User
 
andyrock's Avatar
 
Join Date: Jan 2004
Location: EU / Portugal
Posts: 110
Default Re: OpenGL freezes/lags every 4 seconds

Are you experienced in kernel compiling?

Perhaps you should try first 8k kernel from linuxant.

http://www.linuxant.com/driverloader...ernel-i686.php
__________________
AndyRock

--
1. Toshiba M30-742 | Centrino/Pentium-M 1700mhz | Geforce FX 5200Go
2. Celeron (Tualatin) 1400mhz | Geforce Ti 4800SE
andyrock is offline   Reply With Quote
Old 06-30-04, 08:06 AM   #3
kwisatz
Registered User
 
Join Date: Jun 2004
Posts: 6
Default Re: OpenGL freezes/lags every 4 seconds

I guess I'm experienced enough at kernel compiling, everything works fine.
The linuxant kernel doesn't fit my needs, but if you could tell me where exactly to seek for it, I could check if everything is right.
Would you perhabs like to see the appropriate part of my .config?
kwisatz is offline   Reply With Quote
Old 06-30-04, 09:38 AM   #4
arokh
Registered User
 
arokh's Avatar
 
Join Date: Jun 2004
Posts: 287
Default Re: OpenGL freezes/lags every 4 seconds

Sounds like AGP trouble to me, I wouldn't bother messing with the kernel if the one you're using is working fine. Any errors in dmesg? Have you tried using NvAGP?

If you'd like to try linuxant's fedora kernel anyways it's in my sig.
__________________
Asus A8N32-SLI : AMD64 3700+ @ 2.85GHz : 2GB PC4000 OCZ Platinum EB : 2x 7800GT SLI
arokh is offline   Reply With Quote
Old 06-30-04, 09:59 AM   #5
kwisatz
Registered User
 
Join Date: Jun 2004
Posts: 6
Default Re: OpenGL freezes/lags every 4 seconds

Hmm, just started an uut2004 session and it did all fine, no lags.

A friend of mine told me to add

Quote:
Option "RenderAccel" "1"
to my xorg.conf, maybe that solved it?
What is NvAGP by the way?
kwisatz is offline   Reply With Quote
Old 07-01-04, 12:23 AM   #6
sehh
GFX 5600 VideoSuite
 
Join Date: Oct 2002
Posts: 60
Default Re: OpenGL freezes/lags every 4 seconds

WOOHOO

i've been having this problem for YEARS!!

opengl apps would have a slight pause every few seconds.

i added the RenderAccel option and that fixed it!!

thanks man!!
sehh is offline   Reply With Quote
Old 07-01-04, 02:19 AM   #7
kwisatz
Registered User
 
Join Date: Jun 2004
Posts: 6
Default Re: OpenGL freezes/lags every 4 seconds

I think we're only too lazy to work us through the documentation. I'm sure this would have been described in a Howto or maybe even in the nvidia documentation.
kwisatz is offline   Reply With Quote
Old 07-01-04, 03:06 AM   #8
sehh
GFX 5600 VideoSuite
 
Join Date: Oct 2002
Posts: 60
Default Re: OpenGL freezes/lags every 4 seconds

Unfortunately no. The documentation has very little on this parameter and it doesn't realy
explain what the render module is about and why we may need to enable hardware
acceleration of it.

This problem doesn't seen to affect many people, but in the few systems that affect me
i managed to fix them with that simple line in the config.
sehh is offline   Reply With Quote

Old 07-01-04, 03:14 AM   #9
kwisatz
Registered User
 
Join Date: Jun 2004
Posts: 6
Default Re: OpenGL freezes/lags every 4 seconds

Yeah, the nvidia documentation only says that it's EXPERIMENTAL... but who cares, if it works for us
kwisatz is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenGL book Airstrip1 Software Development 2 08-12-12 08:55 AM
Major WineX prob... I think it has to do with the vidcard... Linewbie NVIDIA Linux 20 10-09-02 09:58 PM
Multiple OpenGL applications and NVidia gbrauer NVIDIA Linux 7 09-01-02 04:47 PM
Refresh rate fix for opengl? Zarich NVIDIA Windows Graphics Drivers 1 08-29-02 02:47 PM
Slow OpenGL on 7.3 kl899 NVIDIA Linux 1 08-04-02 07:58 PM

All times are GMT -5. The time now is 09:49 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.