Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-01-04, 06:28 AM   #37
xzcvczx
Registered User
 
Join Date: Jul 2004
Posts: 1
Default Re: 1.0-6106 for X86-32 thread

does anyone know why they stopped 1024x768 being used as a mode for tv

i use to use it quite happily and it was only for displaying movies anyway

anyone know if it will be readded or fixed or something as i dont like having one monitor @ 1024 and one at 800x600
xzcvczx is offline   Reply With Quote
Old 07-01-04, 07:30 AM   #38
merlin42
Registered User
 
Join Date: Sep 2002
Posts: 52
Default Re: 1.0-6106 for X86-32 thread

Quote:
Originally Posted by _tf_
can you tell what to do to get these glsl demos running?

thanks!
lars
The main thing was to make sure I had the latest glext.h and to translate
wglGetProcAddress to glXGetProcAddressARB
I only messed with the ogl2brick sample program, please note my version broke the cube so once it starts you have to hit 't' to change to a different model.

I have attached my modified source to this message.
Quote:
Originally Posted by dulley
GLSL DEMOS???

Where can I get them?
You can get the original samples (and a whole lot more) from:
http://developer.3dlabs.com/openGL2/downloads/index.htm
Attached Files
File Type: zip brick.zip (10.6 KB, 277 views)
merlin42 is offline   Reply With Quote
Old 07-01-04, 08:02 AM   #39
Silencer_scg
Registered User
 
Join Date: Jun 2004
Posts: 1
Default Re: 1.0-6106 for X86-32 thread

Well nice work nvidia with new drivers and control paner.
But I need again to use 2.6.6 kernel.
In 2.6.7 X crash with new drivers. I'm using MSI Geforce 4 mx440 64mb with twinview CRT,CRT.
I think there is a problem with DVI Connector and drivers in kernel 2.6.7 or it is a kernel problems. Also I'm now using 4ksatck kernel wohooooo
Silencer_scg is offline   Reply With Quote
Old 07-01-04, 08:22 AM   #40
SuLinUX
 
SuLinUX's Avatar
 
Join Date: Sep 2003
Location: UK
Posts: 847
Default Re: 1.0-6106 for X86-32 thread

Quote:
Originally Posted by catimimi


Great Job, everything works fine, text console are no longer broken !!

framebuffer works fine, nvidia-settings are great !!

Thanks to Nvidia.

SuSE 9.1, kernel 2.6.7-bk11
GeForce 5900

Michel

How did you get the kernel 2.6.7 to work with SuSE9.1 because it only mounts my drive as readonly. 2.6.x_proper worked fine in SuSE 9.0, any ideas?
__________________
AthlonXP 2600+ / nForce2 Asus A7N8X-X / PNY GeForce FX5900 Ultra / 1024Mb Samsung Ram /nForce Sound / Hansol 920D Plus 19" monitor / Lite-On 32x12x40 / 2x Maxtor HD 40Gb/80Gb / nVidia 7174 driver / Gnome 2.10.1 / Kernel 2.6.11.9 / Slackware 10.0
SuLinUX is offline   Reply With Quote
Old 07-01-04, 08:49 AM   #41
jnygaard
Registered User
 
Join Date: Feb 2004
Location: Oslo, Norway
Posts: 5
Default Re: 1.0-6106 for X86-32 thread

So, my big, remaining, burning question... Is there emulation of NV40-stuff in there? (Actually, I only need emulation of that which is in NV40 and not in the fx5900 I have in my machine...)

Oh, yes, btw., it works. kernel 2.6.7-bk13 compiled with gcc 3.4.0, the Nvidia driver also with gcc 3.4.0. Doesn't seem any faster, or better, though. But the new extensions, OGSL and 6800 support is what counts, I guess...
jnygaard is offline   Reply With Quote
Old 07-01-04, 08:56 AM   #42
merlin42
Registered User
 
Join Date: Sep 2002
Posts: 52
Default Re: 1.0-6106 for X86-32 thread

Quote:
Originally Posted by jnygaard
So, my big, remaining, burning question... Is there emulation of NV40-stuff in there? (Actually, I only need emulation of that which is in NV40 and not in the fx5900 I have in my machine...)
A quick experiment says no:

$ strings /usr/lib/libGL.so | grep -i __GL
__GL_TEX_MEMORY_SPACE_ENABLES
__GL_LOG_MAX_ANISO
__GL_FORCE_GENERIC_CPU
__GL_SW_RENDERER
__GL_NV20_EMULATE
__GL_NV25_EMULATE
__GL_NV30_EMULATE
__GL_SYNC_DISPLAY_DEVICE
__GL_FSAA_MODE
__GL_SYNC_TO_VBLANK
__GL_FORCE_DIRECT
__GL_SINGLE_THREADED
variable __GL_SINGLE_THREADED to 1. For more information
merlin42 is offline   Reply With Quote
Old 07-01-04, 09:05 AM   #43
ripperda
NVIDIA Corporation
 
Join Date: Sep 2002
Posts: 24
Default Re: 1.0-6106 for X86-32 thread

Quote:
Originally Posted by Silencer_scg
Well nice work nvidia with new drivers and control paner.
But I need again to use 2.6.6 kernel.
In 2.6.7 X crash with new drivers. I'm using MSI Geforce 4 mx440 64mb with twinview CRT,CRT.
I think there is a problem with DVI Connector and drivers in kernel 2.6.7 or it is a kernel problems. Also I'm now using 4ksatck kernel wohooooo
when it crashes, is the system usable or locked up? can you send a bug report script to linux-bugs@nvidia.com? also, make sure you're not using USB 2.0 with 2.6.7 w/ the new drivers. there appears to be a problem with the USB 2.0 driver not handling interrupts and the kernel disables that interrupt. if the USB hub shares an interrupt with our driver, disabling this shared interrupt will hang our driver.
ripperda is offline   Reply With Quote
Old 07-01-04, 10:16 AM   #44
catimimi
Registered User
 
Join Date: Jan 2004
Posts: 52
Default Re: 1.0-6106 for X86-32 thread

Hi all,

First, I managed to get TVout working with this driver, it seems that now TVout is limited to 800x600. If i use this resolution, everything is OK, if I choose 1024x768 X won't start and the console freezes.

Why this regression? Will it be possible to use again 1024x768?

Second, I'd some problem to use kernel 2.6.7 not with SuSE 9.1, but with my hardware.

I've only SCSI drives, the domain validation was rewritten and fails with one of my devices ( the boot disk !!!). I'd to modify the scsi driver in order to get everything working. I didn't meet other problems. Please describe yours, and I can try to help you but perhaps not on this forum if it doesn't concern Nvidia.

again to Nvidia.

Michel.
catimimi is offline   Reply With Quote

Old 07-01-04, 10:20 AM   #45
HarshReality
Registered User
 
Join Date: Jun 2004
Posts: 12
Default Re: 1.0-6106 for X86-32 thread

Just out of curiosity (I am after all green here) I am running FC2 and my compliments go out to NV for the 6106 drivers, they work like a dream.

I wonder what all (I have seen them scattered but dont have a complete list) of options are actually avail. to be used in the Xconfig. I know some wont work on my system but wouldn't mind the complete list all the same. (cant help but wonder if I could get htis sucker to use split wallpapers and the like).

Anyway, here is what I have so far:

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "MSI"
BoardName "NVIDIA GeForce 4 (generic)"
Option "TwinView" "on"
Option "TwinViewOrientation" "RightOf"
Option "MetaModes" "1152x864,1280x960"
Option "ConnectedMonitor" "crt,crt"
Option "NoLogo" "off"
Option "NvAGP" "on"
Option "RenderAccel" "true"
Option "WindowFlip" "false"
Option "Xinerama" "on"

So the question is, what other goodies can I fit in here (the temp thing was one I wouldnt mind at all)
HarshReality is offline   Reply With Quote
Old 07-01-04, 10:22 AM   #46
ripperda
NVIDIA Corporation
 
Join Date: Sep 2002
Posts: 24
Default Re: 1.0-6106 for X86-32 thread

Quote:
Originally Posted by HarshReality
So the question is, what other goodies can I fit in here (the temp thing was one I wouldnt mind at all)
please read the documentation. check /usr/share/doc/README and search for "APPENDIX D: X CONFIG OPTIONS"
ripperda is offline   Reply With Quote
Old 07-01-04, 10:23 AM   #47
freelsjd
Registered User
 
Join Date: Feb 2003
Posts: 73
Default Re: 1.0-6106 for X86-32 thread

How do you get that control panel thing up and running ? I have the driver installed and working great.
__________________
J D Freels
freelsjd is offline   Reply With Quote
Old 07-01-04, 11:03 AM   #48
tru_playaz
Registered User
 
Join Date: Dec 2002
Posts: 12
Default Re: 1.0-6106 for X86-32 thread

Quote:
Originally Posted by freelsjd
How do you get that control panel thing up and running ? I have the driver installed and working great.
The command 'nvidia-settings' should bring it up (just tie an icon to it)

The options you find depend on your cards features.
__________________
bounce-gaming.net
tru_playaz is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:06 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.