Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-21-02, 11:22 PM   #1
FishTech
Registered User
 
Join Date: Oct 2002
Posts: 38
Default How do you exit the X server? What is the X server? Please explain this.

Hi All!... First off thanks to everyone that has been helping me... I have a couple of posts floating around that I never got back to... Sorry, but thanks to you, all my questions have been answered, and I thought I'd lower the traffic a little by just starting a new tread... Thanks Everyone for Your Help!

Ok, I now have the correct RPM files and I'm getting ready to install them, and I was wondering if You could explain to me (in baby talk) what is the X server and how to do what is mentioned in the quote below that came from the install readme?

"BEFORE YOU BEGIN DRIVER INSTALLATION

Before beginning the driver installation, you should exit the X server.
In addition you should set your default run level so you will boot to
console and not start up X (please consult the documentation that came
with your Linux distribution if you are unsure how to do this). This will
make it easier to recover if there is a problem during the installation."

Thanks and Love You!
FishTech
__________________
BIBLICAL REVELATIONS
FishTech is offline   Reply With Quote
Old 10-22-02, 08:20 AM   #2
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

The X server is the program that your GUI programs talk to to get their graphical stuff onto your screen. It listens on either a network port, a Unix domain socket (a.k.a. a special file), or both, for requests in some special form. This is why it's referred to as a server -- it acts just like Apache, listening on a port and responding to requests. When a request is made, for example, to draw a line on the screen, the X server program draws the line (subject to some clipping stuff) on whatever graphical console it's using at the time.

When you log out from your menu, do you go back to a text screen, or a graphical one? If a text screen, then just log out, that kills off the X server. But make the default runlevel change first, as it's easier to use GUI editors.

If you go back to a graphics login screen, then you'll have to (again, make the default runlevel change first, but then) either reboot or /sbin/init 3 to exit out of X.

As for the runlevel change, open up your /etc/inittab file in some sort of editor. The first non-comment line should look something like id:5:initdefault: if you boot right to GUI mode. Change it to id:3:initdefault: -- there should be some comments in the file around that line that explain what the different numbers do.

Once you set it to 3 (and save and exit, obviously ), when you reboot next, you'll come up to a text-mode login screen. Just log in like normal. You can get at a GUI by doing a startx (if, for example, you have forgotten the instructions or whatever). Anyway, do the driver installation and file editing and whatnot, and try to startx. If it works, change that line in /etc/inittab back to id:5:initdefault:
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 10-22-02, 09:40 AM   #3
FishTech
Registered User
 
Join Date: Oct 2002
Posts: 38
Default

bwkaz,

Thanks for explaining that to me... I made a copy of it for future reference!

Ok, now could you please tell me how to get to the "/etc/innitab file"? so I can make the changes that you instructed me to make... I did a search for it but couldn't find it?
__________________
BIBLICAL REVELATIONS
FishTech is offline   Reply With Quote
Old 10-22-02, 12:19 PM   #4
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Well, there are about a million and a half different editors you could use. I like gvim, but that's because I've gotten used to the way it works -- in any case, I'll work off the assumption you'll be using it.

The file is named inittab (one n, two t's), and it should be in your /etc directory. The easiest (at least for me) way to pull it up would be to open a terminal emulator, su - to root, and gvim /etc/inittab. The gvim window should pop up, unless you don't have gvim installed. Some text should be in the gvim window; if not, you may have misspelled the filename. You can go to File -> Open and browse for it if you want. Hit the 'i' key to get into insert mode, and make the appropriate changes (5 -> 3 or whatever). When you're done, go to File -> Save and Exit. Then, still as root, make sure the file's syntax is OK by trying an /sbin/init 3 -- X should exit and you should be at a text login prompt. Log in (as your normal user) and startx to get a GUI back. Next time you reboot, you'll end up at the same text login screen. Oh, /sbin/init 6 also reboots, which would be good to know, since you might need to do that while outside X. Anyway, install the drivers as per the README or the thread you're using, either which way. Then make the changes to /etc/X11/XF86Config (if you're using RedHat 8) or /etc/X11/XF86Config-4 (if you aren't), and try to startx. If it works, then open up /etc/inittab and do the same thing, but change the 3 back to a 5. Next time you reboot, you'll be back at your graphical login screen.

If you have problems, post the error messages, and if they're problems when starting X, post your /var/log/XFree86.0.log file. You can copy it to a floppy, or a Windows partition (if it's FAT32), or even burn it to a CD if you want to go that route. Or, you could even use a text-mode Web browser (lynx, links, and w3c are the ones I know of) to post the file here without having to boot to another OS.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 10-22-02, 03:54 PM   #5
FishTech
Registered User
 
Join Date: Oct 2002
Posts: 38
Default

bwkaz,

I edited the file (I had to use kate instead of gvin-I'm using Mandrake 9.0) and the machine now works the way that you described... Thanks.

I tried to install the rpms: first I tried to install the Kernel and the machine said something like: ################[100%] so I thought it installed... Did it install?

Then I tried to install the GLX and the machine said: error: failed dependencies NVIDIA_kernel is needed... Any ideas?...

I did use the NVchooser and checked the Sums and they are right... Did I miss something?
__________________
BIBLICAL REVELATIONS
FishTech is offline   Reply With Quote
Old 10-22-02, 05:46 PM   #6
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

It should have installed if it went all the way up to 100%... unless it printed other errors after that line or something. Does /sbin/modprobe NVdriver give any errors? -- other than "module will taint kernel", that's harmless. If not (and only if not), you can try to force-install the GLX package with rpm --nodeps --force NVIDIA_GLX......

Normally, forcing isn't a good idea, but in this case, if you can modprobe NVdriver, then it doesn't really matter.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 10-22-02, 11:45 PM   #7
FishTech
Registered User
 
Join Date: Oct 2002
Posts: 38
Default

I tried /sbin/modprobe NVdriver and I received: "modprobe: can't locate module NVdriver"

I reinstalled NVIDIA_kernel and I get ####################### [100%] I try probe again and get: "modprobe: can't locate module NVdriver"

I double check with NVchooser and make sure I have the recommended files, and I do... I check the md5sums and they're right...

I tried to use the package installer in KDE to install GLX and get: error: failed dependencies NVIDIA_kernel is needed... So what do You think?
__________________
BIBLICAL REVELATIONS
FishTech is offline   Reply With Quote
Old 10-23-02, 07:31 AM   #8
Klaus-P
Registered User
 
Join Date: Aug 2002
Location: Germany
Posts: 134
Default

In the install README read the paragraph "Installing/Upgrading by SRPM". It seems you have
downloaded the xxx.src.rpm packages. They do not contain the NVdriver. This 'beast' has to
be compiled on your computer before it can be installed. Maybe you should think about downloading
the xxx.rpm packages for Mandrake 9.0 with precompiled NVdriver. Maybe they are not available
on the server since Mandrake 9.0 is very new. Then you have to wait or to compile.
Klaus-P is offline   Reply With Quote

Old 10-23-02, 08:36 AM   #9
FishTech
Registered User
 
Join Date: Oct 2002
Posts: 38
Default

Thanks Klaus-P,

I'll check it out.

Also, could someone please tell me if it's ok to download the Nvidia Drivers that I need to a Win98 system and then burn them to a disk and migrate them to a Linux system?... Does it mess up the integrity of the Linux files?
__________________
BIBLICAL REVELATIONS
FishTech is offline   Reply With Quote
Old 10-23-02, 11:53 AM   #10
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

It shouldn't hurt to download in Windows, but to make sure, you can copy down the md5sums off the driver page, and then once you're in Linux, you can verify them. Run md5sum /path/to/wherever/the/files/are/NVIDIA* and you'll get a hash of the contents of the files you downloaded. If this output matches the md5sum posted on nVidia's page, then the files haven't been changed (or at least, the probability they have is about one in a few trillion, or something on that order of magnitude).
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 10-23-02, 03:18 PM   #11
FishTech
Registered User
 
Join Date: Oct 2002
Posts: 38
Default

Hi bwkaz,

I checked the md5sums and they check out... So I guess it's ok.

I am now trying to install the drivers with the tar files... I tried them a couple of times and I think I do pretty good until I try to edit the config file with emacs I wipe out... Here are the intructions that I am and using...

By: "elsenator
Geforce 2

Registered: Oct 2002
Location:
Posts: 1

Red Hat 8 and Geforce 4 Ti HOW-TO!!! Easy to understand
Finally, after fiddling around with the src RPMs for a few days with no luck what so ever, I tried to use the tarballs from NVIDIA's page instead... And, to my surprise it all worked smoothly and I'm now running UT2003 on my Geforce 4 Ti4600 with no problems at all!!! Wanna do this too?

------------ READ ------------
First of all, I want to point out that I got it to work after making a clean install of Red Hat 8 workstation with the Development Tools and Kernel Development packages added manually(by telling the installer that I wanted to change the packages it had chosen for me with the workstation list). I'm not sure whether the these packages actually had to be added, but it makes sence since we are going to compile the kernel and GLX module for your particular setup... I think...

Anyways, if you already did make a clean install and the development packages mentioned above haven't been installed you can always add them by clicking
Menu > System Settings > Packages
And then checking the Development Tools and Kernel development packages(I don't know if the kernel development package is needed, but who cares)

ok, here is what I did, step by step:
1. First make sure you have the above mentioned stuff up and running
2. Go to NVIDIA's homepage and under Drivers for Linux download the to driver source tarballs:
NVIDIA_GLX-1.0-3123.tar.gz
NVIDIA_kernel-1.0-3123.tar.gz
3. Now exit Gnome/Kde
4. Go to the directory where you downloaded the tarballz (the tar.gz files)
5. Type "tar xvzf NVIDIA_kernel-1.0-3123.tar.gz" without the quotes (d'oh)
6. Type "tar xvzf NVIDIA_GLX-1.0-3123.tar.gz" also without the quotes (d'oooooh)
7. Now type "cd NVIDIA_kernel-1.0-3123"
8. Type "make install"
9. Type "cd ../NVIDIA_GLX-1.0-3123"
10. Type "make install"

11 Tadaaa!! Now the driver is installed, and all we need to do is modify the Xfree86 config file

Here's how it's done...
1. Type "/etc/X11"
2. Type "emacs XF86Config" (the emacs editor will then start)
3. Find the line that says "Load "dri" and remove it.
4. Find the place where either "vesa" og "nv" is listed under your Geforce 4 card and change it to "nvidia"

And there we are... Type "startx" and you should be up and running with full OpenGL support.

If I missed something, please let me know, so I can correct it... I hope this "guide" will be of some use to some of you... Oh, and this should work with other Geforce cards too! I just wrote this since I couldn't use the other guide from this forum...

Fare thee well! And happy fraggin' or whatever ya wanna do..."

Could You give me more detailed information on how to edit the config file with emacs? or give me anyother tips?
__________________
BIBLICAL REVELATIONS
FishTech is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to set up a safe and secure Web server News Archived News Items 0 11-27-12 10:51 PM
First look: Windows Server 2012 brings the cloud down to earth News Archived News Items 0 09-04-12 04:50 PM
Windows Home Server is dead, but we shouldn't mourn it News Archived News Items 0 07-08-12 01:10 AM
New Windows Server 2012 puts virtualization front and center News Archived News Items 0 07-05-12 09:30 PM
Fujitsu Marries GPUs and Xeon in High-Density HPC Server News Archived News Items 0 06-13-12 06:30 PM

All times are GMT -5. The time now is 02:45 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.