Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-05-04, 11:41 AM   #13
WuppDich
Registered User
 
Join Date: Jul 2004
Posts: 6
Default Re: nvidia driver 3d acceleration doesn't work

i've searched my /var/log/XFree86.0.log

Quote:
[...]

(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.a
(II) Module glx: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.2
(II) Loading sub module "GLcore"
(II) LoadModule: "GLcore"
(II) Loading /usr/X11R6/lib/modules/extensions/libGLcore.a
(II) Module GLcore: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension GLX

[...]

(II) NVIDIA(0): Setting mode "1152x864"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(**) Option "dpms"
(**) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(EE) NVIDIA(0): Failed to load GLX

[...]
I don't understand this... first it writes GLX is loaded and later it failed to load GLX...
WuppDich is offline   Reply With Quote
Old 07-05-04, 12:34 PM   #14
bannerboy
Registered User
 
bannerboy's Avatar
 
Join Date: Jul 2004
Posts: 27
Default Re: nvidia driver 3d acceleration doesn't work

ok, one problem you have is it's not loading the nvidia glx module, it's loading the standard x glx module
bannerboy is offline   Reply With Quote
Old 07-05-04, 01:02 PM   #15
WuppDich
Registered User
 
Join Date: Jul 2004
Posts: 6
Default Re: nvidia driver 3d acceleration doesn't work

I've found another problem(?)

Quote:
root:/usr/lib> ll libGL*
libGL.la
libGL.so -> libGL.so.1
libGL.so.1 -> GL/libGL.so.1.4.mesasoft
libGL.so.1.0.6106
libGLU.so.1 -> libGLU.so.1.3
libGLU.so.1.3
libGLcore.so.1 -> libGLcore.so.1.0.6106
libGLcore.so.1.0.6106
so libGL.so.1 is symlinked to GL/libGL.so.1.4.mesasoft and not to the file from nvidia. okay, i tried to chance the symlink to libGL.so.1.0.6106 (just a try), but starting glxgears chrashes the whole complete xwindows...
WuppDich is offline   Reply With Quote
Old 07-05-04, 01:25 PM   #16
bannerboy
Registered User
 
bannerboy's Avatar
 
Join Date: Jul 2004
Posts: 27
Default Re: nvidia driver 3d acceleration doesn't work

My stuff seems to all check out, but glxgears still runs at a poking 350 fps
bannerboy is offline   Reply With Quote
Old 07-05-04, 04:50 PM   #17
WuppDich
Registered User
 
Join Date: Jul 2004
Posts: 6
Default Re: nvidia driver 3d acceleration doesn't work

After a day full of researched on the i-net, i've solved my problem. The new driver messed up with some files from an old driver. The script ftp://ftp.p-two.net/pub/nv_check.sh gave me some hints what to do...

I've removed some old files and added a few symlinks to the new driver files, now everthing is working fine...

Thanks everybody for your hints!
WuppDich is offline   Reply With Quote
Old 07-05-04, 09:54 PM   #18
bannerboy
Registered User
 
bannerboy's Avatar
 
Join Date: Jul 2004
Posts: 27
Default Re: nvidia driver 3d acceleration doesn't work

OK, I've done all that and it still doesn't work I've still got a stinkin' 350 fps
bannerboy is offline   Reply With Quote
Old 07-05-04, 10:53 PM   #19
Wolfman [TWP]
Geforce 8800 GTS 512
 
Join Date: Nov 2002
Location: Australia
Posts: 396
Default Re: nvidia driver 3d acceleration doesn't work

Quote:
Originally Posted by bannerboy
OK, I've done all that and it still doesn't work I've still got a stinkin' 350 fps
I didn't realise that you were running a GF 2 (Didn't read your post properly ). So that would mean that the FPS's you are getting, seem to be ok. As I'm running a GF4 440MX (Here at the Office) and get around 685fps. So yours should be ok.

Wolf
Wolfman [TWP] is offline   Reply With Quote
Old 07-05-04, 11:59 PM   #20
Nospoonzz
Registered User
 
Join Date: Feb 2004
Location: Somewhere in Linuxville
Posts: 11
Default Re: nvidia driver 3d acceleration doesn't work

Try this; I had the exact same problem and this worked
for me.
Open your terminal and type;
rpm -e --nodeps XFree86-Mesa-libGL


Good Luck.

p.s. I have an Nvidia FX 5900 XT and get over 10,000 fps
in GLX gears.
Nospoonzz is offline   Reply With Quote

Old 07-06-04, 02:49 AM   #21
Wolfman [TWP]
Geforce 8800 GTS 512
 
Join Date: Nov 2002
Location: Australia
Posts: 396
Default Re: nvidia driver 3d acceleration doesn't work

Quote:
Originally Posted by Nospoonzz
p.s. I have an Nvidia FX 5900 XT and get over 10,000 fps
in GLX gears.
I'd be interested to find out just how you managed to get 10,000fps in glxgears with your card. As the card I have is a full blown FX 5950 Ultra and I only get 8800fps in glxgears. So there's something wrong somewhere.

Wolf
Wolfman [TWP] is offline   Reply With Quote
Old 07-06-04, 03:23 AM   #22
lotheac
Registered User
 
Join Date: Nov 2003
Posts: 25
Default Re: nvidia driver 3d acceleration doesn't work

Quote:
Originally Posted by Wolfman [TWP]
I'd be interested to find out just how you managed to get 10,000fps in glxgears with your card. As the card I have is a full blown FX 5950 Ultra and I only get 8800fps in glxgears. So there's something wrong somewhere.
Now correct me if I'm wrong, but glxgears should not be used as a benchmark tool. I've heard multiple times that often glxgears is mistaken for a benchmarking tool, while it's only a diagnostic tool to check whether your card is working correctly. It's _very_ easy to manipulate your glxgears 'score': just resize the window or cover part of it with another window etc... So unless you get less than 1000 fps with a relatively new card, don't worry
lotheac is offline   Reply With Quote
Old 07-06-04, 07:57 AM   #23
how
Registered User
 
Join Date: Dec 2002
Location: Australia
Posts: 142
Default Re: nvidia driver 3d acceleration doesn't work

Quote:
Originally Posted by lotheac
Now correct me if I'm wrong, but glxgears should not be used as a benchmark tool. I've heard multiple times that often glxgears is mistaken for a benchmarking tool, while it's only a diagnostic tool to check whether your card is working correctly. It's _very_ easy to manipulate your glxgears 'score': just resize the window or cover part of it with another window etc... So unless you get less than 1000 fps with a relatively new card, don't worry
I would like to point out glxgears is not a opengl benchmark but is a benchmark of some sort may be more suitable for polygons. How fast you run glxgears is pretty much in relation to how fast you run other things except if you have a bad driver. glxgears is just basic polygons no textures. I am sure no surprise a GPU like FX 5900 can handle this to couple of thousand fps, besides glxgears in default size hasn't got much polygons at all. I got 2600fps and games like ut2003 is slow.
how is offline   Reply With Quote
Old 07-06-04, 09:02 AM   #24
Wolfman [TWP]
Geforce 8800 GTS 512
 
Join Date: Nov 2002
Location: Australia
Posts: 396
Default Re: nvidia driver 3d acceleration doesn't work

Quote:
Originally Posted by lotheac
Now correct me if I'm wrong, but glxgears should not be used as a benchmark tool. I've heard multiple times that often glxgears is mistaken for a benchmarking tool, while it's only a diagnostic tool to check whether your card is working correctly. It's _very_ easy to manipulate your glxgears 'score': just resize the window or cover part of it with another window etc... So unless you get less than 1000 fps with a relatively new card, don't worry
Yes, I know that glxgears is not a benchmarking tool. I only use it for referencing and checking whether 3D graphics is working. But I still think that my graphics card fps's are low, considering the type of card that I have. And then, apart from actual games like UT2K3/4, I don't know of any Linux graphics benchmarking programs, which would come even close to the ones used in Windows. But I'm open to any suggestions and links

And I forgot to mention. The glxgears values that I get with my card are based on the standard window that glxgears puts onto the screen by default.

Wolf
Wolfman [TWP] is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia driver quality decrease? legluondunet NVIDIA Linux 17 06-26-12 10:03 AM
NVIDIA Driver Installation flores.facundo NVIDIA Linux 2 06-24-12 08:37 AM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-01-02 11:58 PM

All times are GMT -5. The time now is 03:54 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.