Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-07-04, 01:07 PM   #13
Dobos
Registered User
 
Join Date: Jul 2004
Posts: 1
Default Re: 6106 with vesafb and GeForce FX 5200 Text mode problem

Same here, when I boot up I go to runlevel 3, looks fine, then when I go to X and either log out or go to a virtual console the monitor goes black and the monitor light blinks yellow (like it's not getting a signal). If I switch back to X or type startx though I get back to X and the monitor works again.

This has been happening with the last couple driver versions, and with lots of different kernels. I am currently on Fedora Core 2 using 2.6.7-mmX. I have vesafb compiled in and rivafb compiled as a module but it isn't loaded at all.
Dobos is offline   Reply With Quote
Old 07-08-04, 06:17 AM   #14
lotheac
Registered User
 
Join Date: Nov 2003
Posts: 25
Default Re: 6106 with vesafb and GeForce FX 5200 Text mode problem

The latest driver version that doesn't seem to do this for me is 46.20. 53.36 wouldn't work -- framebuffer or no framebuffer. I suspect this is the same for 61.06, although I haven't tried that without framebuffer support. vga=normal did nothing for me, I have "IgnoreDisplayDevices" "DFP,TV" in my XF86Config-4 and adding the "ConnectedMonitor" "CRT" option blanks my screen on X startup. I'm using a TFT monitor, but it's connected with a VGA cable.
lotheac is offline   Reply With Quote
Old 07-08-04, 06:24 AM   #15
CorneLinux
Registered User
 
Join Date: Apr 2004
Location: Germany
Posts: 8
Default Re: 6106 with vesafb and GeForce FX 5200 Text mode problem

Hello,

I also had this Porblem with a FX5200.
I upgraded to kernel 2.6.7 and driver 6106.
I removed all frambuffer things from the kernel and now it works without crashes. With 4k AND with 8k stacks (allthough it is terribly slow)

Regards
cornelius
CorneLinux is offline   Reply With Quote
Old 07-09-04, 12:41 AM   #16
dr_zukov
Registered User
 
Join Date: Nov 2003
Posts: 3
Talking Re: 6106 with vesafb and GeForce FX 5200 Text mode problem

Quote:
Originally Posted by dae
I'm also using DVI and couldn't get virtual consoles to work. Then I tried connecting the VGA too (to the same monitor as the DVI cable), and suddenly it worked! Note that I'm not using the VGA input, it's just that the cable needs to be connected.
OK. I connected the VGA cable. Now when I switch to the console from X the monitor apparently only gets the signal through the VGA cable and when I switch back to X it gets the signal from the DVI cable. Thanks for the tip.

Is it possible to somehow get the consoles to send the signal through the DVI cable?
dr_zukov is offline   Reply With Quote
Old 07-09-04, 01:04 AM   #17
dae
Registered User
 
Join Date: Jul 2004
Location: Sweden
Posts: 40
Default Re: 6106 with vesafb and GeForce FX 5200 Text mode problem

Hmm, don't know about that... I didn't have to do anything. I get the signal through both the VGA and the DVI cable when switching to the consoles. All I have to do is have my monitor use the DVI cable, which it apparently automatically does if I turn it on before I turn on the computer.
dae is offline   Reply With Quote
Old 07-09-04, 09:53 AM   #18
dr_zukov
Registered User
 
Join Date: Nov 2003
Posts: 3
Default Re: 6106 with vesafb and GeForce FX 5200 Text mode problem

To clarify a bit:
The switch between VGA and DVI cables is automatic. It's just that in X I only get a signal on DVI and in consoles I only get a signal through VGA. Of course, at boot-up (before starting X for the first time) I get a signal through DVI even though I'm in a console.

Does anyone know if Nvidia is planning to address this issue (considering the number of posts it seems to be a quite common problem)? Since I've gotten the console to work after a fashion it's not really a critical issue, but I would still like to get everything out of my card.
dr_zukov is offline   Reply With Quote
Old 07-09-04, 01:04 PM   #19
skerb1
Registered User
 
Join Date: Jul 2004
Posts: 7
Default Re: 6106 with vesafb and GeForce FX 5200 Text mode problem

I tried disabling the frame buffer as CorneLinux suggested...
Still having the same problem...
I don't think having two cables from the same monitor into the same video card sounds like a good solution...
If anyone has any other ideas on what to do...fire away...=P
skerb1 is offline   Reply With Quote
Old 07-09-04, 05:53 PM   #20
rokka
Registered User
 
Join Date: Jul 2004
Posts: 2
Default Re: 6106 with vesafb and GeForce FX 5200 Text mode problem

I had the very same problem with the 6101 driver and kernel 2.6.3 using the built in gf4mx in a nforce2 IGP motherboard with a DELL TFT (no DVI). Problem solved by setting:
Option "ConnectedMonitor" "CRT"
Option "IgnoreDisplayDevices" "TV"

No other magic required for me.
rokka is offline   Reply With Quote

Old 07-10-04, 05:50 PM   #21
skerb1
Registered User
 
Join Date: Jul 2004
Posts: 7
Default Re: 6106 with vesafb and GeForce FX 5200 Text mode problem

hi...
others who have tried this

Option "ConnectedMonitor" "CRT"
Option "IgnoreDisplayDevices" "TV"

have still had the same problem....
This doesn't seem like a solution to the problem for everyone...
(including me)...=P
NEW ideas??
skerb1 is offline   Reply With Quote
Old 07-16-04, 02:21 AM   #22
epipyman
Registered User
 
Join Date: Jul 2004
Posts: 1
Default Re: 6106 with vesafb and GeForce FX 5200 Text mode problem

If you're still having problems, check to see if your video card has a bios update. I was tearing my hair trying to figure solve the console problem until I tried updating my MSI Geforce4 mx440 bios (via *MSI's update program for windows). Everything works fine for me now. Still, flashing your vga bios should only be considered as a last resort though.

*I don't know if other companies have a similar live update program for their cards.

Last edited by epipyman; 07-16-04 at 02:40 AM.
epipyman is offline   Reply With Quote
Old 07-17-04, 10:10 AM   #23
lotheac
Registered User
 
Join Date: Nov 2003
Posts: 25
Default Re: 6106 with vesafb and GeForce FX 5200 Text mode problem

Hey!

I figured out how to fix this problem for me -- other suggestions didn't work, vga=normal did nothing, "ConnectedMonitor" "CRT" blanked my screen (which led to me thinking about this solution, the screen was actually CRT-1 - don't know why), "IgnoreDisplayDevices" "DFP, TV" I've had all the time.

The solution on my ASUS GeForce4 Ti4600 was to connect my TFT monitor with an AGP cable to the DVI output using an adapter! This seems to be CRT-0. I am using kernel 2.6.7 with framebuffer and 4kstacks. I wonder, though... Why did I not have this problem on versions prior (or equal) to 4620?

I'll attach my XF86Config-4 file for those more or less interested, and to waste my own time.
Attached Files
File Type: txt XF86Config-4.txt (3.2 KB, 186 views)
lotheac is offline   Reply With Quote
Old 08-06-04, 10:24 AM   #24
quetzyg
Linux Power User!
 
Join Date: Apr 2004
Location: /home/quetzyg
Posts: 63
Thumbs up Thanks!

I also had this problem, like all of you guys. First, Virtual Terminal = OK, then switched to X = OK, and then, switched back to VT = NOT OK.

The post before mine, said it all! Just unplug the VGA connector from the graphics adapter, and plug it on the DVI (you will need an adaptor of course). All the rest, like editing the lilo.conf, xorg.conf, etc, etc, doesn't work at all. At least for me, it didn't.

It's all working like a charm now

Thanks lotheac!

Last edited by quetzyg; 08-06-04 at 10:59 AM.
quetzyg is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:11 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.