Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-22-02, 03:27 AM   #1
clemmons78
Guest
 
Posts: n/a
Angry geforce4 & RH 7.0 - No Desktop

I just installed RH 7.0 on my new Pentium 4 w/Intel 850 chipset. I downloaded the NVidia drivers from the Web site and successfully installed them using RPM. Now, when I type "startx" I get a real funky screen with three terminal windows and a small clock. I can't start GNOME or KDE.

Red Hat Tech Support is mystified. None of them has ever seen or heard of the three-window screen I am getting. I can shift the resolution between 1024x768 and 800x600, but I can't run GNOME, which I need.

Red hat thinks it is an NVidia problem. At this point, I have no idea what to do next. Can any one help? I have attached my XFree86.0.log file.



clemmons78
Attached Files
File Type: txt xfree86.0.log.txt (23.9 KB, 100 views)
  Reply With Quote
Old 10-22-02, 05:24 AM   #2
Klaus-P
Registered User
 
Join Date: Aug 2002
Location: Germany
Posts: 134
Default

Is the old fvwm windowmanager (i guess it is or it is fvwm2) not funny with its clock and the three
terminal windows? This is X under Linux pure classics.

Well, a startx <W-manager of your choice>
or an entry in your home .bashrc (if you are running the bash)
export WINDOWMANAGER=/usr/X11R6/bin/kde (resp. export WINDOWMANAGER=/path/to/the/windowmangerprogram)
should help. The manager has to be properly installed on your computer. KDE, fvwm2, fvwm95, etc,...

first of all check what "export" reports about WINDOWMANAGER= ?????.
Klaus-P is offline   Reply With Quote
Old 10-22-02, 08:43 AM   #3
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Hey! That "funky three-window and a clock" you speak of happens to be my window manager of choice! Careful!

It's twm. I've never tried that "export WINDOWMANAGER" way of changing things, but if you create a file name .xinitrc (note the leading period) in your home directory, that contains the single line exec startkde, you'll get KDE when you startx. If you make the file contain exec gnome-session, you'll get Gnome.

To create the file, do an echo "exec gnome-session" >~/.xinitrc, replacing gnome-session with startkde or whatever, if you want. Thereafter, when you startx, you should get your desktop of choice.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 10-23-02, 12:59 PM   #4
clemmons78
Guest
 
Posts: n/a
Thumbs up

The solution offered by bwkaz looked easier, so I tried it first. It worked great! I inserted both lines in the ".xinitrc" file, and I use an editor to "rem out" the line I don't want. It is somewhat clumsy, but it works.

My thanks to both of you, Klaus-P and bwkaz, for helping to get me out of this quagmire. My only question at this point is: Why didn't Red Hat Technical Support know this? I dealt with three different technicians over the course of about five days.

Thanks, again!

clemmons78

  Reply With Quote
Old 10-23-02, 02:37 PM   #5
Klaus-P
Registered User
 
Join Date: Aug 2002
Location: Germany
Posts: 134
Default

Perhaps they are young computer science students. We all are or were young
and don't know about all things of history. Have 'mercy' ;-)
Klaus-P is offline   Reply With Quote
Old 10-23-02, 07:56 PM   #6
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

I wouldn't have had a clue what you were talking about if I hadn't ever seen twm (although twm by itself doesn't look like 3 xterms and an xclock, that's probably actually the way X set its /etc/X11/xinit/xinitrc file up by default) for myself. As it is, when I built my LFS system the first time, I tried to start up X right after installing it (forgetting about things like a window manager), and to my surprise, it actually worked. Well, sort of... it's hard to get used to, but the speed is nice. As is the sloppy focus (which, I know, you can enable in other WMs/DEs, but it isn't the default).
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVIDIA and VMware Enhance the Virtual Desktop Experience News Archived News Items 0 08-27-12 02:30 PM
OpenGL apps crashing in NVIDIA driver when switching desktop dinosaur NVIDIA Linux 0 06-01-12 07:09 PM
GeForce4 owners: Please post your TV encoder and board information ScuzziOne NVIDIA GeForce 7, 8, And 9 Series 8 08-04-02 06:55 PM
3DNA 3d desktop prydah General Software 2 08-01-02 10:59 AM
GeForce4 Owners: Need your TV Encoder & Board Info... please! ScuzziOne NVIDIA Linux 1 08-01-02 04:00 AM

All times are GMT -5. The time now is 01:55 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.