Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-04-04, 02:54 PM   #1
Schugy
Palit GF 7600GT AGP
 
Join Date: Apr 2003
Location: Germany
Posts: 55
Send a message via ICQ to Schugy Send a message via AIM to Schugy Send a message via Yahoo to Schugy
Default 1.0-6106: Missing version information for e.g. dosbox

When I try to start dosbox with the new driver I get the following message:

user@linux:~>dosbox
dosbox: /usr/lib/libGL.so.1: no version information available (required by dosbox)

Does anyone know what has changed since 1.0-5336?
Schugy is offline   Reply With Quote
Old 07-04-04, 07:52 PM   #2
kmare
Registered User
 
Join Date: Jul 2003
Location: greece
Posts: 180
Send a message via ICQ to kmare
Default Re: 1.0-6106: Missing version information for e.g. dosbox

Quote:
Originally Posted by Schugy
When I try to start dosbox with the new driver I get the following message:

user@linux:~>dosbox
dosbox: /usr/lib/libGL.so.1: no version information available (required by dosbox)

Does anyone know what has changed since 1.0-5336?
Having the same warning here... is it something related to the regparm kernel option? anybody?
And btw: the drivers are really great!!!!!!!! thanx again nvidia.

thanx
kmare is offline   Reply With Quote
Old 07-05-04, 05:12 AM   #3
Evil Penguin
Registered User
 
Join Date: May 2004
Posts: 49
Default Re: 1.0-6106: Missing version information for e.g. dosbox

I can run dosbox (0.61) without that warning...
(Using 1.0-6106 version of nvidia drivers...)
Evil Penguin is offline   Reply With Quote
Old 07-05-04, 02:44 PM   #4
Schugy
Palit GF 7600GT AGP
 
Join Date: Apr 2003
Location: Germany
Posts: 55
Send a message via ICQ to Schugy Send a message via AIM to Schugy Send a message via Yahoo to Schugy
Default Re: 1.0-6106: Missing version information for e.g. dosbox

I have a SuSE8.2 with Linux2.6.7

What's your distro that worx?
Schugy is offline   Reply With Quote
Old 07-05-04, 04:29 PM   #5
Evil Penguin
Registered User
 
Join Date: May 2004
Posts: 49
Default Re: 1.0-6106: Missing version information for e.g. dosbox

Debian (sid) with Linux 2.6.7...
Evil Penguin is offline   Reply With Quote
Old 07-17-04, 08:09 PM   #6
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default Re: 1.0-6106: Missing version information for e.g. dosbox

I get the same thing. It's somehow related to the nVidia libGL.so library (likely only on TLS systems, though I'm not entirely sure).

xawtv and mplayer both print it out at startup, but glxgears and most 3D games do not. I can't figure out any similarity between the former programs that's different from the latter, but maybe it's related to whether libGL.so.1 is linked directly or through another library (e.g. libGLU.so.1)?

Also, I get the same warning when doing (e.g.) an ldd /usr/bin/xawtv or ldd /usr/bin/mplayer. The warning is printed first, then the normal ldd output. Does this hold true for others getting this warning also?

I'm using kernel 2.6.7, with the 6106 driver. This system uses NPTL (glibc version is the CVS source from 2004-01-03). It's based on LFS (their CVS book plus their NPTL hint from about the same time, roughly 6-7 months ago).

Has anybody contacted linux-bugs about this warning?
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 10-09-04, 10:46 PM   #7
gantos
Registered User
 
Join Date: Oct 2004
Posts: 1
Default Re: 1.0-6106: Missing version information for e.g. dosbox

This bug isn't caused by any one system configuration; it's caused by the way the nvidia drivers are now packaged.

The answer is simple. The reasoning behind it may not be...
In every dynamic library, the compiler/linker toolchain embeds a list of "symbols" in a so-called "Symbol Table" inside every .so file. However, for most programs and most libraries, its needed only for debugging, not for ordinary use.

Of course, libGL.so is not just any other library. There are multitudes of implementations of it: ATI's GLX, nVidia's GLX, X11/DRI's GLX, and Mesa3d's GLX.
Not all of these versions are completely equal, but they must use the same "major version" of .1, because it follows OpenGL 1.x. Older versions might be missing functions, but if a program calls a non-existing function, then it might crash.
The solution: check the symbol table to see if the function exists; if so, use it.
Otherwise, don't use any advanced features that we aren't certain they exist.

My best guess as to why nVidia is causing us this pain:
Reverse engineering.
Somebody feels that because programmers know where the functions start (also given in the symbol table) somebody will try and "steal" nVidia's code for their own software.
Hopefully, nVidia is not that paranoid, as it will just cause more problems for legitimate users.
gantos is offline   Reply With Quote
Old 10-10-04, 05:08 AM   #8
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: 1.0-6106: Missing version information for e.g. dosbox

There was a bug in earlier NVIDIA driver releases that resulted in libGL.so symbols being stamped with version information; when applications are linked against these versions of libGL.so, they pick up a dependency on this version stamp. As of 1.0-6106, NVIDIA's libGL.so is no longer stamped with version information, hence the problem some users are seeing. The solution is to rebuild any affected packages against 1.0-6106's libGL.so.
zander is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 01:44 PM
Glx mrbig1344 NVIDIA Linux 7 09-30-02 06:45 AM
Error messages... HELP!!!! Imperito NVIDIA Linux 3 09-24-02 10:46 PM
Need help to get the X to work on my Acer TravelMate 630 knchee NVIDIA Linux 16 09-19-02 10:16 PM
RH7.3 and nForce - can't find the module dmw400 NVIDIA Linux 4 08-05-02 12:14 PM

All times are GMT -5. The time now is 07:45 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.