Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-22-02, 06:08 PM   #1
elsenator
Guest
 
Posts: n/a
Talking Red Hat 8 and Geforce HOW-TO!!! Easy to understand

Finally, after fiddling around with the src RPMs for a few days with no luck what so ever, I tried to use the tarballs from NVIDIA's page instead... And, to my surprise it all worked smoothly and I'm now running UT2003 on my Geforce 4 Ti4600 with no problems at all!!! Wanna do this too?

------------ READ ------------
First of all, I want to point out that I got it to work after making a clean install of Red Hat 8 workstation with the Development Tools and Kernel Development packages added manually(by telling the installer that I wanted to change the packages it had chosen for me with the workstation list). I'm not sure whether the these packages actually had to be added, but it makes sence since we are going to compile the kernel and GLX module for your particular setup... I think...

Anyways, if you already did make a clean install and the development packages mentioned above haven't been installed you can always add them by clicking
Menu > System Settings > Packages
And then checking the Development Tools and Kernel development packages(I don't know if the kernel development package is needed, but who cares)

ok, here is what I did, step by step:
1. First make sure you have the above mentioned stuff up and running
2. Go to NVIDIA's homepage and under Drivers for Linux download the two driver source tarballs:
NVIDIA_GLX-1.0-3123.tar.gz
NVIDIA_kernel-1.0-3123.tar.gz
3. Now exit Gnome/Kde
4. Go to the directory where you downloaded the tarballz (the tar.gz files)
5. Type "tar xvzf NVIDIA_kernel-1.0-3123.tar.gz" without the quotes (d'oh)
6. Type "tar xvzf NVIDIA_GLX-1.0-3123.tar.gz" also without the quotes (d'oooooh)
7. Now type "cd NVIDIA_kernel-1.0-3123"
8. Type "make install"
9. Type "cd ../NVIDIA_GLX-1.0-3123"
10. Type "make install"

11 Tadaaa!! Now the driver is installed, and all we need to do is modify the Xfree86 config file

Here's how it's done...
1. Type "cd /etc/X11"
2. Type "emacs XF86Config" (the emacs editor will then start)
3. Find the line that says "Load "dri"" and remove it.
4. Find the place where either "vesa" og "nv" is listed under your Geforce 4 card and change it to "nvidia"
5. Save the document by pressing F10, f, e, y . . .and there you go

And there we are... Type "startx" and you should be up and running with full OpenGL support.

If I missed something, please let me know, so I can correct it... I hope this "guide" will be of some use to some of you... Oh, and this should work with other Geforce cards too! I just wrote this since I couldn't use the other guide from this forum...

Fare thee well! And happy fraggin' or whatever ya wanna do...
  Reply With Quote
Old 10-23-02, 03:37 PM   #2
FishTech
Registered User
 
Join Date: Oct 2002
Posts: 38
Default

Hi elsenator,

Thanks for posting Your instructions... I found them very well written, complete, and easy to understand...

I tried them on a Mandrake 9.0 system and I did everything exactly as you have it written; and I think everything went well until I tried to edit the Config file with emacs... When I opened emacs there wasn't any text and I couldn't figure out how to use the emacs program... So I rebooted and tried to startx and it gave a error and failed to startX, and I couldn't get to the destop... So I reinstalled...


Anyways, Could You please give me more detailed instructions on editing the config file on emacs?

Thanks for Your Help and Time!
Love You!
FishTech
__________________
BIBLICAL REVELATIONS
FishTech is offline   Reply With Quote
Old 10-23-02, 07:44 PM   #3
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default Re: Red Hat 8 and Geforce 4 Ti HOW-TO!!! Easy to understand

One small thing I'd like to add (or, well, change, actually):

Quote:
Originally posted by elsenator
1. Type "/etc/X11"
I believe this one should read Type "cd /etc/X11" instead. I think this is why emacs gave you a blank screen as well, FishTech, because you weren't in the directory that the config file was in when you tried to edit it. So it tried to create a file of that name in whatever directory you were in, and of course a new file will be blank.

As for instructions on how to use emacs, I don't really know. It's been way too long since I've used it.
__________________
Registered Linux User #219692

Last edited by bwkaz; 10-23-02 at 07:49 PM.
bwkaz is offline   Reply With Quote
Old 10-24-02, 02:14 AM   #4
elsenator
Guest
 
Posts: n/a
Default

Whoops, forgot that... It has now been corrected...

Oh, and for the people who have probs editing using Emacs, just do the following...

1. After typing "Emacs XF86Config" and changing the stuff mentioned in the very first post of this thread, you save the document by pressing F10, f, e, y . . .and there you go

F=file menu
E=Exit
Y=Yes to save document
  Reply With Quote
Old 10-24-02, 10:10 AM   #5
FishTech
Registered User
 
Join Date: Oct 2002
Posts: 38
Default

Thanks bwkaz, and elsenator,

That makes it better... But when I type in "emacs XF86Config" I don't find the settings that I'm supposed to edit?... Shouldn't I be typing in "emacs XF86Config" if I'm using version 3 of XFree and "emacs XF86Config-4" if I'm using version 4 of XFree?
__________________
BIBLICAL REVELATIONS
FishTech is offline   Reply With Quote
Old 10-24-02, 11:56 AM   #6
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

It depends on your version of RedHat (aren't they just wonderful?). If an XF86Config-4 file exists, then edit it. If not, then edit XF86Config instead.

With version 8, RedHat changed something that allowed them to not need an XF86Config-4 file anymore. But in earlier versions, and in most other distros, you need to edit XF86Config-4, because it will exist.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 10-24-02, 04:52 PM   #7
sdv
Registered User
 
Join Date: Oct 2002
Location: MI
Posts: 6
Default

check out the first few lines in the /var/log/XF*.log file

It will log the config file it is reading from (**)
__________________
Dell Inspiron 8200 GeForce4 440 GO
sdv is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
304.79 Beta & PhysX 9.12.0613 xavier2k5 NVIDIA Windows Graphics Drivers 1 07-03-12 03:00 PM
New GPU from Nvidia Announced Today, the GeForce GTX 670 News Latest Tech And Game Headlines 0 05-10-12 01:50 PM
Gainward Unleashes the Sexy GeForce GTX 670 Phantom Graphics Card, Also launches the News Latest Tech And Game Headlines 0 05-10-12 09:28 AM
red hat 7.3 driver problems please help war18 NVIDIA Linux 7 09-16-02 12:25 PM
Red Hat Linux and Dell Inspiron 8200 haridamineni NVIDIA Linux 3 08-27-02 12:37 PM

All times are GMT -5. The time now is 04:30 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.