Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-13-04, 09:22 AM   #1
vertiger
Registered User
 
Join Date: Aug 2004
Posts: 6
Default Problems enableing OpenGL

I have a GeForce FX 5600 und want to install driver version 61.11
I have successfully installed the kernel-driver, the x-server runs also well

but enableing opengl don't worked.

My system: 2.8GHz Pentium4-HT, Gentoo-Linux 2004.1, Kernel: gentoo-dev-sources (2.6.7 mit patches von gentoo)

Console: vesafb im kernel (1024x768)

Here is my Xorg.log:
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.6111
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension GLX
(II) LoadModule: "nvidia"
(II) Loading /usr/X11R6/lib/modules/drivers/nvidia_drv.o
(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.6111
Module class: XFree86 Video Driver
((II) NVIDIA(0): Setting mode "1280x800"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(II) Loading extension NV-CONTROL
(WW) NVIDIA(0): Option "passwordFile" is not used
(==) RandR enabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension LBX
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing extension GLX

here is the output of glxinfo
name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.3
server glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig,
GLX_SGIX_pbuffer, GLX_SGI_video_sync, GLX_SGI_swap_control,
GLX_ARB_multisample, GLX_NV_float_buffer
client glx vendor string: NVIDIA Corporation
client glx version string: 1.3
client glx extensions:
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_visual_info,
GLX_EXT_visual_rating, GLX_EXT_import_context, GLX_SGI_video_sync,
GLX_NV_swap_group, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
GLX_SGI_swap_control, GLX_NV_float_buffer
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig,
GLX_SGIX_pbuffer, GLX_SGI_video_sync, GLX_SGI_swap_control,
GLX_ARB_multisample, GLX_NV_float_buffer, GLX_ARB_get_proc_address
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce FX Go5600/AGP/SSE2
OpenGL version string: 1.5.1 NVIDIA 61.11
OpenGL extensions:
GL_ARB_depth_texture, GL_ARB_fragment_program,
GL_ARB_fragment_program_shadow, GL_ARB_fragment_shader, GL_ARB_imaging,
GL_ARB_multisample, GL_ARB_multitexture, GL_ARB_occlusion_query,
GL_ARB_point_parameters, GL_ARB_point_sprite, GL_ARB_shadow,
GL_ARB_shader_objects, GL_ARB_shading_language_100,
GL_ARB_texture_border_clamp, GL_ARB_texture_compression,
GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
GL_ARB_texture_mirrored_repeat, GL_ARB_transpose_matrix,
GL_ARB_vertex_buffer_object, GL_ARB_vertex_program, GL_ARB_vertex_shader,
GL_ARB_window_pos, GL_S3_s3tc, GL_EXT_texture_env_add, GL_EXT_abgr,
GL_EXT_bgra, GL_EXT_blend_color, GL_EXT_blend_func_separate,
GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_compiled_vertex_array,
GL_EXT_Cg_shader, GL_EXT_draw_range_elements, GL_EXT_fog_coord,
GL_EXT_multi_draw_arrays, GL_EXT_packed_pixels, GL_EXT_paletted_texture,
GL_EXT_pixel_buffer_object, GL_EXT_point_parameters,
GL_EXT_rescale_normal, GL_EXT_secondary_color,
GL_EXT_separate_specular_color, GL_EXT_shadow_funcs,
GL_EXT_shared_texture_palette, GL_EXT_stencil_two_side,
GL_EXT_stencil_wrap, GL_EXT_texture3D, GL_EXT_texture_compression_s3tc,
GL_EXT_texture_cube_map, GL_EXT_texture_edge_clamp,
GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
GL_EXT_texture_filter_anisotropic, GL_EXT_texture_lod,
GL_EXT_texture_lod_bias, GL_EXT_texture_object, GL_EXT_vertex_array,
GL_HP_occlusion_test, GL_IBM_rasterpos_clip,
GL_IBM_texture_mirrored_repeat, GL_KTX_buffer_region, GL_NV_blend_square,
GL_NV_copy_depth_to_color, GL_NV_depth_clamp, GL_NV_fence,
GL_NV_float_buffer, GL_NV_fog_distance, GL_NV_fragment_program,
GL_NV_fragment_program_option, GL_NV_half_float, GL_NV_light_max_exponent,
GL_NV_multisample_filter_hint, GL_NV_occlusion_query,
GL_NV_packed_depth_stencil, GL_NV_pixel_data_range, GL_NV_point_sprite,
GL_NV_primitive_restart, GL_NV_register_combiners,
GL_NV_register_combiners2, GL_NV_texgen_reflection,
GL_NV_texture_compression_vtc, GL_NV_texture_env_combine4,
GL_NV_texture_expand_normal, GL_NV_texture_rectangle,
GL_NV_texture_shader, GL_NV_texture_shader2, GL_NV_texture_shader3,
GL_NV_vertex_array_range, GL_NV_vertex_array_range2, GL_NV_vertex_program,
GL_NV_vertex_program1_1, GL_NV_vertex_program2,
GL_NV_vertex_program2_option, GL_SGIS_generate_mipmap,
GL_SGIS_texture_lod, GL_SGIX_depth_texture, GL_SGIX_shadow,
GL_SUN_slice_accum
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess


ldd /usr/X11R6/bin/glxgears
linux-gate.so.1 => (0xffffe000)
libGL.so.1 => /usr/lib/opengl/nvidia/lib/libGL.so.1 (0x4003c000)
libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x400a4000)
libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x400b2000)
libpthread.so.0 => /lib/libpthread.so.0 (0x40175000)
libm.so.6 => /lib/libm.so.6 (0x401c7000)
libc.so.6 => /lib/libc.so.6 (0x401e8000)
libGLcore.so.1 => /usr/lib/opengl/nvidia/lib/libGLcore.so.1 (0x402f4000)
libnvidia-tls.so.1 => /usr/lib/opengl/nvidia/lib/libnvidia-tls.so.1 (0x409cc000)
libdl.so.2 => /lib/libdl.so.2 (0x409ce000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
all libraries are the ones from nvidia !!

so why glxgears runs only on Softrender and opengl-games don't start ??
vertiger is offline   Reply With Quote
Old 08-13-04, 10:16 AM   #2
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default Re: Problems enableing OpenGL

In the info you posted is nothing wrong. If there's a problem we can't see it with this info.
Thunderbird is offline   Reply With Quote
Old 08-15-04, 08:24 AM   #3
vertiger
Registered User
 
Join Date: Aug 2004
Posts: 6
Default Re: Problems enableing OpenGL

All programs that use OpenGL always say could not load lidGL.so

here is a example:

Quote:
Heavy Metal: FAKK2 1.02 linux-i386 Oct 9 2001
----- FS_Startup -----
Current search path:
/root/.loki/fakk2/fakk
/usr/local/games/fakk2/fakk/pak3.pk3 (21 files)
/usr/local/games/fakk2/fakk/pak2.pk3 (13 files)
/usr/local/games/fakk2/fakk/pak1.pk3 (2532 files)
/usr/local/games/fakk2/fakk/pak0.pk3 (9610 files)
/usr/local/games/fakk2/fakk
/usr/local/games/fakk2/fakk/pak3.pk3 (21 files)
/usr/local/games/fakk2/fakk/pak2.pk3 (13 files)
/usr/local/games/fakk2/fakk/pak1.pk3 (2532 files)
/usr/local/games/fakk2/fakk/pak0.pk3 (9610 files)
/usr/local/games/fakk2/fakk

----------------------
Config: config.cfg
execing default.cfg
execing menu.cfg
couldn't exec config.cfg
execing localized.cfg
execing autoexec.cfg
Joystick is not active.
----- Client Initialization -----
----- Initializing Renderer ----
----- R_Init -----
...loading libGL.so: SDL: SDL_GL_LoadLibrary() failed! rc == (-1).
SDL_GetError() reports "Could not load OpenGL library".
failed
...loading libMesaVoodooGL.so.3.1: SDL: SDL_GL_LoadLibrary() failed! rc == (-1).
SDL_GetError() reports "Could not load OpenGL library".
failed
----- CL_Shutdown -----
-----------------------
----- CL_Shutdown -----
-----------------------
Error: GLimp_Init() - could not load OpenGL subsystem
note: all lib-files and dev-nodes are in the right place and have the right permissions

i also tried UT2004 - it don't worked with the same expanation

i have tried the driver version 6111 at an old mandrake9.2 system :
here they worked perfectly


can someone help me, please

Last edited by vertiger; 08-15-04 at 08:39 AM.
vertiger is offline   Reply With Quote
Old 08-27-04, 02:42 AM   #4
BonesNV
Registered User
 
Join Date: Mar 2004
Posts: 15
Default Re: Problems enableing OpenGL

Quote:
ldd /usr/X11R6/bin/glxgears

linux-gate.so.1 => (0xffffe000)
libGL.so.1 => /usr/lib/opengl/nvidia/lib/libGL.so.1 (0x4003c000)
libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x400a4000)
libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x400b2000)
libpthread.so.0 => /lib/libpthread.so.0 (0x40175000)
libm.so.6 => /lib/libm.so.6 (0x401c7000)
libc.so.6 => /lib/libc.so.6 (0x401e8000)
libGLcore.so.1 => /usr/lib/opengl/nvidia/lib/libGLcore.so.1 (0x402f4000)
libnvidia-tls.so.1 => /usr/lib/opengl/nvidia/lib/libnvidia-tls.so.1 (0x409cc000)
libdl.so.2 => /lib/libdl.so.2 (0x409ce000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

all libraries are the ones from nvidia !!
Are you sure all the libraries are the nvidia ones? I'm having a similar problem. My ldd output looks exaclty like yours and I know this is the problem, still trying to figure out how to fix it though.

In my case the libGL located at /usr/lib/opengl/nvidia... is not the right library. If fact I need to change this to /usr/lib/libGL.so.
Would anyone know how to accomplish this? I know it has to do with ldconfig and paths.
BonesNV is offline   Reply With Quote
Old 08-27-04, 06:30 PM   #5
kmare
Registered User
 
Join Date: Jul 2003
Location: greece
Posts: 180
Send a message via ICQ to kmare
Default Re: Problems enableing OpenGL

[QUOTE/]----- Client Initialization -----
----- Initializing Renderer ----
----- R_Init -----
...loading libGL.so: SDL: SDL_GL_LoadLibrary() failed! rc == (-1).
SDL_GetError() reports "Could not load OpenGL library".
failed
...loading libMesaVoodooGL.so.3.1: SDL: SDL_GL_LoadLibrary() failed! rc == (-1).
SDL_GetError() reports "Could not load OpenGL library".
failed
----- CL_Shutdown -----
[/quote]
it seems like the game is trying to load mesaGL... this is wrong... I don't know but you might try to copy libGL.so and libGL.so.1 to /usr/lib/. Make sure they are the nvidia ones... As far as I recall correctly loki games where searching for libGL.so.1 in /usr/lib/ but I may be totally wrong...
kmare is offline   Reply With Quote
Old 08-30-04, 11:11 PM   #6
BonesNV
Registered User
 
Join Date: Mar 2004
Posts: 15
Default Re: Problems enableing OpenGL

I just prepended XXX to the file name /usr/lib/opengl/nvidia/lib/libGL.so.1.
Then reran ldconfig and all my links are correct and working now.

Hope it helps.
BonesNV is offline   Reply With Quote
Old 08-31-04, 12:28 AM   #7
buckyballnut
Registered User
 
Join Date: Aug 2004
Posts: 5
Default Re: Problems enableing OpenGL

I have incurred similiar problems. The fastest way I resolved them is to use driver 1.0-6106 instead.
buckyballnut is offline   Reply With Quote
Old 08-31-04, 03:03 AM   #8
vertiger
Registered User
 
Join Date: Aug 2004
Posts: 6
Default Re: Problems enableing OpenGL

That won't solve the problem!!

There are links to /usr/lib/opengl/nvidia/libGL.so in /usr/lib/
And I'm sure that are the once from nvidia.
I'm also tried to compile the driver myself (and don't use the gentoo installer) but the result is the same.

Note: FAKK2 first try's to load the opengl-lib form nvidia and if that fails it trys to load the mesa-lib

2. Note: If I tried to compile the game frozen-bubbles with nvidia-opengl turned on, he always says he couldn't use the file libnvidia-tls!!
But if I turn Xorg-opengl (mesa) on, he can compile it.

Hmm, all files are in the right place, all links and permissions are correct.
Nevertheless the files won't load or could be used - It looks like are not compiled correct.

Can this be true?
vertiger is offline   Reply With Quote

Old 08-31-04, 04:48 AM   #9
Antti
Registered User
 
Join Date: Aug 2004
Posts: 45
Default Re: Problems enableing OpenGL

Have you tried first this:
LD_PRELOAD="/usr/lib/libGL.so.1"

..and then starting the game that has problems. That solved my problems with UT2004, but maybe you have different sorts of trouble.
Antti is offline   Reply With Quote
Old 08-31-04, 06:26 AM   #10
vertiger
Registered User
 
Join Date: Aug 2004
Posts: 6
Default Re: Problems enableing OpenGL

No, that didn't solve the problem.
vertiger is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenGL book Airstrip1 Software Development 2 08-12-12 08:55 AM
Unity 5.12 Fixes Ubuntu OpenGL Performance Problems News Archived News Items 0 06-11-12 01:20 PM
Major WineX prob... I think it has to do with the vidcard... Linewbie NVIDIA Linux 20 10-09-02 09:58 PM
OpenGL SDK compilation problems gib bogle NVIDIA Linux 2 09-18-02 09:15 AM
Slow OpenGL on 7.3 kl899 NVIDIA Linux 1 08-04-02 07:58 PM

All times are GMT -5. The time now is 06:14 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.