Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Closed Thread
 
Thread Tools
Old 07-17-04, 12:21 PM   #13
rednuht
GeForce FX5600 (1.0-5336)
 
rednuht's Avatar
 
Join Date: Sep 2003
Location: uk
Posts: 164
Default Re: "screen frozen, but mouse pointer moves" bug

Strawks: yep thats what I get from strace
rednuht is offline  
Old 07-21-04, 07:02 PM   #14
ToastyX
Registered User
 
Join Date: Feb 2004
Posts: 32
Default Re: "screen frozen, but mouse pointer moves" bug

Quote:
Originally Posted by Kamel
i will mention that 2 times i can think of (probably more), konqueror for KDE caused this type of crash, when clicking on a combo box. i could tell that they were related because of the way it behaved in each situation. a bit hard to explain in text, but basically i just feel it too ironic that i've had multiple crashes of this sort that happened somewhere between clicking the combo box and moving the cursor to the option (only to find out that it doesn't highlight, and i've gotten the nasty bug).
I know exactly what you mean. The same thing used to happen to me with Mozilla.
ToastyX is offline  
Old 08-15-04, 05:47 PM   #15
kernel_panic
Registered User
 
Join Date: Mar 2004
Posts: 2
Default Re: "screen frozen, but mouse pointer moves" bug

I've exactly the same problem :

- Dell Inspiron 5150
- GF FX5200Go
- I tried all the 2.6 kernels but that didn't fix it !
kernel_panic is offline  
Old 08-16-04, 03:07 PM   #16
samgreen01
Registered User
 
Join Date: Aug 2004
Posts: 10
Default Re: "screen frozen, but mouse pointer moves" bug

I've the same problem.

I know it cannot possibly be a hardware problem because, when I am able to keep from freezing for 3 minutes, I'm able to launch Cedega and have it run City of Heroes - and managed to keep CoH running for *hours*.

What I have done to deal with the problem (though it is absolutely not a real solution) is this:

I made 2 versions of my xorg.conf file. 1 of them has the "nvidia" stuff in it, the other uses the open source "nv" drivers. Then I made a script that will check to see what conf file is in use, swap it with the other one, and then restart X.

What I can do then is launch X with nvidia's drivers running (if I need to use them for something - usually gaming) and I can usually launch a game before I freeze. Once I launch, I have no problem. If I want to do other work on the box, I run my swapping script and restart X with the nv drivers, which don't lock up.

When I do lock (and I *always* lock when leaving a game or logging out to switch users) I have to SSH in from another machine and manually kill X and start it again.

Not perfect, not by a long-shot, but I'm able to work with it until a real fix is found.

Once I get back off the road I'll submit the script if anyone wants it.
samgreen01 is offline  
Old 08-16-04, 06:16 PM   #17
PrakashP
gentoo ~x86_64 user
 
PrakashP's Avatar
 
Join Date: Jul 2004
Location: Germania
Posts: 213
Default Re: "screen frozen, but mouse pointer moves" bug

The funny thing is, this kind of lock-up only seems to occur in 2d. In my case I found out it seems to occur when the GPU gets too hot. So, by cooling it more efficiently, no more problem. The windows driver seems to be less error prone, ie it can recover, but the linux version does not. Starnge enough, in 3d even the linux version recovers. When it gets too hot here, it freezes for a few seconds (10-20) and then continues.

Nevertheless, I expereince a second type of lock-up, where nothing move, ie a real hard lock-up. It seems to be APIC related, I am now resolving this. Usually when I do heavy compiling for 2-4h the system will lock up. (Doing less, and the machine survived days.) Will the nv os driver, no problem though. It is not AGP related, as it locked up with nvagp "0", as well. Now I booted with noapic and the system survived 4h of compiling without APIC and without AGP. Now I enabled AGP and will see whether it survives the night compiling. If it does I will try APIC again, but with CPU Disconnect to off (the old issue...whcih Nvidia supposed to have fixed...).

I am trying with vanilla 2.6.7 kernel. Will keep you updated.
PrakashP is offline  
Old 08-17-04, 06:12 AM   #18
NoVoodoo
Registered User
 
Join Date: Apr 2004
Posts: 3
Default Re: "screen frozen, but mouse pointer moves" bug

Quote:
Originally Posted by NoVoodoo
I get this problem also, both with the 5336 & the 6106 drivers. I do not get
the problem when I have a gf4 mx440 in the box, only when I have an fx5700 installed.
...
See my previous post, with detailed system specs, etc:
http://www.nvnews.net/vbulletin/showthread.php?t=27645
...
Still have the lockups with the new drivers. It seemed to take longer to actually lockup with 6111, though it still locked up regularly.

Oddly, the system was up for 3 days with 6111 with my fx5700 installed, but it wasn't used at all in that time it was just sitting idle. When i did start using it (surfing the web, etc), it locked up within 15-20 mins. And again following a reboot after using it for about 30 minutes.

So i'm stuck with the gf4 mx440 again, which really isn't going to cut it when the d3 linux client is released :-(

- NoVoodoo
NoVoodoo is offline  
Old 08-18-04, 08:00 PM   #19
ToastyX
Registered User
 
Join Date: Feb 2004
Posts: 32
Default Re: "screen frozen, but mouse pointer moves" bug

Here's yet another victim: http://www.nvnews.net/vbulletin/showthread.php?t=33273

Here are some other things I've tried lately:

I tried the 4363 driver (because of the thread mentioned above), and that didn't make a difference.
I installed Slackware 10.0 which has GCC 3.3.4, and that didn't make a difference.
I installed kernel 2.6.7 and tried agpgart (I was using NVIDIA's AGP support), and that didn't make a difference.

I'm getting tired of this. Why does this happen, and why won't NVIDIA acknowledge the problem?
ToastyX is offline  
Old 08-19-04, 12:19 AM   #20
gilgamesher
Registered User
 
Join Date: Aug 2004
Posts: 3
Default Re: "screen frozen, but mouse pointer moves" bug

Quote:
Originally Posted by ToastyX
Examples:
After dealing with this problem for several months, I finally figured out a pattern. The problem only seems to occur if I run X for several days, then restart it. The "lockup" then occurs within 24 hours or so. I don't know if this is the case with everyone else, but perhaps that might be a clue as to why it happens.
X freezes for me within 30 seconds of running. and it happens when there is mouse activity (clicking) it seems. I don't know why. Maybe i should go over to ATI. II bought a new card so it woiuld be faster than my old one, but I had to disable AGP to have my ststem run under X fore more than a few seconds. I am deeply disappointed in nVidia.
gilgamesher is offline  

Old 08-19-04, 02:05 PM   #21
gilgamesher
Registered User
 
Join Date: Aug 2004
Posts: 3
Default Re: "screen frozen, but mouse pointer moves" bug

Ok. I am sure about this now. For me, this happens every time I move the cursor over a GL app. entering quake3 it usuallt happens. moving or resizing the glx gears window, or moving the mouse over the glx gears window, or clicking buttons on the gnome desktop. very rarely at idle. Strange.. I always catch it frozen in mid-click of a button, when the pressing animation is happening. almost always....

This seems mouse related for me, could this have something to do with cursor shadow?
gilgamesher is offline  
Old 08-20-04, 10:39 PM   #22
jlacroix
Registered User
 
Join Date: Jun 2004
Posts: 57
Default Re: "screen frozen, but mouse pointer moves" bug

Let's face it: NVidia doesn't care about us. Most of their revenue comes from Windows users.

I am ABSOLUTELY FRUSTRATED. I bought a new Geforce FX video card, which was a COMPLETE waste of money because the problem still persists.

NVidia has not even acknowledged this problem. There has been four, maybe even five, driver versions WITHOUT ONE SINGLE ATTEMPT to even try to fix this.

I'm done, absolutely done!!!! I switch to Linux because its more stable, and it crashes every 15 minutes with these worthless drivers. Linux becomes LESS stable than Windows 98 with their drivers.

I had alot of respect for NVidia, but my Geforce FX card is going back to the store tomorrow.

Edit: Sorry to rant, but there is not one damned excuse for this. It's not that hard to check the source code. I make games myself and can even find time to edit source code if someone needs it to work.
jlacroix is offline  
Old 08-25-04, 08:45 AM   #23
discord
Registered User
 
Join Date: Feb 2004
Posts: 12
Default Re: "screen frozen, but mouse pointer moves" bug

My machine does this too. what is the ****ing problem? the vesa driver works, can they not make a working driver themselves. those aholes if they would only give devlopers information about their hardware maybe it would work.
discord is offline  
Old 08-25-04, 09:07 AM   #24
lancer01
Registered User
 
Join Date: May 2004
Posts: 20
Default Re: "screen frozen, but mouse pointer moves" bug

Another victim here. Although it got a lot better with 6106 driver, the problem's still there.

Previous to 6106 I could get 10 minutes of computing. now I can get whole days if I'm lucky. This morning it got stuck within 5 minutes.

System: Athlon XP 1700+, A7V166-E (VIA KT166A chipset), GF4-4200Ti and 768Megs of mem (in three slots). As a sidenote, the problem became really big when I put in the third bank of memory (there is a topic lying about somewhere on the forum about this)

I also have a laptop with P4M and i8x0 chipset and 4200Ti and no problems there.
lancer01 is offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:28 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.