Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Closed Thread
 
Thread Tools
Old 01-17-06, 10:41 PM   #397
h2gofast
Registered User
 
Join Date: Sep 2004
Posts: 1
Default Re: "screen frozen, but mouse pointer moves" bug

2.6.12-1-k7 #1 Tue Sep 27 13:22:07 JST 2005 i686 GNU/Linux
asus a7nx-x, with an overclocked barton core amd chip.
nvidia fx5200 with an old ati card for a dual screen setup using xinerama. the fx5200 also is using twinview to put s-video out to the tv. running xorg
Running Debian Testing and have used different kernels from 2.4
I have had this bug on and off. A couple of times it only occured running fluxbox and would not occur while running kde or gnome. The bug did not occur at the same time but often would happen under heavier network use, either downloads or file transfers.
I can ssh into this box from a laptop on the same lan.
The bug has been happening lately more often. Mouse pointer moves but no mouse button or keyboard response. NumLock button doesn't light the NumLock light on the keyboard.
Last time it happened, I ssh into the box and killall firefox-bin. each window flickered like I was scrolling through workspaces, and the keyboard and mouse buttons now respond.
h2gofast is offline  
Old 01-18-06, 09:07 AM   #398
HellSpawn
Registered User
 
Join Date: Jan 2005
Posts: 21
Talking Re: "screen frozen, but mouse pointer moves" bug

I bought a PNY Geforce 6200 256MB Agp VGA Dvi Svid HDtv Breakout Pod, and it hasn't given me any "screen frozen, but mouse pointer moves", I'll be trying some other features like TwinView with my TV, etc...

I played UT2004 for a while, checked email with Evolution, surf with Firefox, and Remote Desktop with tclient (I manege some W2K3 servers for a Living ), And downloaded heavy stuff all night with aMule. I'll be installing Quake 4 too....

The other Card was an XFX GeForce 5200 128Mb AGP 8x VGA S-Video.
__________________
Ubuntu 5.10 Breezy Badger 64bits
PNY Geforce 6200 256MB AGP 8x VGA Dvi Svid HDtv Breakout Pod
AMD ATHLON 64 3000+ (Socket 754)
MOBO Gigabyte GA-K8NS nForce3
RAM 1Gb DDR400
Kernel: Linux ubuntu 2.6.12-10-amd64-k8 #1 Thu Dec 22 11:12:06 UTC 2005 x86_64 GNU/Linux
Nvidia Driver: 8178 64bits
HellSpawn is offline  
Old 02-01-06, 11:33 AM   #399
marmot4
Registered User
 
Join Date: Jan 2006
Posts: 1
Default Re: "screen frozen, but mouse pointer moves" bug

This thread is absurdly long. After spending forever reading through it I had seen so many version of: "do this, it worked for me" followed by "didn't work for me, but this did" that I ended up with no idea what to do...

Here's my version of "do this, it worked for me." I was getting the screen frozen, but mouse pointer moves bug. Though sometimes the mouse pointer wouldn't move, and it would always eventually stop moving... But close enough I think. I'm using SuSE 10.0 OSS with an Nvidia FX5500 256mb AGP 4x card with an AMD Athelon 2100Mhz cpu.

I *seem* to have solved it by added Option "NvAgp" "1" to the Nvidia Driver section of my xorg.conf. I say seem, because for all I know it'll freeze in the next ten minutes. It's been running without a freeze for longer than ever, so I'm hopeful. Apparantly the problem is that some nvidia chipsets have a problem with the agpgart module used by default in the linux kernel.

I thought this thread could use a post explaining some of the basics, especially here at the end.

After some research I have found that agpgart is the standard linux kernel driver for dealing with the special features of AGP. As an agp device can be used as if it were any normal PCI you need a driver capable of using the special memory features and so forth that give you a performance increase. Thus, agpgart. According to various people on the web, agpgart is widely considered to be more stable than most alternatives, NvAgp especially.

NvAgp on the other hand is part of the nvidia kernel module and serves the same purpose as agpgart. But the rumor is that it is both slower and less stable than agpgart. NvAgp has 4 options. 0, 1, 2, and 3 which you specify in the driver section of your xorg.conf like so: Option "NvAgp" "1"
0 - disables AGP support
1 - uses NvAgp if possible
2 - uses agpgart, if possible
3 - tries agpgart, if it fails, tries NvAgp

Hope this info helps some other people out!
marmot4 is offline  
Old 02-26-06, 02:17 PM   #400
cagdasinan
Registered User
 
Join Date: Feb 2006
Posts: 1
Default Re: "screen frozen, but mouse pointer moves" bug

Solution to this:

Driver "nv "
BusID "PCI:1:0:0"
Option "noAccel" "true" write this in your /etc/X11/xorg.conf file

If someone has a better solution, please share with us...
cagdasinan is offline  
Old 03-15-06, 02:16 PM   #401
kbellve
Registered User
 
Join Date: May 2004
Posts: 18
Default Re: "screen frozen, but mouse pointer moves" bug

EDITED TO ADD: I can't upload my nvidia bug report log because it exceeds the 100kb limit.

Ok...I read the entire thread...nothing helped.

First, we have three identical computers each with dual Xeon 2.2MHz, Tyan motherboards running Fedora FC4 with the latest kernel.

No AGP slots on the Tyan motherboard.

Two of the three computers have the screen freeze but mouse continues to move with X taking nearly 100% of CPU time. I can log in remotely to restart X. The third computer has no problems at all.

Screen freezes but mouse pointer still moves:
1) nVidia Corporation NV34 [GeForce FX 5500]
2) nVidia Corporation NV36 [GeForce FX 5700LE]

No combination of settings in Xorg prevents the problem. All I have to do is resize a shell quickly several times to get the screen freeze on either system.

Computer is fine:
1) nVidia Corporation GeForce FX 5200

These are all PCI based NVidia cards running on identical systems running the same NVidia driver with the same FC4 kernel. The only thing different is each has a different NVidia card.

dmesg output:
n_atomic():1, irqs_disabled():0
[<c0152f34>] __kmalloc+0x8d/0x8f [<f92b33d1>] nv_alloc_kernel_mapping+0x14e/0x26a [nvidia]
[<f908a218>] _nv002326rm+0x78/0xd4 [nvidia] [<f91ae201>] _nv005646rm+0x389/0x440 [nvidia]
[<f91cfd1a>] _nv004902rm+0x8a/0x94 [nvidia] [<f90893b2>] _nv002276rm+0x1a/0x20 [nvidia]
[<f91e266d>] _nv004829rm+0xd1/0x16c [nvidia] [<f91e2685>] _nv004829rm+0xe9/0x16c [nvidia]
[<f907a7cd>] _nv002423rm+0x1d/0x2c [nvidia] [<f926a89f>] _nv001858rm+0x28b/0x504 [nvidia]
[<f926a886>] _nv001858rm+0x272/0x504 [nvidia] [<f907a603>] _nv002429rm+0x6f/0x84 [nvidia]
[<f926c4e8>] _nv001849rm+0xd4/0x12c [nvidia] [<f91cf9f1>] _nv005136rm+0x441/0x484 [nvidia]
[<f926a415>] _nv001856rm+0x1d5/0x240 [nvidia] [<f926a3f2>] _nv001856rm+0x1b2/0x240 [nvidia]
[<f91fb84f>] _nv004609rm+0xcfb/0xf90 [nvidia] [<f91d070b>] _nv005100rm+0x23/0x28 [nvidia]
[<f91d070b>] _nv005100rm+0x23/0x28 [nvidia] [<f916bb6c>] _nv000389rm+0x24/0x28 [nvidia]
[<f916c67a>] _nv000414rm+0xba/0xf4 [nvidia] [<f91692eb>] _nv000410rm+0x2b/0x30 [nvidia]
[<f92a2de4>] _nv006353rm+0x49c/0x4a8 [nvidia] [<f91d065d>] _nv005103rm+0x19/0x40 [nvidia]
[<f922e44b>] _nv003507rm+0x197/0x484 [nvidia] [<f922e43b>] _nv003507rm+0x187/0x484 [nvidia]
[<f916c540>] _nv000436rm+0x20/0xa0 [nvidia] [<f92285d0>] _nv003514rm+0x90/0xd4 [nvidia]
[<f9079cfc>] _nv002448rm+0x58/0x100 [nvidia] [<f91d070b>] _nv005100rm+0x23/0x28 [nvidia]
[<f908d1a7>] _nv001646rm+0x87/0xa8 [nvidia] [<c02bf8e9>] pci_read+0x29/0x2e
[<f909161f>] rm_isr_bh+0x47/0x74 [nvidia] [<f909163a>] rm_isr_bh+0x62/0x74 [nvidia]
[<c012e234>] run_timer_softirq+0x13c/0x1b2 [<f92b285b>] nv_kern_isr_bh+0x1e/0x23 [nvidia]
[<c012a50b>] tasklet_action+0x52/0xb3 [<c012a1f2>] __do_softirq+0x72/0xdc
[<c0106383>] do_softirq+0x4b/0x4f
=======================
[<c0106265>] do_IRQ+0x55/0x86 [<c0104a7a>] common_interrupt+0x1a/0x20
[<c032007b>] xfrm_state_update+0xeb/0x18a [<c017bd0c>] do_select+0x153/0x303
[<c017ba21>] __pollwait+0x0/0x97 [<c017c0ba>] sys_select+0x1e6/0x38f
[<c0169833>] vfs_read+0x151/0x158 [<c0104035>] syscall_call+0x7/0xb
NVRM: Xid: 13, 0000 02005f00 0000009f 00000300 0010c300 00000002
Debug: sleeping function called from invalid context at mm/slab.c:2499
in_atomic():1, irqs_disabled():0
[<c0152f34>] __kmalloc+0x8d/0x8f [<f92b33d1>] nv_alloc_kernel_mapping+0x14e/0x26a [nvidia]
[<f908a218>] _nv002326rm+0x78/0xd4 [nvidia] [<f91ae201>] _nv005646rm+0x389/0x440 [nvidia]
[<f91cfd1a>] _nv004902rm+0x8a/0x94 [nvidia] [<f90893b2>] _nv002276rm+0x1a/0x20 [nvidia]
[<f91e266d>] _nv004829rm+0xd1/0x16c [nvidia] [<f91e2685>] _nv004829rm+0xe9/0x16c [nvidia]
[<f907a7cd>] _nv002423rm+0x1d/0x2c [nvidia] [<f926a89f>] _nv001858rm+0x28b/0x504 [nvidia]
[<f926a886>] _nv001858rm+0x272/0x504 [nvidia] [<f907a603>] _nv002429rm+0x6f/0x84 [nvidia]
[<f926c4e8>] _nv001849rm+0xd4/0x12c [nvidia] [<f91cf9f1>] _nv005136rm+0x441/0x484 [nvidia]
[<f926a415>] _nv001856rm+0x1d5/0x240 [nvidia] [<f926a3f2>] _nv001856rm+0x1b2/0x240 [nvidia]
[<f91fb84f>] _nv004609rm+0xcfb/0xf90 [nvidia] [<f91d070b>] _nv005100rm+0x23/0x28 [nvidia]
[<f91d070b>] _nv005100rm+0x23/0x28 [nvidia] [<f907a7cd>] _nv002423rm+0x1d/0x2c [nvidia]
[<f907a7d6>] _nv002423rm+0x26/0x2c [nvidia] [<f907a7cd>] _nv002423rm+0x1d/0x2c [nvidia]
[<f91d070b>] _nv005100rm+0x23/0x28 [nvidia] [<f907a7d6>] _nv002423rm+0x26/0x2c [nvidia]
[<f91d065d>] _nv005103rm+0x19/0x40 [nvidia] [<f91d070b>] _nv005100rm+0x23/0x28 [nvidia]
[<f91d065d>] _nv005103rm+0x19/0x40 [nvidia] [<f908ace6>] _nv002304rm+0x1a/0x6c [nvidia]
[<f907a7d6>] _nv002423rm+0x26/0x2c [nvidia] [<f922e44b>] _nv003507rm+0x197/0x484 [nvidia]
[<f922e43b>] _nv003507rm+0x187/0x484 [nvidia] [<f916c540>] _nv000436rm+0x20/0xa0 [nvidia]
[<f92285d0>] _nv003514rm+0x90/0xd4 [nvidia] [<f9079cfc>] _nv002448rm+0x58/0x100 [nvidia]
[<f91d070b>] _nv005100rm+0x23/0x28 [nvidia] [<f908d1a7>] _nv001646rm+0x87/0xa8 [nvidia]
[<c02bf8e9>] pci_read+0x29/0x2e [<f909161f>] rm_isr_bh+0x47/0x74 [nvidia]
[<f909163a>] rm_isr_bh+0x62/0x74 [nvidia] [<f92b285b>] nv_kern_isr_bh+0x1e/0x23 [nvidia]
[<c012a50b>] tasklet_action+0x52/0xb3 [<c012a1f2>] __do_softirq+0x72/0xdc
[<c0106383>] do_softirq+0x4b/0x4f
=======================
[<c0106265>] do_IRQ+0x55/0x86 [<c0104a7a>] common_interrupt+0x1a/0x20

Last edited by kbellve; 03-15-06 at 03:28 PM.
kbellve is offline  
Old 03-15-06, 03:31 PM   #402
cdrw
Registered User
 
Join Date: Mar 2006
Posts: 59
Default Re: "screen frozen, but mouse pointer moves" bug

nv driver worked for me too, however in my specific case in SuSE, prelink was causing GUI freeze with both linux AGPGART and NvAGP.

removing prelink resolved problem for me and now I have 3D acceleration with AGPGART or NvAGP working without any problems.



I dont think that you can enable NvAGP if AGPGART is build in (even as a module) the kernel. For whatever reason AGPGART is blocking NvAGP (NVAGP option 1), even if AGPGART is build as a module.

In my case, I had to remove AGPGART completely from the kernel to run NvAGP.
So if I am right, you will have to re-compile kernel without AGPGART (in 64-bit linux you will have to remove 3GB RAM support for 32-bit apps, which is not used usually anyways).

I hope that this will help (maybe). At least collecting all info regarding GUI freezeng problems with moving mouse cursor.
cdrw is offline  
Old 03-22-06, 04:26 AM   #403
PsypherPunk
Registered User
 
Join Date: Jun 2005
Posts: 3
Default Re: "screen frozen, but mouse pointer moves" bug

Looks like a change of graphics card has fixed it here. Normally i can replicate the problem on demand; since i switch it hasn't appeared and i can't cause it.

For reference:

Motherboard: ASRock KVT74A Pro
Old card: Nvidia Geforce MX 4000
New card: Nvidia Geforce 6600GT

The error occured when using SuSE 9.2, SuSE 10.0, Slackware 10.2, Debian 3.1, Ubuntu 5.10 with stock kernels. Tested with Xorg 6.8.2 and 6.9.0.
PsypherPunk is offline  
Old 03-28-06, 09:43 PM   #404
steo
Registered User
 
Join Date: Mar 2006
Posts: 2
Default Re: "screen frozen, but mouse pointer moves" bug

I seem to have fixed the problem by commenting out load glx in the modules section and setting Option NvAGP to 1 in xorg.conf.

But why do I have to not load glx?

At least the system seems more stable now.

---------------------------------
Ubuntu 5.10 Breezy Badger AMD64 SMP
Asus Geforce 6200 128MB
Tyan K8W motherboard
nvidia driver 1.0.7667
steo is offline  

Old 03-28-06, 10:34 PM   #405
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: "screen frozen, but mouse pointer moves" bug

if you don't load glx, than there is no point in using the nvidia driver at all.

Use the nv driver instead and at least it should be hassle free.
energyman76b is offline  
Old 03-29-06, 02:24 PM   #406
steo
Registered User
 
Join Date: Mar 2006
Posts: 2
Default Re: "screen frozen, but mouse pointer moves" bug

But when I use the 'nv' driver, I get the "screen frozen but mouse pointer moves" bug.

---------------------------------
Ubuntu 5.10 Breezy Badger AMD64 SMP
Asus Geforce 6200 128MB
Tyan K8W motherboard
nvidia driver 1.0.7667
steo is offline  
Old 03-31-06, 08:40 AM   #407
Hexa
Registered User
 
Join Date: Mar 2006
Posts: 2
Default Re: "screen frozen, but mouse pointer moves" bug

Any news about this subject? Still getting same behavior.
I tried all the ideas proposed in this thread. I don't want to flash BIOS yet, Everything works OK in Windows.....

Any guru with new answers?
Hexa is offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:24 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.