Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-13-04, 01:29 AM   #1
token
Food eater
 
token's Avatar
 
Join Date: Jul 2004
Location: Rock Creek, Ohio
Posts: 10
Default nvidia.ko will not build, no matter what I do..

I'm the last person in the world to admit to defeat and to ask for help on a forum.. I'm stubborn

But this error has gotten the best of me.. I will paste a log of my manual 'make install' to show you what I mean. Somebody, please please help.. Linux sucks with a card that only works 1/4 of its potential..

NOTE: I am using a 2.6.7 kernel. The card I am using is an nvidia GeForce2 MX 400

I have seen this question asked in a lot of spots, but never have I seen an answer that worked.. I checked all my software, updated GCC, reconfigured and rebuilt my kernel a number of times, installed mod-init-tools, uninstalled X and KDE, reinstalled X and KDE.. nothing has worked yet.

It has been 1 week of me being stubborn.

bash-2.05b# make install
cd usr/src/nv; make install
make[1]: Entering directory `/home/token/NVIDIA-Linux-x86-1.0-6106-pkg1/usr/src/nv'
make[2]: Entering directory `/usr/src/linux-2.6.7'
Building modules, stage 2.
MODPOST
make[2]: Leaving directory `/usr/src/linux-2.6.7'
FATAL: Error inserting nvidia (/lib/modules/2.6.7/kernel/drivers/video/nvidia.ko): Invalid module format
make[1]: *** [package-install] Error 1
make[1]: Leaving directory `/home/token/NVIDIA-Linux-x86-1.0-6106-pkg1/usr/src/nv'
make: *** [kernel_module_install] Error 2
token is offline   Reply With Quote
Old 07-14-04, 03:03 PM   #2
chrismortimore
Registered User
 
Join Date: Jul 2004
Posts: 131
Default Re: nvidia.ko will not build, no matter what I do..

Just a couple of stupid questions.

1. Have you tried just running the nvidia installer and not extracting its contents?
2. Have you tried to download it again just in case something silly happened down the interweb line?
3. Did you modify the source of the nvidia module?

I got my Geforce FX Go5200 working fine with 2.6.7, but then I discovered not much else worked with 2.6.7, hence just now I'm on 2.6.6
chrismortimore is offline   Reply With Quote
Old 07-16-04, 11:32 AM   #3
FOXX
Registered User
 
Join Date: Jun 2004
Posts: 5
Default Re: nvidia.ko will not build, no matter what I do..

I have the SAME problem on the 2.6.6 kernel and never found a solution. I'm running Slack 9.1 and I'd just be content to get the damn module inserted after building.
FOXX is offline   Reply With Quote
Old 07-16-04, 01:40 PM   #4
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: nvidia.ko will not build, no matter what I do..

FATAL: Error inserting nvidia (/lib/modules/2.6.7/kernel/drivers/video/nvidia.ko): Invalid module format

The module loader typically comments this kind of error, check the output of dmesg after a failed attempt to load nvidia.ko; chances are the compiler or configuration didn't match the kernel.
zander is offline   Reply With Quote
Old 07-19-04, 04:48 PM   #5
token
Food eater
 
token's Avatar
 
Join Date: Jul 2004
Location: Rock Creek, Ohio
Posts: 10
Default Re: nvidia.ko will not build, no matter what I do..

Quote:
Originally Posted by chrismortimore
Just a couple of stupid questions.

1. Have you tried just running the nvidia installer and not extracting its contents?
2. Have you tried to download it again just in case something silly happened down the interweb line?
3. Did you modify the source of the nvidia module?

I got my Geforce FX Go5200 working fine with 2.6.7, but then I discovered not much else worked with 2.6.7, hence just now I'm on 2.6.6
1. Yes, tried that many many times, tried different versions, older ones, pre-2.6 ones that were 2.6 patched, tried many times with the regular installer.

2. I think 1 might be able to cover 2 too.. (heh.. tu-tu)

3. I never mess with source code unless im bored.. Thats a negatory on that, roger!
token is offline   Reply With Quote
Old 07-19-04, 04:49 PM   #6
token
Food eater
 
token's Avatar
 
Join Date: Jul 2004
Location: Rock Creek, Ohio
Posts: 10
Default Re: nvidia.ko will not build, no matter what I do..

Quote:
Originally Posted by zander
FATAL: Error inserting nvidia (/lib/modules/2.6.7/kernel/drivers/video/nvidia.ko): Invalid module format

The module loader typically comments this kind of error, check the output of dmesg after a failed attempt to load nvidia.ko; chances are the compiler or configuration didn't match the kernel.
I'll check that and post my findings.
token is offline   Reply With Quote
Old 07-19-04, 04:54 PM   #7
token
Food eater
 
token's Avatar
 
Join Date: Jul 2004
Location: Rock Creek, Ohio
Posts: 10
Default Re: nvidia.ko will not build, no matter what I do..

Quote:
bash-2.05b# /sbin/modprobe nvidia
FATAL: Error inserting nvidia (/lib/modules/2.6.7/kernel/drivers/video/nvidia.ko): Invalid module format
bash-2.05b# /bin/dmesg
nvidia: disagrees about version of symbol struct_module
bash-2.05b#
Theres my output.. Any ideas?
token is offline   Reply With Quote
Old 07-20-04, 10:16 AM   #8
chrismortimore
Registered User
 
Join Date: Jul 2004
Posts: 131
Default Re: nvidia.ko will not build, no matter what I do..

Errmmm... Maybe you have updated your GCC since compiling your kernel, seems to cause problems. Otherwise you've stumped me and should file a bug report with nvidia.
__________________
[ www.guff.tk ]
chrismortimore is offline   Reply With Quote

Old 07-20-04, 10:38 AM   #9
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: nvidia.ko will not build, no matter what I do..

The NVIDIA kernel module picks up this kind of version information from the kernel source tree, mismatches suggest that the kernel source tree (or its configuration) doesn't correspond to the running kernel.
zander is offline   Reply With Quote
Old 07-20-04, 04:11 PM   #10
afdf
Registered User
 
Join Date: Jul 2004
Posts: 4
Default Re: nvidia.ko will not build, no matter what I do..

make sure "assign IRQ to AGP" is checked in your bios
afdf is offline   Reply With Quote
Old 07-22-04, 05:14 AM   #11
token
Food eater
 
token's Avatar
 
Join Date: Jul 2004
Location: Rock Creek, Ohio
Posts: 10
Default Re: nvidia.ko will not build, no matter what I do..

I only updated GCC because the nvidia module wasn't compiled. I saw that it may be do to an older version. It didnt compile with the older version or the newer version.

This is starting to confuse me though..
token is offline   Reply With Quote
Old 07-22-04, 11:14 PM   #12
token
Food eater
 
token's Avatar
 
Join Date: Jul 2004
Location: Rock Creek, Ohio
Posts: 10
Default Re: nvidia.ko will not build, no matter what I do..

I should also add some more info about my setup..

It is Mandrake 10 (very pointless to say now, since i rebuilt most of it from scratch), a K7TA motherboard, an AWARD bios, with an AMD Athlon 1ghz processor and 256mb of ram.
token is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Video: High Schoolers Build Supercomputer in Ontario News Archived News Items 0 06-01-12 12:10 PM
Diablo 3 Wizard build guide News Archived News Items 0 05-30-12 02:40 PM
Build versus buy: One company's decision to go it alone News Archived News Items 0 05-13-12 08:40 PM
Diablo 3 build guide: Barbarian, Demon Hunter, Monk, Witch Doctor and Wizard News Archived News Items 0 05-12-12 12:00 PM
My source RPM won't build right! z28Power NVIDIA Linux 5 09-18-02 11:55 AM

All times are GMT -5. The time now is 07:27 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.