Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-24-02, 04:53 PM   #1
sdv
Registered User
 
Join Date: Oct 2002
Location: MI
Posts: 6
Question inspiron 8200 laptop redhat 8.0 XF86Config for Force 4 440 Go

I installed the NV 1.0-3123 kernel and GLX rpms from src files. I had XWindows working fine under the previous (2160 ) version of the driver under redhat 7.2.

Under redhat 8.0, with NV 3123, and several modifications of my previous XF86Config file, I am unable to get past the NVIDIA Logo.

I used the startx -- -verbose 10 -logverbose to capture additional information to debug. There are no (EE) or (WW) errors or warnings.

The actual files are at http://www.cs.wayne.edu/~sdv/nvidia

Any suggestion will be greatly appreciated.

I could not determine the exact HorizSync and VertRefresh rates for the 17" LCD display.
__________________
Dell Inspiron 8200 GeForce4 440 GO
sdv is offline   Reply With Quote
Old 10-24-02, 06:05 PM   #2
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Quote:
NVRM: AGPGART: unknown chipset
Found this in your dmesg... it might help to pass agp_try_unsupported=1 to the agpgart module. Open up /etc/modules.conf and add a line:

options agpgart agp_try_unsupported=1

Save, and run /sbin/depmod -a (do all of this as root). Then reboot (well, you wouldn't have to reboot, but it's the easiest way to do it) and see if you get any better results.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 10-24-02, 06:55 PM   #3
sdv
Registered User
 
Join Date: Oct 2002
Location: MI
Posts: 6
Default

Included the
options agpgart agp_try_unsupported=1

and

options NVdriver NVreg_Mobile=1

(which I read from the nvidia pdf file)
in my /etc/modules.conf

The problem persists.

Here is some history:
1. redhat 7.2 and the 2160 drivers work fine for months
2. The only change I made to the system was install the yahoo messenger rpm
3. startx does not work any more
4. new version of the nvidia drivers 3123 does not help
5. Upgrade to the redhat 8.0, remove the old NVIDIA drivers and compile/rpmbuild the source rpms of 3123 drivers - problem persists
__________________
Dell Inspiron 8200 GeForce4 440 GO
sdv is offline   Reply With Quote
Old 10-25-02, 12:11 AM   #4
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Does removing the yahoo messenger rpm help?

There should be other programs that will allow you to connect to Yahoo's service. gaim might, jabber might, and there are others. Check a few of those out first, and see if they work any better.

Since the YM rpm seems to have broken things, it wouldn't surprise me to learn that they screwed up something in your configuration. Unless... where did you get that rpm from?
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 10-25-02, 11:13 AM   #5
sdv
Registered User
 
Join Date: Oct 2002
Location: MI
Posts: 6
Default

I downloaded yahoo messenger from Yahoo.

I removed the rpm (rpm -e) as the first thing to fix my startx.

But the problem persists
__________________
Dell Inspiron 8200 GeForce4 440 GO
sdv is offline   Reply With Quote
Old 10-25-02, 01:19 PM   #6
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

When you're seeing the nVidia logo, does Ctrl-Alt-Backspace kill off X?

Before you try this, you should be booting to runlevel 3 instead of 5 -- oh, wait, never mind. You are. OK, try it and see if you get a console back or not. Maybe that will give you a meaningful message...

You might end up having to reinstall to really clean out the YM package... assuming that's what caused the problem. Since you got it from Yahoo, as opposed to somewhere like http://freshmeat.net, it wouldn't be too surprising if the people that put it together weren't quite aware of the way things work in Linux... at least if they had it posted on Freshmeat, then you could be reasonably sure that it replacing needed files wasn't the problem, but as it is, I don't know.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 10-25-02, 03:32 PM   #7
sdv
Registered User
 
Join Date: Oct 2002
Location: MI
Posts: 6
Default

I had windows XP installed on a separate partition. I also have a partition (VFAT) shared between linux and windows xp. I mounted the shared partition from linux, backed up all my data files.
Re-installed redhat 8.0 from CD, under the same partitions as earlier. Redhat identified Nvidia 440 (generic) driver. It however did not detect the monitor. I chose the Dell 1600x Laptop screen instead of the generic unknown. I tested a few variations and finally the 16bit color for 1600x1200 display was perfect. I wish it could handle 24 bit

I guess I found a workaround.
__________________
Dell Inspiron 8200 GeForce4 440 GO
sdv is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 07:48 PM
Redhat 8.0, no rpm, can't compile. Ironphil NVIDIA Linux 6 10-02-02 04:13 PM

All times are GMT -5. The time now is 10:06 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.