Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-08-04, 06:36 AM   #1
mhenn
Registered User
 
Join Date: Aug 2004
Posts: 4
Question Black screen when X starts

Hello,

I have a problem using the nvidia drivers (6111). Upon starting x the screen will go black and the system will become unresponsive. CTRL-ALT-DEL and CTRL-ALT-BACKSPACE do nothing, and a hard reset is required.

X works perfectly with the open-source 'nv' driver, but trying to start with driver 'nvidia' always results in this problem.

I installed the 6106 driver, but the problem remains. (I also tried to install 5336, but the kernel module refused to compile against my 2.6.7 kernel.)

I have tried changing the resolution and Option "NvAGP" "0", but that doesn't have any effect.

Some information on my system:

Gentoo system running with a manually compiled vanilla 2.6.7 kernel.
Athlon processor and nForce2 based motherboard (GA-7N400E-L)
Graphics card is a Leadtek A360TDH (GeForce FX5700)
X.org server

I have attached my Xorg.conf file and /var/log/Xorg.0.log at verbosity 5

Any ideas?

Thanks,
Mark.
Attached Files
File Type: txt xorg.conf.txt (2.1 KB, 167 views)
File Type: txt xorg.0.log.txt (26.1 KB, 149 views)
mhenn is offline   Reply With Quote
Old 08-08-04, 07:38 PM   #2
whig
550Ti
 
Join Date: Jan 2004
Location: New Zealand
Posts: 854
Default Re: Black screen when X starts

Is the nvidia-glx package installed? Have you run opengl-update?
whig is offline   Reply With Quote
Old 08-10-04, 03:03 AM   #3
mhenn
Registered User
 
Join Date: Aug 2004
Posts: 4
Default Re: Black screen when X starts

I have been using the driver from nviida, not the gentoo ebuilds, so no. some people seem to think this is a bad idea, but i have yet to have a reason why. The only problem I can see is a minor difficulty when trying to update X through portage.

I have just solved the problem, if anyone is interested, by disabling 4k stacks and recompiling the kernel.

Thanks for the suggestions, in any case.
mhenn is offline   Reply With Quote
Old 08-10-04, 06:02 AM   #4
can|s|_ycan
Registered User
 
Join Date: Jul 2004
Posts: 12
Default Re: Black screen when X starts

Ooooo, yeah, that's your problem right there >>> Graphics card is a Leadtek A360TDH (GeForce FX5700)

FX5700 was giving me some major migraines and burnt several weeks of my loser life trying to fix the hard-lock thing...bugs in X or driver dunno...Finally, I just stuck a 5200 card in and issues go by-by. (I stuck the 5700 card in a win box and it works fine over 'there')
can|s|_ycan is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
GT240M - black screen with newer drivers > 275.33 and win 7 doktor5000 NVIDIA GeForce 200 Series 1 07-08-12 11:17 AM
[9800gt] Xorg black screen after installing nvidia driver HacKurx NVIDIA Linux 1 06-07-12 01:29 PM
Black screen after switching between graphical virtual consoles five times rrr-wtf NVIDIA Linux 1 05-21-12 04:40 PM
Black screen and lockup on startx. redmoose NVIDIA Linux 4 09-18-02 11:53 AM
kernel 2.4.19 and 2960 -> black screen osterhase NVIDIA Linux 7 08-22-02 06:24 PM

All times are GMT -5. The time now is 01:57 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.