Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-27-04, 03:55 AM   #1
Caraflan
Registered User
 
Join Date: Jul 2004
Posts: 17
Red face framebuffer with vga=791

WELLCOME TO CARAFLAN'S MONOLOGUE

driver 53dontknowwhat
kernel 2.6.7
debian sid
twinview enabled (dont know if that matters)

Can someone tell if framebuffer doesn't works because of nvidia driver or is xlibs fault?
didn't tried all modes, but i think that the better one that works is 800x600x256 (in lilo 773.. or 771.. dont remember.)

All modes works perfect until the xserver is launched

Maybe will try the olds drivers with and 2.4 kernel (now in job :^P)

¡¡LoL!! look at these bananas ->
they are doing nasty things, isnt?

found severall pages saying that vesafb works with nvidia driver, but not rivafb, im using vesafb (y in kernel)
can i use nvidia driver as framebuffer driver?

bye

Last edited by Caraflan; 07-27-04 at 01:56 PM.
Caraflan is offline   Reply With Quote
Old 07-27-04, 06:31 AM   #2
Caraflan
Registered User
 
Join Date: Jul 2004
Posts: 17
Default Re: framebuffer with vga=791

ok, readed more, seems that i can't have a decent fb console with nvidia driver.
im feeling like the banana that is being sodomized

Last edited by Caraflan; 07-27-04 at 07:46 AM.
Caraflan is offline   Reply With Quote
Old 07-27-04, 01:50 PM   #3
Caraflan
Registered User
 
Join Date: Jul 2004
Posts: 17
Default Re: framebuffer with vga=791

well, got it working with driver 4349 in 2.4.26 kernel..
a nice console: 1024x768, framebuffer, PINK!?!?
seems that someone in nvidia loves pink color... for sure the one behind -> (hehe, usefull smiley)
all seems to work ok thanks developers

Last edited by Caraflan; 07-27-04 at 02:01 PM.
Caraflan is offline   Reply With Quote
Old 07-27-04, 05:01 PM   #4
Caraflan
Registered User
 
Join Date: Jul 2004
Posts: 17
Default Re: framebuffer with vga=791

LOL that is not ok, video playing in the console is pink too :''''(
all ok with 4191 driver
thanks a lot

Last edited by Caraflan; 07-27-04 at 05:18 PM.
Caraflan is offline   Reply With Quote
Old 07-28-04, 05:29 AM   #5
Caraflan
Registered User
 
Join Date: Jul 2004
Posts: 17
Cool Re: framebuffer with vga=791

can someone help with glx installation for 2.6.7 and old nvidia 4191 driver patched with patches in www.minion.de?

driver module patched works fine in 2.6 but im unable to use neither the new or old opengl libraries, i need to disable load "glx" from my x config to run the x server.

can someone help?

for more monologues visit www.monologuesbycaraflan.com
Caraflan is offline   Reply With Quote
Old 07-28-04, 05:46 AM   #6
PrakashP
gentoo ~x86_64 user
 
PrakashP's Avatar
 
Join Date: Jul 2004
Location: Germania
Posts: 213
Default Re: framebuffer with vga=791

*Don't* use any kind of framebuffer. Here the Vesa one works, but slows down glx.
PrakashP is offline   Reply With Quote
Old 07-28-04, 07:41 AM   #7
Caraflan
Registered User
 
Join Date: Jul 2004
Posts: 17
Default Re: framebuffer with vga=791

thanks to stop letting me speak alone but i need framebuffer
Caraflan is offline   Reply With Quote
Old 07-28-04, 08:33 AM   #8
SuLinUX
 
SuLinUX's Avatar
 
Join Date: Sep 2003
Location: UK
Posts: 847
Default Re: framebuffer with vga=791

What has the frambuffer got to do with the nvidia driver, it's the kernel that provides your framebuffer.
__________________
AthlonXP 2600+ / nForce2 Asus A7N8X-X / PNY GeForce FX5900 Ultra / 1024Mb Samsung Ram /nForce Sound / Hansol 920D Plus 19" monitor / Lite-On 32x12x40 / 2x Maxtor HD 40Gb/80Gb / nVidia 7174 driver / Gnome 2.10.1 / Kernel 2.6.11.9 / Slackware 10.0
SuLinUX is offline   Reply With Quote

Old 07-28-04, 08:55 AM   #9
Caraflan
Registered User
 
Join Date: Jul 2004
Posts: 17
Default Re: framebuffer with vga=791

Quote:
Originally Posted by SuLinUX
What has the frambuffer got to do with the nvidia driver, it's the kernel that provides your framebuffer.
Story of my life:
newer versions of nvidia driver makes framebuffered consoles to 'disappear' when xserver starts.
then i went back to a driver that works with framebuffer (and dont give a pink console XD), that one was 4191,
but 4191 was a driver for 2.4 kernels, and 2.4 cdcether kernel module give me some problems (sometimes I get my connection broken),
so I'm now trying to make use 4191 driver with 2.6.7 kernel, and it works, but glx extension not (glx extension works ok on 2.4.26 with 4191 driver).
I dont know anything of glx, so..
can i make it work in 2.6.7 with patched 4191 driver?
there are others solutions like a non nvidia glx that will work?
am i the most beautiful girl in the world?

thanks
Caraflan is offline   Reply With Quote
Old 07-30-04, 02:58 PM   #10
Caraflan
Registered User
 
Join Date: Jul 2004
Posts: 17
Default Re: framebuffer with vga=791

can someone help me with vesafb-tng patch?
in kernel 2.6.7 with debian patches it doesn't works
in kernel 2.6.7 without debian patches it works, but boot process freezes after checking previous state os serial ports (previous, stored or something similar can't remember)
help will be granted with sex
bye
Caraflan is offline   Reply With Quote
Old 07-30-04, 07:56 PM   #11
PrakashP
gentoo ~x86_64 user
 
PrakashP's Avatar
 
Join Date: Jul 2004
Location: Germania
Posts: 213
Default Re: framebuffer with vga=791

@SuLinux
Both use the same graphic memory...
PrakashP is offline   Reply With Quote
Old 08-03-04, 06:05 AM   #12
Caraflan
Registered User
 
Join Date: Jul 2004
Posts: 17
Default Re: framebuffer with vga=791

got vesafb-tng working with 2.6.7 with debian patches (great job Mr.Spock )
now all works:
nvidia driver 5336
glx
twinview
1024x768-16 framebuffer console

But now I get segmentation faults in some applications like gcc (3.3), dpkg and vdr (all these stuff for vdr and now it doesn't works...)
My first though was: Can't be possible that a framebuffer patch can do that!, but then though that both vesafb and nvidia make use of video memory.., maybe are getting more than must...or not, don't know about these thing..
Caraflan is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
bad cursor after X in framebuffer console wintersky NVIDIA Linux 11 11-07-03 12:59 PM
GF4 - can't get framebuffer working (tried rivafb and vesafb)! roger NVIDIA Linux 2 10-08-02 07:56 PM
Framebuffer console mascot NVIDIA Linux 1 09-14-02 10:18 AM
Can I use 3-D acceleration in the framebuffer coredumped NVIDIA Linux 3 08-24-02 02:20 PM

All times are GMT -5. The time now is 07:11 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.