Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-29-04, 12:12 PM   #1
sAvAgE-SMP
Registered User
 
Join Date: Jul 2004
Posts: 23
Unhappy NVIDIA Driver 6106 Problems

All Works great in Driver 5336, but when I use 6106 the games wont run. Its wierd the module loads, nvidia splash screen works, glxgears work but q3, ut2004 wont work

edit: I tried also using 6106 on a fresh install and still the same thing, seems I have to reinstall gentoo to put in the 5336 driver to get things to work. I am doing a fresh install at home again so please any suggestions to get the 6106 driver to work with my rig, cause knowing my luck Doom 3 will require the latest Nvidia Driver.
Error message
code:--------------------------------------------------------------------------------
rob@devel rob $ ut2004
Xlib: extension "XFree86-DRI" missing on display ":0.0".
WARNING: ALC_EXT_capture is subject to change!
Xlib: extension "XiG-SUNDRY-NONSTANDARD" missing on display ":0.0".
Either GL_EXT_bgra or glDrawRangeElements not supported- bailing out.

History:

Exiting due to error
--------------------------------------------------------------------------------


P.S. I am Using Gentoo 2004.1, My Window is Xfree86-4.3.0-r7 and kernel 2.6.7 SMP Enabled


__________________
(Devel) Gentoo 2004.1 | PC-DL Deluxe | 1GB Kingston PC3200 Dual Channel CL3 | 2 x 2.8/533 Xeons | GeForce FX 5900XT | 80GB WDC SE 8mb Cache HDD | 2 X 2.8/533 | Linux 2.6.7

Last edited by sAvAgE-SMP; 07-29-04 at 12:24 PM.
sAvAgE-SMP is offline   Reply With Quote
Old 07-29-04, 04:12 PM   #2
PrakashP
gentoo ~x86_64 user
 
PrakashP's Avatar
 
Join Date: Jul 2004
Location: Germania
Posts: 213
Default Re: NVIDIA Driver 6106 Problems

glxinfo?
PrakashP is offline   Reply With Quote
Old 07-29-04, 05:44 PM   #3
sAvAgE-SMP
Registered User
 
Join Date: Jul 2004
Posts: 23
Default Re: NVIDIA Driver 6106 Problems

I am reinstalling and finishing it up tonight and I will install from the nvidia site the 6106 Drivers and I will get all that information should only take me a few hours to compile Xfree and gnome and kde and install the Drivers
sAvAgE-SMP is offline   Reply With Quote
Old 07-29-04, 09:54 PM   #4
kgroombr
Using Linux Since 1995
 
Join Date: Sep 2002
Posts: 130
Default Re: NVIDIA Driver 6106 Problems

Had this problem, I copied this from a post I put on bugzilla.icculus.org for ut2004:

I found systems with this problem. Also my system had this problem after
installing some updates via portage on Gentoo. Here is one fix, may or may not
work:

In the ut2004 install directory, go to the System directory. Type:

ln -s /usr/lib/libGL.so.1
ln -s /usr/lib/libGLcore.so.1

Of course these assume that these files are in /usr/lib, but just fix the path
for your install.

If this doesn't work, this is the solution for Gentoo:

emerge the latest kernel-headers
emerge the latest glibc

This will build glibc for your system. I believe it was a glibc update that
causes ut2004 not to "see" the opengl libs. Rebuilding glibc with the correct
headers fixed it. You shouldn't need the above links in your System directory
after this fix.

Strange that all other games worked fine except for ut2004. Thankfully I was
able to determine that one of the major changes to my system between when ut2004
worked and didn't work was the emerge of glibc. For some reason though, when
emerging glibc, it didn't emerge the latest kernel-headers.

Oh yeah, should reboot after this as well. All works fine now for me.
__________________
Kenton A. Groombridge
kgroombr@comcast.net
http://home.comcast.net/~kgroombr/
kgroombr is offline   Reply With Quote
Old 07-30-04, 12:42 AM   #5
whig
550Ti
 
Join Date: Jan 2004
Location: New Zealand
Posts: 854
Default Re: NVIDIA Driver 6106 Problems

Is the nvidia-glx-1.0.6106 package installed? Have you run opengl-update?
whig is offline   Reply With Quote
Old 07-30-04, 09:45 AM   #6
sAvAgE-SMP
Registered User
 
Join Date: Jul 2004
Posts: 23
Default Re: NVIDIA Driver 6106 Problems

Had problems with my server last night but managed to install Xfree 4.3.0 KDE and Gnome the openGL update in portage tree was OpenGL-update 1.78 or 1.71 will get it up and runinng tonight with the 6106 then let the questions begin
sAvAgE-SMP is offline   Reply With Quote
Old 07-30-04, 12:58 PM   #7
forky
Registered User
 
Join Date: Oct 2003
Posts: 4
Angry Re: NVIDIA Driver 6106 Problems

Using slackware-current, 2.6.7 kernel, and Dell D800 (A10 BIOS) with GeForce4 Ti4200 Go, I get random hard freezes when in X within 5 minutes to 2 hours using the 6106 Nvidia driver. Switching back to 5336 version, I don't see these problems. I guess I'll wait until the driver becomes more stable.
forky is offline   Reply With Quote
Old 07-30-04, 11:33 PM   #8
sAvAgE-SMP
Registered User
 
Join Date: Jul 2004
Posts: 23
Default Re: NVIDIA Driver 6106 Problems

ok I am up and running and I will just be installing the 6106 Nvidia drivers on my System and get my FX5900XT up and running just a few things of info from my system before I start
[code]
savage@devel savage $ uname -a
Linux devel 2.6.7 #2 SMP Thu Jul 29 00:54:48 MDT 2004 i686 Intel(R) Xeon(TM) CPU 2.80GHz GenuineIntel GNU/Linux
savage@devel savage $
[code]
if there are any commands that you wish to see after I install the Nvidia Drivers please let me know just going to install them now
sAvAgE-SMP is offline   Reply With Quote

Old 07-30-04, 11:47 PM   #9
sAvAgE-SMP
Registered User
 
Join Date: Jul 2004
Posts: 23
Default Re: NVIDIA Driver 6106 Problems

OK here is the scoop I just installed the 6106 and here it goes

under /etc/modules.autoload there is

nvidia
rebooted the machine after mounting /dev/hda1 and installing the 6106 Driver

nvidia module loaded? == yes
nvidia splash == yes
modified /etc/X11/XF86Config == yes

glxinfo?

savage@devel savage $ glxinfo
name of display: :0.0
Xlib: extension "XFree86-DRI" missing on display ":0.0".
display: :0 screen: 0
direct rendering: No
server glx vendor string: NVIDIA Corporation
server glx version string: 1.3
server glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig,
GLX_SGIX_pbuffer, GLX_SGI_video_sync, GLX_SGI_swap_control,
GLX_ARB_multisample, GLX_NV_float_buffer
client glx vendor string: SGI
client glx version string: 1.2
client glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce FX 5900XT/AGP/SSE2
OpenGL version string: 1.5.1 NVIDIA 61.06
OpenGL extensions:
GL_ARB_multitexture, GL_EXT_blend_minmax, GL_EXT_blend_color,
GL_ARB_imaging
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x21 24 tc 0 32 0 r y . 8 8 8 0 0 24 8 16 16 16 16 0 0 None
0x22 24 dc 0 32 0 r y . 8 8 8 0 0 24 8 16 16 16 16 0 0 None
0x23 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 0 0 None
0x24 24 tc 0 32 0 r . . 8 8 8 0 0 24 8 16 16 16 16 0 0 None
0x25 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 0 0 None
0x26 24 tc 0 32 0 r y . 8 8 8 0 0 16 0 16 16 16 16 0 0 None
0x27 24 tc 0 32 0 r y . 8 8 8 8 0 16 0 16 16 16 16 0 0 None
0x28 24 tc 0 32 0 r . . 8 8 8 0 0 16 0 16 16 16 16 0 0 None
0x29 24 tc 0 32 0 r . . 8 8 8 8 0 16 0 16 16 16 16 0 0 None
0x2a 24 tc 0 32 0 r y . 8 8 8 0 0 0 0 16 16 16 16 0 0 None
0x2b 24 tc 0 32 0 r y . 8 8 8 8 0 0 0 16 16 16 16 0 0 None
0x2c 24 tc 0 32 0 r . . 8 8 8 0 0 0 0 16 16 16 16 0 0 None
0x2d 24 tc 0 32 0 r . . 8 8 8 8 0 0 0 16 16 16 16 0 0 None
0x2e 24 tc 0 32 0 r y . 8 8 8 0 0 24 8 16 16 16 16 0 0 Ncon
0x2f 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 0 0 Ncon
0x30 24 tc 0 32 0 r y . 8 8 8 0 0 24 8 16 16 16 16 0 0 Ncon
0x31 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 0 0 Ncon
0x32 24 tc 0 32 0 r y . 8 8 8 0 0 16 0 16 16 16 16 0 0 Ncon
0x33 24 tc 0 32 0 r y . 8 8 8 8 0 16 0 16 16 16 16 0 0 Ncon
0x34 24 tc 0 32 0 r y . 8 8 8 0 0 16 0 16 16 16 16 0 0 Ncon
0x35 24 tc 0 32 0 r y . 8 8 8 8 0 16 0 16 16 16 16 0 0 Ncon
0x36 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 0 0 None
0x37 24 dc 0 32 0 r . . 8 8 8 0 0 24 8 16 16 16 16 0 0 None
0x38 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 0 0 None
0x39 24 dc 0 32 0 r y . 8 8 8 0 0 16 0 16 16 16 16 0 0 None
0x3a 24 dc 0 32 0 r y . 8 8 8 8 0 16 0 16 16 16 16 0 0 None
0x3b 24 dc 0 32 0 r . . 8 8 8 0 0 16 0 16 16 16 16 0 0 None
0x3c 24 dc 0 32 0 r . . 8 8 8 8 0 16 0 16 16 16 16 0 0 None
0x3d 24 dc 0 32 0 r y . 8 8 8 0 0 0 0 16 16 16 16 0 0 None
0x3e 24 dc 0 32 0 r y . 8 8 8 8 0 0 0 16 16 16 16 0 0 None
0x3f 24 dc 0 32 0 r . . 8 8 8 0 0 0 0 16 16 16 16 0 0 None
0x40 24 dc 0 32 0 r . . 8 8 8 8 0 0 0 16 16 16 16 0 0 None
0x41 24 dc 0 32 0 r y . 8 8 8 0 0 24 8 16 16 16 16 0 0 Ncon
0x42 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 0 0 Ncon
0x43 24 dc 0 32 0 r y . 8 8 8 0 0 24 8 16 16 16 16 0 0 Ncon
0x44 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 0 0 Ncon
0x45 24 dc 0 32 0 r y . 8 8 8 0 0 16 0 16 16 16 16 0 0 Ncon
0x46 24 dc 0 32 0 r y . 8 8 8 8 0 16 0 16 16 16 16 0 0 Ncon
0x47 24 dc 0 32 0 r y . 8 8 8 0 0 16 0 16 16 16 16 0 0 Ncon
0x48 24 dc 0 32 0 r y . 8 8 8 8 0 16 0 16 16 16 16 0 0 Ncon
savage@devel savage $


any more questions?
sAvAgE-SMP is offline   Reply With Quote
Old 07-31-04, 12:27 AM   #10
sAvAgE-SMP
Registered User
 
Join Date: Jul 2004
Posts: 23
Default Re: NVIDIA Driver 6106 Problems

ok just installed quake31.32b and quake3 runs but not running properly all the GLX is not there but quake3 looks like *****
sAvAgE-SMP is offline   Reply With Quote
Old 07-31-04, 12:59 AM   #11
sAvAgE-SMP
Registered User
 
Join Date: Jul 2004
Posts: 23
Default Re: NVIDIA Driver 6106 Problems

here is what quake3 looks like on my system
Attached Thumbnails
Click image for larger version

Name:	****up.jpg
Views:	272
Size:	81.3 KB
ID:	7237  

Last edited by sAvAgE-SMP; 07-31-04 at 01:18 AM.
sAvAgE-SMP is offline   Reply With Quote
Old 07-31-04, 03:46 AM   #12
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: NVIDIA Driver 6106 Problems


client glx vendor string: SGI
client glx version string: 1.2
client glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating


Judging from this output, the driver isn't installed correctly; if you installed the driver using the .run installer, make sure no Gentoo NVIDIA driver or X.org OpenGL packages are installed. Alternatively, install the latest Gentoo NVIDIA packages.
zander is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
Rumor regarding lack of 680 availability ViN86 Rumor Mill 6 05-09-12 04:48 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-01-02 11:58 PM
RH7.3 & nVidia driver problems BigChin NVIDIA Linux 4 10-01-02 01:33 AM

All times are GMT -5. The time now is 07:50 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.