Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-07-04, 08:11 AM   #1
SlackTuX
Registered User
 
Join Date: Aug 2004
Posts: 2
Exclamation kernel problem

hi, while trying to install the latest nvidia driver for my machine (AMD 1800+ Geforce 3 TI200) i got the message that, it couldn't load the module nvidia.ko due to some problem finding the kernel sources. I tried to give the instaler the flag --kernel-source-path /usr/src/linux-2.6.6 but nothing....
I instaled 2.6.6 myself so i'm sure that i have the sources....i've unpacked and installed them myself... The most strange thing is that i've already installed previous NVIDIA drivers with no problems...

If someone could help...
Thanks in advance
SlackTuX is offline   Reply With Quote
Old 08-07-04, 10:00 AM   #2
d*.*b
Registered User
 
Join Date: Aug 2004
Posts: 10
Default Re: kernel problem

I'm not too familiar with the nVidia drivers yet but if you did a "make mrproper" in your sources tree after you installed your new kernel, that could explain it.

Just running "make" with the same .config used in your actual kernel should do the trick, ...if it's the case of course.

HTH
d*.*b is offline   Reply With Quote
Old 08-07-04, 02:29 PM   #3
Albert
Registered User
 
Join Date: May 2003
Location: Antwerp, BELGIUM
Posts: 19
Default Re: kernel problem

Nope, I have the same problem running Mandrake (kernel 2.6.3-15mdk). Running make does not make any difference, it keeps refusing to compile.

Kernel source can' t be the problem. I even reinstalled the source from scratch. No use.
__________________
Albert
Albert is offline   Reply With Quote
Old 08-07-04, 05:01 PM   #4
Albert
Registered User
 
Join Date: May 2003
Location: Antwerp, BELGIUM
Posts: 19
Default Re: kernel problem

"Never change a winnin' team..."

So, I reInstalled 'good-old' 5336; since 6111 refuses to compile.

(5336 always used to run like a whistle; glxgears shows 1104 fps)

6106, did compile, but it made a bizar objection about possible conflicts (which I did experience) because of some other module being loaded.
__________________
Albert
Albert is offline   Reply With Quote
Old 08-07-04, 11:54 PM   #5
Albert
Registered User
 
Join Date: May 2003
Location: Antwerp, BELGIUM
Posts: 19
Default Re: kernel problem

BTW, when I tried to compile 6106 it reported a possible conflict with an already installed module rivafb.
__________________
Albert
Albert is offline   Reply With Quote
Old 08-08-04, 04:43 AM   #6
Antti
Registered User
 
Join Date: Aug 2004
Posts: 45
Default Re: kernel problem

Also having the same problem. Tried with different kernels and sources, 6111 just won't compile under Mandrake 10! Previous versions worked so well.
Antti is offline   Reply With Quote
Old 08-08-04, 07:48 AM   #7
SlackTuX
Registered User
 
Join Date: Aug 2004
Posts: 2
Default Re: kernel problem

Hey Albert that hing with rivafb i thinks thats no problem, i get that message as well, that means ther kernel you've got in your system has support for rivafb but as long as the module isn't loaded there's no problem... I'm using SlackWare 10 and i get thet error about not loading nvidia.ko and kernel sources problem so i think nvidia should have a look at this since it's not a one problem distro. I'm going to send them guys an e-mail to ask for support, i encourage you guys to od the same
linux-bugs@nvidia.com

btw when you get your replies from the nvidia guys it would be good to post them here . Cya
SlackTuX is offline   Reply With Quote
Old 08-08-04, 05:11 PM   #8
Antti
Registered User
 
Join Date: Aug 2004
Posts: 45
Default Re: kernel problem

Solution to this problem has been found by Aristiana here:

http://www.nvnews.net/vbulletin/show...716#post396716
Antti is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Random crashes, NVRM Xid messages Iesos NVIDIA Linux 90 10-04-12 04:27 AM
Corrupted display - 302.17 - Dell Precision T3500 (G98 [Quadro NVS 295]) gbailey NVIDIA Linux 1 06-27-12 11:24 AM
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 05:51 AM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 12:04 PM
Crash when logout from X TGL NVIDIA Linux 10 09-13-02 09:22 PM

All times are GMT -5. The time now is 03:01 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.