Go Back   nV News Forums > Linux Support Forums > General Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-15-04, 11:22 PM   #1
Chuck Roast
Registered User
 
Join Date: Jun 2004
Posts: 2
Default RHEL v3 and NFORCE unified driver

Tried to install nforce 1.0-0274 driver in my Linux box running Red Hat Enterprise AS v3 Update 2. This is kernel 2.4.21-xx. Rebuild proceeds fine following instructions for building from a Source RPM (output below). Built-in soundcard works perfectly. However, I can't find the built-in ethernet on my MSI nForce2 motherboard nor can I start a network. One part of the NVIDIA instructions state there is a line in the SRPM that indicates where the new compiled rpm was written to and then tells me to install that as a binary RPM. I do not see this line in my SRPM output (below) and I could not locate that RPM anywhere on my machine. I could use any advice someone has to resolve this and help me get my network running again. It worked fine under Red Hat 9. Thanks. Here is the output of the SRPM rebuild:

[root@localhost transfer]# rpmbuild --rebuild NVIDIA_nforce-1.0-0274.src.rpm
Installing NVIDIA_nforce-1.0-0274.src.rpm
warning: user buildmeister does not exist - using root
warning: user buildmeister does not exist - using root
warning: user buildmeister does not exist - using root
warning: user buildmeister does not exist - using root
warning: user buildmeister does not exist - using root
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.81841
+ umask 022
+ cd /usr/src/redhat/BUILD
+ LANG=C
+ export LANG
+ unset DISPLAY
+ echo '---- Copying Sources ----'
---- Copying Sources ----
+ cd /usr/src/redhat/BUILD
+ rm -rf nforce
+ /usr/bin/gzip -dc /usr/src/redhat/SOURCES/nvnet.tgz
+ tar -xvvf -
drwxr-xr-x buildmeister/adm 0 2004-04-16 15:10:49 nforce/
drwxr-xr-x buildmeister/adm 0 2004-04-16 15:10:49 nforce/nvnet/
-rw-r--r-- buildmeister/adm 23833 2004-04-16 15:17:45 nforce/nvnet/adapter.h
-rw-r--r-- buildmeister/adm 6867 2004-04-16 15:17:45 nforce/nvnet/basetype.h
-rw-r--r-- buildmeister/adm 6219 2004-04-16 15:17:45 nforce/nvnet/drvinfo.h
-rw-r--r-- buildmeister/adm 12003 2004-04-16 15:17:45 nforce/nvnet/nvenet.h
-rw-r--r-- buildmeister/adm 5129 2004-04-16 15:17:45 nforce/nvnet/os.h
-rw-r--r-- buildmeister/adm 6945 2004-04-16 15:17:45 nforce/nvnet/phy.h
-rw-r--r-- buildmeister/adm 102460 2004-04-16 15:17:45 nforce/nvnet/nvenet.c
-rw-r--r-- buildmeister/adm 38352 2004-04-16 15:17:45 nforce/nvnet/nvenetlib.o
-rw-r--r-- buildmeister/adm 3717 2004-04-16 15:17:45 nforce/nvnet/Makefile
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd nforce
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chown -Rhf root .
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chgrp -Rhf root .
+ /bin/chmod -Rf a+rX,g-w,o-w .
+ cd /usr/src/redhat/BUILD
+ /usr/bin/gzip -dc /usr/src/redhat/SOURCES/nvaudio.tgz
+ tar -xvvf -
drwxr-xr-x buildmeister/adm 0 2004-04-16 15:17:46 nforce/
drwxr-xr-x buildmeister/adm 0 2004-04-16 15:17:46 nforce/nvaudio/
-rw-r--r-- buildmeister/adm 3202 2004-04-16 15:17:46 nforce/nvaudio/Makefile
-rw-r--r-- buildmeister/adm 64845 2004-04-16 15:17:46 nforce/nvaudio/nvcrush.c
-rw-r--r-- buildmeister/adm 84378 2004-04-16 15:17:46 nforce/nvaudio/nvhw.c
-rw-r--r-- buildmeister/adm 41741 2004-04-16 15:17:46 nforce/nvaudio/nvmain.c
-rw-r--r-- buildmeister/adm 9910 2004-04-16 15:17:46 nforce/nvaudio/nvrec.c
-rw-r--r-- buildmeister/adm 20056 2004-04-16 15:17:46 nforce/nvaudio/nvspdif.c
-rw-r--r-- buildmeister/adm 18339 2004-04-16 15:17:46 nforce/nvaudio/nvwavout.c
-rw-r--r-- buildmeister/adm 2651 2004-04-16 15:17:46 nforce/nvaudio/chaninfo.h
-rw-r--r-- buildmeister/adm 10215 2004-04-16 15:17:46 nforce/nvaudio/nvhw.h
-rw-r--r-- buildmeister/adm 2797 2004-04-16 15:17:46 nforce/nvaudio/nvioctl.h
-rw-r--r-- buildmeister/adm 1392 2004-04-16 15:17:46 nforce/nvaudio/nvrec.h
-rw-r--r-- buildmeister/adm 1618 2004-04-16 15:17:46 nforce/nvaudio/nvspdif.h
-rw-r--r-- buildmeister/adm 1499 2004-04-16 15:17:46 nforce/nvaudio/nvwavout.h
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd nforce
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chown -Rhf root .
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chgrp -Rhf root .
+ /bin/chmod -Rf a+rX,g-w,o-w .
+ cd /usr/src/redhat/BUILD
+ /usr/bin/gzip -dc /usr/src/redhat/SOURCES/nvmaster.tgz
+ tar -xvvf -
drwxr-xr-x buildmeister/adm 0 2004-04-16 15:17:45 nforce/
-rw-r--r-- buildmeister/adm 1259 2004-04-16 15:17:45 nforce/Makefile
-rw-r--r-- buildmeister/adm 5404 2004-04-16 15:17:45 nforce/NVLicense.txt
-rw-r--r-- buildmeister/adm 18007 2004-04-16 15:17:45 nforce/GNULicense.txt
-rw-r--r-- buildmeister/adm 28128 2004-04-16 15:17:45 nforce/ReleaseNotes.html
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd nforce
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chown -Rhf root .
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chgrp -Rhf root .
+ /bin/chmod -Rf a+rX,g-w,o-w .
+ cd /usr/src/redhat/BUILD
+ /usr/bin/gzip -dc /usr/src/redhat/SOURCES/nvgart.tgz
+ tar -xvvf -
drwxr-xr-x buildmeister/adm 0 2004-04-16 15:17:46 nforce/
drwxr-xr-x buildmeister/adm 0 2004-04-16 15:17:46 nforce/nvgart/
-rw-r--r-- buildmeister/adm 854 2004-04-16 15:17:46 nforce/nvgart/Makefile
-rw-r--r-- buildmeister/adm 2093 2004-04-16 15:17:46 nforce/nvgart/README
-rw-r--r-- buildmeister/adm 21192 2004-04-16 15:17:46 nforce/nvgart/linux-2.4.20-agpgart.diff
-rw-r--r-- buildmeister/adm 1211 2004-04-16 15:17:46 nforce/nvgart/linux-2.4.21-102-agpgart.diff
-rw-r--r-- buildmeister/adm 13557 2004-04-16 15:17:46 nforce/nvgart/linux-2.4.21-4.EL-agpgart.diff
-rw-r--r-- buildmeister/adm 22493 2004-04-16 15:17:46 nforce/nvgart/linux-2.4.21-agpgart.diff
-rw-r--r-- buildmeister/adm 13775 2004-04-16 15:17:46 nforce/nvgart/linux-2.4.22-agpgart.diff
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd nforce
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chown -Rhf root .
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chgrp -Rhf root .
+ /bin/chmod -Rf a+rX,g-w,o-w .
+ exit 0
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.43967
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd nforce
+ LANG=C
+ export LANG
+ unset DISPLAY
+ echo '---- Building Drivers ----'
---- Building Drivers ----
+ make
make -C nvnet
make[1]: Entering directory `/usr/src/redhat/BUILD/nforce/nvnet'
cc -c -Wall -DLINUX -DMODULE -DEXPORT_SYMTAB -D__KERNEL__ -O2 -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -fomit-frame-pointer -pipe -mpreferred-stack-boundary=2 -march=i686 -DMODULE -DCONFIG_PM -falign-functions=4 -I/lib/modules/2.4.21-15.EL/build/include -DMODVERSIONS -include /lib/modules/2.4.21-15.EL/build/include/linux/modversions.h nvenet.c
ld -r -o temp.o nvenet.o nvenetlib.o
objcopy --strip-symbol="gcc2_compiled." temp.o
cp temp.o nvnet.o
rm temp.o
rm -f nvenet.o
make[1]: Leaving directory `/usr/src/redhat/BUILD/nforce/nvnet'
make -C nvaudio
make[1]: Entering directory `/usr/src/redhat/BUILD/nforce/nvaudio'
make nvaudio.o
make[2]: Entering directory `/usr/src/redhat/BUILD/nforce/nvaudio'
cc -D__KERNEL__ -I/lib/modules/2.4.21-15.EL/build/include -Wall -Wstrict-prototypes -O -fno-strict-aliasing -mpreferred-stack-boundary=2 -march=i686 -falign-functions=4 -DMODULE -DDRIVERVER=\"0274\" -DREMAP_NEW -DMODVERSIONS -include /lib/modules/2.4.21-15.EL/build/include/linux/modversions.h -c -o nvhw.o nvhw.c
cc -D__KERNEL__ -I/lib/modules/2.4.21-15.EL/build/include -Wall -Wstrict-prototypes -O -fno-strict-aliasing -mpreferred-stack-boundary=2 -march=i686 -falign-functions=4 -DMODULE -DDRIVERVER=\"0274\" -DREMAP_NEW -DMODVERSIONS -include /lib/modules/2.4.21-15.EL/build/include/linux/modversions.h -c -o nvrec.o nvrec.c
cc -D__KERNEL__ -I/lib/modules/2.4.21-15.EL/build/include -Wall -Wstrict-prototypes -O -fno-strict-aliasing -mpreferred-stack-boundary=2 -march=i686 -falign-functions=4 -DMODULE -DDRIVERVER=\"0274\" -DREMAP_NEW -DMODVERSIONS -include /lib/modules/2.4.21-15.EL/build/include/linux/modversions.h -c -o nvwavout.o nvwavout.c
cc -D__KERNEL__ -I/lib/modules/2.4.21-15.EL/build/include -Wall -Wstrict-prototypes -O -fno-strict-aliasing -mpreferred-stack-boundary=2 -march=i686 -falign-functions=4 -DMODULE -DDRIVERVER=\"0274\" -DREMAP_NEW -DMODVERSIONS -include /lib/modules/2.4.21-15.EL/build/include/linux/modversions.h -c -o nvspdif.o nvspdif.c
cc -D__KERNEL__ -I/lib/modules/2.4.21-15.EL/build/include -Wall -Wstrict-prototypes -O -fno-strict-aliasing -mpreferred-stack-boundary=2 -march=i686 -falign-functions=4 -DMODULE -DDRIVERVER=\"0274\" -DREMAP_NEW -DMODVERSIONS -include /lib/modules/2.4.21-15.EL/build/include/linux/modversions.h -c -o nvcrush.o nvcrush.c
cc -D__KERNEL__ -I/lib/modules/2.4.21-15.EL/build/include -Wall -Wstrict-prototypes -O -fno-strict-aliasing -mpreferred-stack-boundary=2 -march=i686 -falign-functions=4 -DMODULE -DDRIVERVER=\"0274\" -DREMAP_NEW -DMODVERSIONS -include /lib/modules/2.4.21-15.EL/build/include/linux/modversions.h -c -o nvmain.o nvmain.c
ld -r nvhw.o nvrec.o nvwavout.o nvspdif.o nvcrush.o nvmain.o -o nvaudio.o
make[2]: Leaving directory `/usr/src/redhat/BUILD/nforce/nvaudio'
make[1]: Leaving directory `/usr/src/redhat/BUILD/nforce/nvaudio'
make -C nvgart
make[1]: Entering directory `/usr/src/redhat/BUILD/nforce/nvgart'
making gart
make[1]: Leaving directory `/usr/src/redhat/BUILD/nforce/nvgart'
+ exit 0
Executing(%install): /bin/sh -e /var/tmp/rpm-tmp.25937
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd nforce
+ LANG=C
+ export LANG
+ unset DISPLAY
+ echo '---- Installing Drivers ----'
---- Installing Drivers ----
+ rm -f /usr/src/redhat/BUILD/nforce/modules.list
+ '[' -z '' ']'
++ uname -r
+ export TARGET_KERNEL=2.4.21-15.EL
+ TARGET_KERNEL=2.4.21-15.EL
+ make INSTROOT=/var/tmp/NVIDIA_nforce-1.0-0274-root install
make -C nvnet install
make[1]: Entering directory `/usr/src/redhat/BUILD/nforce/nvnet'
mkdir -p /var/tmp/NVIDIA_nforce-1.0-0274-root//lib/modules/2.4.21-15.EL/kernel/drivers/net
install -b -m 644 -o root nvnet.o /var/tmp/NVIDIA_nforce-1.0-0274-root//lib/modules/2.4.21-15.EL/kernel/drivers/net
/sbin/depmod -a
make[1]: Leaving directory `/usr/src/redhat/BUILD/nforce/nvnet'
make -C nvaudio install
make[1]: Entering directory `/usr/src/redhat/BUILD/nforce/nvaudio'
mkdir -p /var/tmp/NVIDIA_nforce-1.0-0274-root//lib/modules/2.4.21-15.EL/kernel/drivers/sound
mkdir -p /var/tmp/NVIDIA_nforce-1.0-0274-root/usr/include
install -b -m 755 -o root nvaudio.o /var/tmp/NVIDIA_nforce-1.0-0274-root//lib/modules/2.4.21-15.EL/kernel/drivers/sound
install -b -m 444 -o root nvioctl.h /var/tmp/NVIDIA_nforce-1.0-0274-root/usr/include/nvaudio.h
/sbin/depmod -a
make[1]: Leaving directory `/usr/src/redhat/BUILD/nforce/nvaudio'
make -C nvgart install
make[1]: Entering directory `/usr/src/redhat/BUILD/nforce/nvgart'
mkdir -p /var/tmp/NVIDIA_nforce-1.0-0274-root//usr/src/nvidia/nvgart
for patch in linux-2.4.20-agpgart.diff linux-2.4.21-agpgart.diff linux-2.4.21-102-agpgart.diff linux-2.4.21-4.EL-agpgart.diff linux-2.4.22-agpgart.diff ; do \
install -b -m 644 -o root $patch /var/tmp/NVIDIA_nforce-1.0-0274-root//usr/src/nvidia/nvgart; \
done
install -b -m 644 -o root README /var/tmp/NVIDIA_nforce-1.0-0274-root//usr/src/nvidia/nvgart
make[1]: Leaving directory `/usr/src/redhat/BUILD/nforce/nvgart'
+ echo '%attr(644, root, root) /lib/modules/2.4.21-15.EL/kernel/drivers/sound/nvaudio.o'
+ echo '%attr(644, root, root) /lib/modules/2.4.21-15.EL/kernel/drivers/net/nvnet.o'
+ /usr/lib/rpm/brp-compress
Processing files: NVIDIA_nforce-1.0-0274
Executing(%doc): /bin/sh -e /var/tmp/rpm-tmp.80042
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd nforce
+ DOCDIR=/var/tmp/NVIDIA_nforce-1.0-0274-root/usr/share/doc/NVIDIA_nforce-1.0
+ export DOCDIR
+ rm -rf /var/tmp/NVIDIA_nforce-1.0-0274-root/usr/share/doc/NVIDIA_nforce-1.0
+ /bin/mkdir -p /var/tmp/NVIDIA_nforce-1.0-0274-root/usr/share/doc/NVIDIA_nforce-1.0
+ cp -pr NVLicense.txt /var/tmp/NVIDIA_nforce-1.0-0274-root/usr/share/doc/NVIDIA_nforce-1.0
+ cp -pr GNULicense.txt /var/tmp/NVIDIA_nforce-1.0-0274-root/usr/share/doc/NVIDIA_nforce-1.0
+ cp -pr ReleaseNotes.html /var/tmp/NVIDIA_nforce-1.0-0274-root/usr/share/doc/NVIDIA_nforce-1.0+ exit 0
Requires(interp): /bin/sh /bin/sh
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Requires(post): /bin/sh
Requires(postun): /bin/sh
Checking for unpackaged file(s): /usr/lib/rpm/check-files /var/tmp/NVIDIA_nforce-1.0-0274-root
error: Installed (but unpackaged) file(s) found:
/lib/modules/2.4.21-15.EL/kernel/drivers/net/nvnet.o~
/lib/modules/2.4.21-15.EL/kernel/drivers/sound/nvaudio.o~
/usr/include/nvaudio.h~
/usr/src/nvidia/nvgart/README~
/usr/src/nvidia/nvgart/linux-2.4.20-agpgart.diff~
/usr/src/nvidia/nvgart/linux-2.4.21-102-agpgart.diff
/usr/src/nvidia/nvgart/linux-2.4.21-102-agpgart.diff~
/usr/src/nvidia/nvgart/linux-2.4.21-4.EL-agpgart.diff
/usr/src/nvidia/nvgart/linux-2.4.21-4.EL-agpgart.diff~
/usr/src/nvidia/nvgart/linux-2.4.21-agpgart.diff~
/usr/src/nvidia/nvgart/linux-2.4.22-agpgart.diff~


RPM build errors:
user buildmeister does not exist - using root
user buildmeister does not exist - using root
user buildmeister does not exist - using root
user buildmeister does not exist - using root
user buildmeister does not exist - using root
Installed (but unpackaged) file(s) found:
/lib/modules/2.4.21-15.EL/kernel/drivers/net/nvnet.o~
/lib/modules/2.4.21-15.EL/kernel/drivers/sound/nvaudio.o~
/usr/include/nvaudio.h~
/usr/src/nvidia/nvgart/README~
/usr/src/nvidia/nvgart/linux-2.4.20-agpgart.diff~
/usr/src/nvidia/nvgart/linux-2.4.21-102-agpgart.diff
/usr/src/nvidia/nvgart/linux-2.4.21-102-agpgart.diff~
/usr/src/nvidia/nvgart/linux-2.4.21-4.EL-agpgart.diff
/usr/src/nvidia/nvgart/linux-2.4.21-4.EL-agpgart.diff~
/usr/src/nvidia/nvgart/linux-2.4.21-agpgart.diff~
/usr/src/nvidia/nvgart/linux-2.4.22-agpgart.diff~
[root@localhost transfer]#
Chuck Roast is offline   Reply With Quote
Old 06-17-04, 04:17 AM   #2
arokh
Registered User
 
arokh's Avatar
 
Join Date: Jun 2004
Posts: 287
Default Re: RHEL v3 and NFORCE unified driver

Uncomment the line that starts with %__check_files in /usr/lib/rpm/macros.
On my FC2 installation it's at line 308.
__________________
Asus A8N32-SLI : AMD64 3700+ @ 2.85GHz : 2GB PC4000 OCZ Platinum EB : 2x 7800GT SLI
arokh is offline   Reply With Quote
Old 06-25-04, 04:50 AM   #3
Chuck Roast
Registered User
 
Join Date: Jun 2004
Posts: 2
Default Re: RHEL v3 and NFORCE unified driver

Arokh, I have no idea how you found this particular line in the /usr/lib/rpm/macros file but that solved much of my network problem. It was line 308 in my RHEL AS 3 as well. However, in mine the default is not commented out and compatability isn't enforced. I commented out the line and the rpm was written out as expected. Here was the output result:
Wrote: /usr/src/redhat/RPMS/i386/NVIDIA_nforce-1.0-0274.i386.rpm

I was able to then install the rpm and the network came up after I activated the eth0 device. I proceeded to do a large set of system updates and then rebooted. I noticed a failure initializing eth0 on the reboot. Here is the error:
interface 'eth0' not found
nvenet device eth0 does not seem to be present, delaying initialization.

On checking further, I couldn't find anything on the referenced nvenet device. I looked in the release notes at /var/tmp/NVIDIA_nforce-1.0-0274-root/usr/share/doc/NVIDIA_nforce-1.0/ReleaseNotes.html
It says:
The tar files don't try to modify the module configuration files. You should make sure the following lines are in the configuration file (it will be named /etc/modules.conf on most current distributions):
* alias eth0 nvnet
* alias sound-slot-0 nvaudio
* alias usb-interface usb-ohci

I checked my /etc/modules.conf file and found the alias for eth0 nvnet was not present. I added that line (the others were there) and the network came right up. However, on my next reboot I found that the line alias eth0 nvnet had changed back to alias eth0 nvenet. Nvenet doesn't have a driver so the network device is never activated.

For Nvidia: I suspect there is a typo in something with the src.rpm that is causing this problem. One, the alias for eth0 was not written into modules.conf and then it is changed to nvenet on a reboot. I will manually change the file each time I reboot, but I hope you can come up with a better solution. Thanks for your time!
Chuck Roast is offline   Reply With Quote
Old 07-05-04, 03:03 PM   #4
Blueshark
Registered User
 
Join Date: Jul 2004
Posts: 1
Default Re: RHEL v3 and NFORCE unified driver

Very informative post.

I recently built a dedicated Linux box- I am also new to Linux but am a programmer by trade.
I used an nforce2 board and RHEL v3 AS and had the exact same problems as you Chuck. I also have to modify etc/modules.conf to get my network to work.

It does seem to by a very annoying typo. Do you have any more permanent solutions since your last post?
Blueshark is offline   Reply With Quote
Old 07-07-04, 07:22 PM   #5
edlucas
Registered User
 
Join Date: Jul 2004
Posts: 1
Default Re: RHEL v3 and NFORCE unified driver

Quote:
Originally Posted by Chuck Roast
For Nvidia: I suspect there is a typo in something with the src.rpm that is causing this problem. One, the alias for eth0 was not written into modules.conf and then it is changed to nvenet on a reboot. I will manually change the file each time I reboot, but I hope you can come up with a better solution. Thanks for your time!
Thanks for posting all this! I have had exactly the same problem running Centos 3.1 - which is a RHEL v3 variant.

I grepped through everything looking for the command to modify that would stop the "alias eth0 nvnet" line in /etc/modules.conf getting rewritten to "alias eth0 nvenet" on startup, but with no result.

The (slightly embarassing) solution I came up with was to copy the nvnet.o module to nvenet.o (in /lib/modules/2.4.21-9.0.1.EL.c0/kernel/drivers/net on Centos). I have not had any more problems with modules.conf getting rewritten. Can't say I have exhaustively tested this though. Will report back if anything else comes up.
edlucas is offline   Reply With Quote
Old 08-12-04, 09:10 AM   #6
sandstorm
Registered User
 
Join Date: Jul 2004
Location: Amsterdam
Posts: 3
Default Re: RHEL v3 and NFORCE unified driver

what up with this driver?

i commented out that macro line and it rebuilds.. yahoooo!
on reboot kudzu recognizes the nic and configures it.. yehaaaw!
but alas, it can't activate the the nic.... boooohooh!

lsmod says: nvnet
modules.conf says: nvnet
but i noticed that in /proc/net has a dir called "nvenet" instead of nvnet

could this be the problem and how to solve this?

running RHEL3 ES
sandstorm is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:43 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.