Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-11-04, 04:11 AM   #1
ravi101
Registered User
 
Join Date: Aug 2004
Posts: 7
Exclamation Cannot Change Resolution form 1024x768

I installed the nvidia drivers and rebooted. Everything went smooth, even the nvidia splash screen came up.

When X loaded, the resolution had been changed to 1024x768. I changed the resolution back to 1280x1024 and restarted X. After doing this, xorg.conf had been automatically changed back to what it was before installing the nvidia drivers.

So I chaned xorg.conf to what it was supposed to be and restarted. Again the resolution had been changed to 1024x768.

Please tell me what I need to do to change the resolution to 1280x1024 and still use the proper nvidia drivers.

More Info that might help:
I'm running Fedora Core 2
Using GeForce4 Ti 4200
Kernel Version 2.6.7-1.494.2.2

Thanks in advance,
Ravi

Last edited by ravi101; 08-11-04 at 04:35 AM.
ravi101 is offline   Reply With Quote
Old 08-11-04, 04:32 AM   #2
ravi101
Registered User
 
Join Date: Aug 2004
Posts: 7
Default Re: Cannot Change Resolution form 1024x768

BTW, the nvidia drivers I've installed is version '1.0-6111'. My motherboard is a Gigabyte GA-8ITML which has the Intel 850 chipset.

Hope this helps.
ravi101 is offline   Reply With Quote
Old 08-11-04, 04:38 AM   #3
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default Re: Cannot Change Resolution form 1024x768

Show the x.org log file which is stored in /var/log. (the one with 1280x1024 in ofcourse)
Thunderbird is offline   Reply With Quote
Old 08-11-04, 05:01 AM   #4
ravi101
Registered User
 
Join Date: Aug 2004
Posts: 7
Default Re: Cannot Change Resolution form 1024x768

I have attached my Xorg.log file.
Attached Files
File Type: txt Xorg.0.log.txt (35.2 KB, 185 views)
ravi101 is offline   Reply With Quote
Old 08-11-04, 05:37 AM   #5
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default Re: Cannot Change Resolution form 1024x768

Before fixing the 1280x1024 stuff I would fix your x.org config file as you aren't using the nvidia drivers at all. Installing the drivers is not just running the installer or installing the rpms. Afterwards you need to edit the config file. In short the following things need to be done:
- remove line Load "dri" and "GLcore" (if exists)
- change driver "nv" to "nvidia"
Thunderbird is offline   Reply With Quote
Old 08-11-04, 11:30 AM   #6
ravi101
Registered User
 
Join Date: Aug 2004
Posts: 7
Default Re: Cannot Change Resolution form 1024x768

Sorry for the late reply.

I did change my xorg.conf file according to the readme. Then my X loads with a resolution of 1024x768. I can't work with the resolution at 1024x768 so I changed the resolution to 1280x1024. And when I do this my xorg.conf file automatically changes back to what it was before. (ie. The driver is 'nv' and the line 'Load dri' is back.)

Everytime I change my xorg.conf file to use the proper nvidia drivers, the resolution is chaned to 1024x768.

I hope you understand my problem.

Ravi
ravi101 is offline   Reply With Quote
Old 08-11-04, 11:51 AM   #7
ravi101
Registered User
 
Join Date: Aug 2004
Posts: 7
Default Re: Cannot Change Resolution form 1024x768

I have attached my xorg.log file after editing xorg.conf with the proper settings.

NOTE: Now the proper drivers have been loaded and the redolution is 1024x768. If I change the resolution to 1280x1024, the xorg.conf file will automatically be changed with the generic drivers.

Here's my xorg.conf file with the correct settings:


Code:
# Xorg configuration created by system-config-display

Section "ServerLayout"
	Identifier     "single head configuration"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database.  Note, this is the name of the 
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
	RgbPath      "/usr/X11R6/lib/X11/rgb"
	FontPath     "unix/:7100"
EndSection

Section "Module"
	Load  "dbe"
	Load  "extmod"
	Load  "fbdevhw"
	Load  "glx"
	Load  "record"
	Load  "freetype"
	Load  "type1"
	#Load  "dri"

EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#	Option	"Xleds"		"1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
#	Option	"XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#	Option	"XkbModel"	"pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#	Option	"XkbModel"	"microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#	Option	"XkbLayout"	"de"
# or:
#	Option	"XkbLayout"	"de"
#	Option	"XkbVariant"	"nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#	Option	"XkbOptions"	"ctrl:swapcaps"
# Or if you just want both to be control, use:
#	Option	"XkbOptions"	"ctrl:nocaps"
#
	Identifier  "Keyboard0"
	Driver      "keyboard"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "IMPS/2"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "S/M 150MP"
	DisplaySize  300	230
	HorizSync    30.0 - 70.0
	VertRefresh  56.0 - 85.0
	Option	    "dpms"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "nvidia"
	VendorName  "Videocard vendor"
	BoardName   "NVIDIA GeForce 4 (generic)"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes    "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
		Modes    "1280x1024" "1280x960" "1152x864" "1024x768" "800x600"
	EndSubSection
EndSection

Section "DRI"
	Group        0
	Mode         0666
EndSection
__________________________________________________ _____________________
Here's my xorg.conf file after I change the resolution to 1280x1024:


Code:
# Xorg configuration created by system-config-display

Section "ServerLayout"
	Identifier     "single head configuration"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database.  Note, this is the name of the 
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
	RgbPath      "/usr/X11R6/lib/X11/rgb"
	FontPath     "unix/:7100"
EndSection

Section "Module"
	Load  "dbe"
	Load  "extmod"
	Load  "fbdevhw"
	Load  "glx"
	Load  "record"
	Load  "freetype"
	Load  "type1"
	#Load  "dri"
	Load  "dri"

EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#	Option	"Xleds"		"1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
#	Option	"XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#	Option	"XkbModel"	"pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#	Option	"XkbModel"	"microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#	Option	"XkbLayout"	"de"
# or:
#	Option	"XkbLayout"	"de"
#	Option	"XkbVariant"	"nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#	Option	"XkbOptions"	"ctrl:swapcaps"
# Or if you just want both to be control, use:
#	Option	"XkbOptions"	"ctrl:nocaps"
#
	Identifier  "Keyboard0"
	Driver      "keyboard"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "IMPS/2"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "S/M 150MP"
	DisplaySize  300	230
	HorizSync    30.0 - 70.0
	VertRefresh  56.0 - 85.0
	Option	    "dpms"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "nv"
	VendorName  "Videocard vendor"
	BoardName   "NVIDIA GeForce 4 (generic)"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes    "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
		Modes    "1280x1024" "1280x960" "1152x864" "1024x768" "800x600"
	EndSubSection
EndSection

Section "DRI"
	Group        0
	Mode         0666
EndSection
As you can see the xorg.conf file has been changed automatically.

Hope this helps,
Ravi
Attached Files
File Type: txt Xorg.0.log.txt (27.3 KB, 156 views)
ravi101 is offline   Reply With Quote
Old 08-12-04, 01:16 AM   #8
ravi101
Registered User
 
Join Date: Aug 2004
Posts: 7
Default Re: Cannot Change Resolution form 1024x768

Hasn't anyone had this problem before?

The whole thing worked just fine when I had the 2.6.5 kernel.

Anyone? I tried reinstalling the driver but it still won't allow me to change the resolution.

Ravi
ravi101 is offline   Reply With Quote

Old 08-12-04, 01:17 AM   #9
ravi101
Registered User
 
Join Date: Aug 2004
Posts: 7
Default Re: Cannot Change Resolution form 1024x768

Okay, I had to lend my Nvidia to my LUG for an exhibition. I'll get it back on Monday.

Then I'll format and reinstall everything and update to a more stable kernel. I hope nobody else runs into this problem.

Until next time, thanks a lot for your help.

Ravi

Last edited by ravi101; 08-12-04 at 01:27 AM. Reason: I think it's my kernel.
ravi101 is offline   Reply With Quote
Old 08-12-04, 02:49 AM   #10
Antti
Registered User
 
Join Date: Aug 2004
Posts: 45
Default Re: Cannot Change Resolution form 1024x768

Quote:
Originally Posted by Thunderbird
remove line Load "dri" and "GLcore"
These lines are meant to be removed?? How about Load "glx"? I've always had those 2 lines and "glx" enabled and never had any problems (great performance as well with nVidia-drivers). And doesn't nVidia's own documentation tell to enable those lines?

How do they actually affect X?
Antti is offline   Reply With Quote
Old 08-12-04, 04:35 AM   #11
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default Re: Cannot Change Resolution form 1024x768

The line load "glx" was already there so I didn't mention it.
Thunderbird is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
GPU fan always at 100%, can not change the thermal settings legluondunet NVIDIA Linux 26 05-04-13 05:56 AM
8800 GT and Ubuntu - Plymouth low resolution legluondunet NVIDIA Linux 3 06-24-12 03:22 PM
Opinions on 1280x1024 resolution skipparoo NVIDIA GeForce 7, 8, And 9 Series 103 06-22-12 11:38 PM
30.82 and 40.41 resolution + monitor OSD. Max3D NVIDIA Windows Graphics Drivers 2 09-05-02 02:15 AM
Resolution MichaelZ NVIDIA Linux 7 08-07-02 06:18 PM

All times are GMT -5. The time now is 12:45 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.