Go Back   nV News Forums > Linux Support Forums > NVIDIA FreeBSD

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-28-04, 05:29 PM   #37
mehigh
Registered User
 
Join Date: Aug 2004
Posts: 3
Default Re: 1.0-6113 for FreeBSD thread

Hi

Since I installed the new nVidia drivers problems started to appear. I followed the faq and patched the files but no use. My computer simply freezed and reseted.

What can I say it's very frustrating for Freebsd, those things shouldn't happen, right?

Anyway I returned to the previous driver and I hope everything will be ok, I got 200 more frames in glxgears using the old drivers 43.65

I wonder what are your experiences with this new driver

Regards
mehigh is offline   Reply With Quote
Old 08-31-04, 10:42 AM   #38
dehling
Registered User
 
Join Date: Aug 2004
Posts: 1
Default Re: 1.0-6113 for FreeBSD thread

This driver locks up my system completely, even with AGP disabled. Just like recent versions of the NV opensource driver. Older versions of both drivers worked prefectly :-(

Intel 440BX motherboard
Pentium 2 350Mhz
Diamond viper v770 (TNT 2, 32MB)

Eike.
dehling is offline   Reply With Quote
Old 09-01-04, 01:31 PM   #39
UNIX4ALL
Registered User
 
Join Date: May 2003
Location: Tenerife, Canary Islands
Posts: 5
Thumbs down Re: 1.0-6113 for FreeBSD thread

Quote:
This driver locks up my system completely, even with AGP disabled. Just like recent versions of the NV opensource driver. Older versions of both drivers worked prefectly :-(
Same here, this drivers freezes all my computer randomly (only when Im on X, moving icons, browsing, with gnome-terminal ...) I Tested with FreeBSD AGP, Nvidia AGP and without AGP with SMP enabled, now Im recompiling the kernel without SMP and test.

FreeBSD 5.3-BETA2 (cvsupped of today)
Intel Pentium 4 3,06Ghz HT
Asus P4G8X Deluxe (Intel E7205 Chipset)
Asus V9520 TD 256MB (Only works with this driver version, the older driver canīt initialize the card)
CPUTYPE=i686
CFLAGS & CXXFLAGS = -O -pipe.

I Hope Nvidia will fix these problems soon, a lot of crashes arenīt good for my partitions and it is very frustating.
UNIX4ALL is offline   Reply With Quote
Old 09-03-04, 08:17 AM   #40
hishnik
Registered User
 
Join Date: Sep 2004
Posts: 4
Unhappy Re: 1.0-6113 for FreeBSD thread

Quote:
Originally Posted by muythaibxr
Anybody have any luck with AGP on an ASUS k8v deluxe mobo (Athlon 64, but running it 32-bit mode)?? It appears according to the README file, nvidia's internal AGP support doesn't support the via 8385 AGP controller, which is what this mobo has.

I tried recompiling the kernel module the correct way to use FreeBSD's AGP, but then when I try to start X that way, the machine hangs requiring a hard reset.

Kinda frustrating if you ask me.
I think I would have such problem
The same situation.
hishnik is offline   Reply With Quote
Old 09-05-04, 07:24 AM   #41
UNIX4ALL
Registered User
 
Join Date: May 2003
Location: Tenerife, Canary Islands
Posts: 5
Default It works

Well, after several days of usage with an UP kernel (not SMP enabled) Its rock solid, nothing nasty, all works without hangs but the problems arise when I build a SMP kernel.

SMP + NVIDIA = Hangs on X.

UP + NVIDIA = Rock Solid.

Well, there are any information, progress or anything about this issue ?
UNIX4ALL is offline   Reply With Quote
Old 09-05-04, 08:28 AM   #42
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: 1.0-6113 for FreeBSD thread

@UNIX4ALL: are you using FreeBSD's AGPGART driver or the builtin NvAGP driver? In the former case, does the SMP problem reproduce with NvAGP? Also, does the behavior change if you build the kernel without optimizations (i.e. with the default flags)?
zander is offline   Reply With Quote
Old 09-05-04, 10:26 AM   #43
UNIX4ALL
Registered User
 
Join Date: May 2003
Location: Tenerife, Canary Islands
Posts: 5
Default Re: 1.0-6113 for FreeBSD thread

Quote:
@UNIX4ALL: are you using FreeBSD's AGPGART driver or the builtin NvAGP driver? In the former case, does the SMP problem reproduce with NvAGP? Also, does the behavior change if you build the kernel without optimizations (i.e. with the default flags)?
I use booth, and hang with NvAGP too, moving away make.conf (for defaults optimizations) make the same situation .

Post #39 have information about my hardware and software versions.
UNIX4ALL is offline   Reply With Quote
Old 09-06-04, 06:57 AM   #44
UNIX4ALL
Registered User
 
Join Date: May 2003
Location: Tenerife, Canary Islands
Posts: 5
Smile Re: 1.0-6113 for FreeBSD thread

I have discover the fix to this problem:

Patching sys/kern/uipc_socket.c to version 1.212 and recompiling kernel with SMP enabled and debug.mpsafenet=1 debug.mpsafevm=1 works great ! The hangs are related to the problems on poll()/select() application wedge with debug.mpsafenet=1, because the fix isnīt MFC'ed we have this problems, a temporary workaround is patching by hand, however on the next few days the patch will appear on RELENG_5.

The patch is here:

patch

Last edited by UNIX4ALL; 09-06-04 at 06:59 AM. Reason: Fix link
UNIX4ALL is offline   Reply With Quote

Old 09-06-04, 10:22 AM   #45
hishnik
Registered User
 
Join Date: Sep 2004
Posts: 4
Exclamation Re: 1.0-6113 for FreeBSD thread

Quote:
Originally Posted by muythaibxr
Anybody have any luck with AGP on an ASUS k8v deluxe mobo (Athlon 64, but running it 32-bit mode)?? It appears according to the README file, nvidia's internal AGP support doesn't support the via 8385 AGP controller, which is what this mobo has.

I tried recompiling the kernel module the correct way to use FreeBSD's AGP, but then when I try to start X that way, the machine hangs requiring a hard reset.

Kinda frustrating if you ask me.
The Same Thing.
I can't use this driver - it's really bad thing i'm think.
Is there any ideas?
There is nothing unusual in log. It ends with

(II) NVIDIA(0): Setting mode "1280x1024"

That's all.
Please help US.
hishnik is offline   Reply With Quote
Old 09-16-04, 12:13 PM   #46
hishnik
Registered User
 
Join Date: Sep 2004
Posts: 4
Default Is anybody here? (-)

---
hishnik is offline   Reply With Quote
Old 09-16-04, 12:58 PM   #47
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: 1.0-6113 for FreeBSD thread

@hishnik: you'll need to provide more information about your hardware/sofware configuration. Without it, we can only guess: have you tried disabling ACPI?
zander is offline   Reply With Quote
Old 09-27-04, 12:49 PM   #48
Oberonald
To newbie or not to be
 
Join Date: Sep 2004
Location: Netherlands
Posts: 2
Default Re: 1.0-6113 for FreeBSD thread

Just a short question....

Is there a way (for a newby so please dont make it too complex) to get FreeBSD 5.2.1. to work on a AMD64 with a NVIDIA Geforce FX-5500 card? I've been busy for day's, surfing the Internet, trying to figure things out only to reach the conclusion that it's probably "impossible". There simply are no NVIDIA drivers to be used on a AMD64 FreeBSD machine.

Am I correct? Or is there there still hope ;-))
Oberonald is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:33 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Đ1998 - 2014, nV News.