Go Back   nV News Forums > Linux Support Forums > NVIDIA FreeBSD

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-23-04, 10:09 AM   #97
Nvidiot
Registered User
 
Join Date: Dec 2004
Posts: 1
Default Re: 1.0-6113 for FreeBSD thread

I am running FreeBSD 5.3 together with xorg 6.8.1 and your 6113 freebsd driver. However, when I try to start X, I get the following error:

(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!
(EE) NVIDIA(0): *** Aborting ***

I compiled the nvidia driver with -DACPI_ENABLE so I could make use of the acpi functions in my laptop.

I have attached dmesg, sysctl hw.nvidia and Xorg.0.log files. If there is anything further that I can do to help you such as compiling a new kernel or providing other information, please let me know.

PS. I tried emailing freebsd-gfx-bugs@nvidia.com but that message bounced
Attached Files
File Type: txt dmesg.txt (5.6 KB, 256 views)
File Type: txt nvidia_sysctl.txt (427 Bytes, 242 views)
File Type: txt Xorg.0.log.txt (18.0 KB, 288 views)
Nvidiot is offline   Reply With Quote
Old 12-27-04, 06:43 AM   #98
expl0i
Registered User
 
Join Date: Dec 2004
Posts: 1
Default Nvidia driver's Linux ABI compatiability

Nvidia driver's Linux ABI compatiability

It seems that the nvidia's version of linux_base libGL.so.1 is failing with segmentation fault when trying to load it with any linux binary that uses ogl.

I use 5.3-RELEASE, linux_base-8-8.0_4 and nvidia-driver-1.0.6113_1.

Please do help!

P.S. The freebsd version of ogl runs just fine.
expl0i is offline   Reply With Quote
Old 01-08-05, 06:40 PM   #99
splat
Registered User
 
Join Date: Aug 2004
Posts: 3
Default Re: 1.0-6113 for FreeBSD thread

Hi,

Upon starting X with multipl cards, the machine crashes. I've set a bug report to freebsd-gfx-bugs@nvidia.com but it bounced. I've tried most combinations of FreeBSD versions and X (that actually find multiple cards), with similar results. Here's the data from a 6.0 (8th Jan) version with 2 MX4000 cards runngin xorg 6.7.0_9 (from a serial console). I can run any tests or versions that might help - just let me know.

Thanks

John
Attached Files
File Type: txt crash.txt (608 Bytes, 221 views)
File Type: txt trace.txt (1.4 KB, 237 views)
File Type: txt sysctl.txt (1.0 KB, 254 views)
splat is offline   Reply With Quote
Old 01-21-05, 05:49 PM   #100
reinhard.lennin
Registered User
 
Join Date: Jan 2005
Posts: 1
Default Re: 1.0-6113 for FreeBSD thread

i am currently using freebsd 5.3-RELEASE with the 1.0-6113 nvidia driver. everything worked perfectly under freebsd 5.2.1 with this driver but using it under 5.3 the x server (xorg 6.8.1) freezes several times a day so i can only shutdown the computer (acpi - power button, the system is still responding). this always happens suddenly while playing enemy territory, an open gl game using linux emulation.

are there plans to release an updated driver for freebsd 5.3 soon? unfortunately using gnu/linux is no option for me. :/
reinhard.lennin is offline   Reply With Quote
Old 01-31-05, 08:35 AM   #101
andras
Registered User
 
Join Date: Jan 2005
Posts: 1
Default Re: 1.0-6113 for FreeBSD thread

I'm using FreeBSD 5.3.
The driver 1.0-6113 + xorg 6.8.0 (or 6.7.0) was working fine.
After portupgrade, i have xorg 6.8.1 and problem with system hang-up when i try enemy-territory or doom3; glxgears runs with 600F/S. I recompiled kernel without agp and using : Option "NvAGP" "1".

It was my mistake ;-) i had to reinstall /usr/ports/x11/nvidia-driver (i've made portupgrade while x11 was running) , now everything works like before..

Last edited by andras; 01-31-05 at 12:08 PM. Reason: solved
andras is offline   Reply With Quote
Old 02-06-05, 12:18 AM   #102
m87carlson
Registered User
 
Join Date: Feb 2005
Posts: 1
Default Works great!

I know its typical to post problems in a forum, but I for one have always had pretty good sucess with the FreeBSD Drivers. Currently I use a Dell Percision 670 running FreeBSD 5.3

So far I everything works great with the Geforce Quadro1300FX PCI-e 16x card. I can even run the doom3 demo with acceptable framerates.

I just wanted to post an encouraging word on the Drivers for others. I've used almost everything from a tnt2 to a Quardo with both Drivers rev's and the FreeBSD 5.x branch. Please keep up the good work
m87carlson is offline   Reply With Quote
Old 02-07-05, 04:47 AM   #103
jmann
Registered User
 
Join Date: Feb 2005
Posts: 1
Default Re: 1.0-6113 for FreeBSD thread

I'm running FreeBSD 5.3-RELEASE.

I have attempted the build the driver without Linux ABI compatibility, by editting src/nv-freebsd.h and changing:

#define NV_SUPPORT_LINUX_COMPAT

to

#undef NV_SUPPORT_LINUX_COMPAT

However, the driver build script still wants to install files into /compat/linux/ subdirectories, and when the module is loaded, it still preloads linux.ko.

Why is this?
jmann is offline   Reply With Quote
Old 02-20-05, 12:21 AM   #104
darius
foo
 
Join Date: Nov 2002
Posts: 38
Default Re: 1.0-6113 for FreeBSD thread

Quote:
Originally Posted by lanjoe9
Thanks Harvey, that stopped the message and actually stopped another which said "stray irq 7".

However I can't make my desktop computer's card work, I'll try the various solutions floating around here..
"stray irq 7" is from your parallel port - just ignore it.
darius is offline   Reply With Quote

Old 02-20-05, 01:06 AM   #105
darius
foo
 
Join Date: Nov 2002
Posts: 38
Default Re: 1.0-6113 for FreeBSD thread

I'm getting a panic with 6.0-CURRENT, the 6113 drivers and a Dell Inspiron 8600 with an Fx5200 Go..



# startx
xauth: (argv):1: bad display name ":0" in "list" command
xauth: (stdin):1: bad display name ":0" in "add" command
xauth: (argv):1: bad display name ":0" in "list" command
xauth: (stdin):1: bad display name ":0" in "add" command


X Window System Version 6.8.1
Release Date: 17 September 2004
X Protocol Version 11, Revision 0, Release 6.8.1
Build Operating System: FreeBSD 6.0 i386 [ELF]
Current Operating System: FreeBSD 6.0-CURRENT FreeBSD 6.0-CURRENT #0: Sun Feb 1
3 21:23:24 CST 2005 darius@inchoate.localdomain:/usr/obj/usr/src/sys/INCHOAT
E i386
Build Date: 02 December 2004
Before reporting problems, check http://wiki.X.Org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Feb 20 17:05:45 2005
(==) Using config file: "/usr/X11R6/lib/X11/xorg.conf"

(EE) Failed to load module "speedo" (module does not exist, 0)

NVRM: detected agp.ko, aborting NVIDIA AGP setup!



Fatal trap 12: page fault while in kernel mode
fault virtual address = 0xbfc00000
fault code = supervisor write, page not present
instruction pointer = 0x8:0xc05ac6e5
stack pointer = 0x10:0xd558c9c0
frame pointer = 0x10:0xd558c9cc
code segment = base 0x0, limit 0xfffff, type 0x1b
= DPL 0, pres 1, def32 1, gran 1
processor eflags = interrupt enabled, resume, IOPL = 3
current process = 106 (Xorg)
[thread pid 106 tid 100043 ]
Stopped at pmap_unmapdev+0x4d: movl $0,PTmap(,%eax,4)
db>
db> bt
No such command
db> tr
Tracing pid 106 tid 100043 td 0xc1e34450
pmap_unmapdev(98,1000,d558c9fc,c07fc8a2,98) at pmap_unmapdev+0x4d
os_unmap_kernel_space(98,1000,d558c9fc,c07fc894,2) at os_unmap_kernel_space+0xe
_nv001148rm(c1e10c00,98,1000,c209a200,0) at _nv001148rm+0x1e
_nv000938rm(c2230000,3,0,c2230000,a) at _nv000938rm+0x29c
_nv001635rm(c21d9000,11,10,74,c1d00021) at _nv001635rm+0x137
_nv001545rm(c21d9000,4,0,c07fcb42,c1e10c00) at _nv001545rm+0x62
_nv006175rm(c1e60a00,c1d7dd00,0,d558caf0,c0801ccb) at _nv006175rm+0x9b
rm_shutdown_adapter(c1e60a00,c1e60a00,c1e60b00,c1e 60a00,d558cb34) at rm_shutdown
_adapter+0x51
nvidia_close_dev(c1e60b00,c1e60900,c1e34450,c1e60a 00,c1e01280) at nvidia_close_d
ev+0x4e
nvidia_dev_close(c1e60900,3,2000,c1e34450,c1e60900 ) at nvidia_dev_close+0x30
devfs_close(d558cb78) at devfs_close+0x24e
VOP_CLOSE_APV(c0605700,d558cb78) at VOP_CLOSE_APV+0x38
vn_close(c220d564,3,c1d7cd80,c1e34450,c1d7dd00) at vn_close+0x40
vn_closefile(c2174678,c1e34450,d558cc2c,c0491b08,c 2174678) at vn_closefile+0xd6
devfs_close_f(c2174678,c1e34450) at devfs_close_f+0xf
fdrop_locked(c2174678,c1e34450,c1d68688,0,c05de717 ) at fdrop_locked+0x70
fdrop(c2174678,c1e34450,c0571ed4,c14453c0,c1437330 ) at fdrop+0x24
closef(c2174678,c1e34450,0,c1e34450,7) at closef+0x33b
close(c1e34450,d558cd14,1,9a,3282) at close+0x17d
syscall(2f,2f,2f,0,836e000) at syscall+0x213
Xint0x80_syscall() at Xint0x80_syscall+0x1f
--- syscall (6, FreeBSD ELF32, close), eip = 0x2823e933, esp = 0xbfbfeb4c, ebp = 0xbfbfeb68 ---
db> show reg
cs 0x8
ds 0xc04a0010 linker_lookup_file+0x1c4
es 0xd5580010
fs 0xc20b0018
ss 0x10
eax 0
ecx 0x2000
edx 0
ebx 0x2000
esp 0xd558c9c0
ebp 0xd558c9cc
esi 0
edi 0x98
eip 0xc05ac6e5 pmap_unmapdev+0x4d
efl 0x13246
dr0 0
dr1 0
dr2 0
dr3 0
dr4 0xffff0ff0
dr5 0x400
dr6 0xffff0ff0
dr7 0x400

darius is offline   Reply With Quote
Old 02-28-05, 02:51 PM   #106
muythaibxr
Registered User
 
Join Date: Nov 2002
Posts: 13
Send a message via AIM to muythaibxr
Default Re: 1.0-6113 for FreeBSD thread

I sure hope nVidia releases a new driver soon, since they haven't released one since Aug.... I STILL don't have AGP support on my K8T800 chipset... it's planned for the next release....
muythaibxr is offline   Reply With Quote
Old 03-23-05, 12:04 AM   #107
lanjoe9
Registered User
 
Join Date: Aug 2004
Posts: 24
Default Re: 1.0-6113 for FreeBSD thread

I hope my laptop's TV-OUT works again.... and my desktop's CRT-OUT works again as well!
lanjoe9 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:45 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.