Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-17-04, 01:07 AM   #1
Tanveer
Registered User
 
Join Date: Oct 2003
Posts: 4
Default New nvsound driver. Great sound but still having some problems...

First of all kudos to the nvidia people. You guys are doing great work for us linux fans. The graphics driver is just great and keeps getting better. I have NEVER had a problem with the driver in any way.

But the sound story is slightly different. For months now i have been working with Kernel 2.6 (2.6.7 currently) so had to content with the ALSA drivers (i have given my system config below). The alsa drivers gave a pathetic sound quality and that too with only 2 channels. So naturally i was delighted to find the new NForce nvsound 1.0-0283 drivers from nvidia with 6-channel sound and hardware mixing! The sound quality is great and the hardware mixing really works.

But i am having some small annoyances:

- nvmixer forgets the '5.1 speakers' mode everytime i boot my system and i have to set the mode manually.

- the driver does not have options to create the center channel and the LFE as the windows one does. Does anybody know how to artificially create the center channel from stereo files using this driver or some plugin for any audio player under linux.

- when i play 5.1 AC3 files the channels get swapped in wierd ways. While playing one file the center channel is played in the right front speaker! Similarly while playing multichannel ogg files too the channels dont play at their own place. But strangely when i play multichannel WMA (windows media audio) or WMV (windows media video) files through the mplayer plugin the channels play properly. May be this problem is more concerned with the media players under linux than the drivers.

My configuraton:

ASUS A7N266-E board with original nforce1 chip
Athlon 1800+
Geforce3 Ti 200

I had to do the following to make the nvsound driver work. hope it helps somebody:
- add the boot paramaters 'acpi=off' and 'noapic' to the kernel, otherwise the nvsound module would hang while being loaded.
- use '-channels 6' while using mplayer. Otherwise it says 'Your system is too SLOW to play this!' while playing certain video files and then hangs.

Tanveer.
__________________
If it feels good. it must be Linux!
Tanveer is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
My UT2003 Tweak Guide DXnfiniteFX Gaming Central 48 10-30-02 11:59 PM
F1 2002 problems with driver 40.41 arutten NVIDIA Windows Graphics Drivers 6 10-01-02 07:07 AM
RH7.3 & nVidia driver problems BigChin NVIDIA Linux 4 10-01-02 01:33 AM
red hat 7.3 driver problems please help war18 NVIDIA Linux 7 09-16-02 12:25 PM

All times are GMT -5. The time now is 01:52 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.