Go Back   nV News Forums > Linux Support Forums > General Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-13-04, 09:17 AM   #1
ratnarajesh
Registered User
 
Join Date: Aug 2004
Posts: 2
Unhappy RedHat Enterprise WS 2.1 and Nvidia 980 Quadro 4 XGL

Dear All,

I have a proprietary software (which is developed specific to Redhat Enterprise WS 2.1). When I try to install this software on WS 3.0, it is throwing several errors. Then I was suggested by the particular company to go for WS 2.1.

So I upgraded (downgraded!) my OS to WS 2.1. Now I have a problem with graphic interface. The startx is not working (Only a blue screen with several horizontal streaks).

Details -
OS - Redhat Linux Enterprise Work Station 2.1
Graphics card - nVidia Corporation NV28GL [Quadro4 980 XGL].
Monitor - Hyundai ImageQUest L90D

After extensively searching the web, I realized that WS 2.1 is too primitive to recognize this Video card (which is relatively new). So then I upgraded the libraries as suggested by RedHat (https://rhn.redhat.com/errata/RHEA-2003-131.html).
But unfortunately this didnot solve the problem.

Then I install/setup the nVidia driver from http://www.nvidia.com/object/linux_d..._1.0-6111.html
inorder to make sure that the system is fully up to date (including the kernel).

Still no use.

I am clueless. Please suggest me how to solve this problem.

Last few lines of error message when I run 'startx' :
================================================== ===
Fatal server error:
AddScreen/ScreenInit failed for driver 0


If you encounter a server crash, please report the problem by filing a bug
report in the XFree86.org bugzilla at http://bugs.xfree86.org and/or Red Hat
bugzilla at http://bugzilla.redhat.com/bugzilla. When filing your report, it
is very important that you explain your problem in as much detail as possible,
and include a complete description on how to reproduce the problem. After
submitting the bug report, attach the following files as uncompressed
individual file attachments using the bugzilla file attachment feature:
- X server log file: /var/log/XFree86.0.log
- Kernel log file: /var/log/messages

XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
after 0 requests (0 known processed) with 0 events remaining.
================================================== =========

Thank you.

Raj
ratnarajesh is offline   Reply With Quote
Old 08-16-04, 05:58 AM   #2
LordMorgul
Electrical Engineer
 
LordMorgul's Avatar
 
Join Date: Dec 2002
Location: San Luis Obispo, CA
Posts: 872
Default Re: RedHat Enterprise WS 2.1 and Nvidia 980 Quadro 4 XGL

Please attach the complete XFree86 log file (/var/log/XFree86.0.log) for review, it may shed some light on the problem.
__________________
"..the triumph of evil is for good men to do nothing." (Edmond Burke)
nVIDIA video driver RPMs for Fedora :: see yum repo at livna.org.
LordMorgul is offline   Reply With Quote
Old 08-16-04, 08:56 AM   #3
ratnarajesh
Registered User
 
Join Date: Aug 2004
Posts: 2
Default Re: RedHat Enterprise WS 2.1 and Nvidia 980 Quadro 4 XGL

Hi
Thanks for the reply.

Please see the error log here.

================================================== ======================
XFree86 Version 4.1.0 (Red Hat Linux release: 4.1.0-58.EL) / X Window System
(protocol Version 11, revision 0, vendor release 6510)
Release Date: 21 December 2001
Build Operating System: Linux 2.4.21-2.ELsmp i686 [ELF]
Build Host: porky.devel.redhat.com

Module Loader present
(==) Log file: "/var/log/XFree86.0.log", Time: Sat Aug 14 17:05:31 2004
(==) Using config file: "/etc/X11/XF86Config-4"
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) ServerLayout "XFree86 Configured"
(**) |-->Screen "Screen0" (0)
(**) | |-->Monitor "CustomConfiguration"
(**) | |-->Device "Unsupported VGA compatible"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Keyboard0"
(**) Option "XkbLayout" "us"
(**) XKB: layout: "us"
(==) Keyboard: CustomKeycode disabled
(**) FontPath set to "unix/:7100"
(==) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(--) using VT number 7

(WW) Cannot open APM
(II) Module ABI versions:
XFree86 ANSI C Emulation: 0.1
XFree86 Video Driver: 0.4
XFree86 XInput driver : 0.2
XFree86 Server Extension : 0.1
XFree86 Font Renderer : 0.2
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="The XFree86 Project"
compiled for 4.1.0, module version = 1.0.0
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.2
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="The XFree86 Project"
compiled for 4.1.0, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.4
(II) PCI: Probing config type using method 1
(II) PCI: Config type is 1
(II) PCI: stages = 0x03, oldVal1 = 0x00000000, mode1Res1 = 0x80000000
(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 8086,2570 card 1043,80f2 rev 02 class 06,00,00 hdr 00
(II) PCI: 00:01:0: chip 8086,2571 card 0000,0000 rev 02 class 06,04,00 hdr 01
(II) PCI: 00:1d:0: chip 8086,24d2 card 1043,80a6 rev 02 class 0c,03,00 hdr 80
(II) PCI: 00:1d:1: chip 8086,24d4 card 1043,80a6 rev 02 class 0c,03,00 hdr 00
(II) PCI: 00:1d:2: chip 8086,24d7 card 1043,80a6 rev 02 class 0c,03,00 hdr 00
(II) PCI: 00:1d:3: chip 8086,24de card 1043,80a6 rev 02 class 0c,03,00 hdr 00
(II) PCI: 00:1d:7: chip 8086,24dd card 1043,80a6 rev 02 class 0c,03,20 hdr 00
(II) PCI: 00:1e:0: chip 8086,244e card 0000,0000 rev c2 class 06,04,00 hdr 01
(II) PCI: 00:1f:0: chip 8086,24d0 card 0000,0000 rev 02 class 06,01,00 hdr 80
(II) PCI: 00:1f:1: chip 8086,24db card 1043,80a6 rev 02 class 01,01,8a hdr 00
(II) PCI: 00:1f:2: chip 8086,24d1 card 1043,80a6 rev 02 class 01,01,8f hdr 00
(II) PCI: 00:1f:3: chip 8086,24d3 card 1043,80a6 rev 02 class 0c,05,00 hdr 00
(II) PCI: 00:1f:5: chip 8086,24d5 card 1043,80f3 rev 02 class 04,01,00 hdr 00
(II) PCI: 01:00:0: chip 10de,0288 card 10de,0174 rev a1 class 03,00,00 hdr 00
(II) PCI: 02:03:0: chip 1106,3044 card 1043,808a rev 46 class 0c,00,10 hdr 00
(II) PCI: 02:04:0: chip 1106,3164 card 1043,80f4 rev 06 class 01,04,00 hdr 00
(II) PCI: 02:0a:0: chip 10b7,9200 card 10b7,1000 rev 78 class 02,00,00 hdr 00
(II) PCI: End of PCI scan
(II) LoadModule: "scanpci"
(II) Loading /usr/X11R6/lib/modules/libscanpci.a
(II) Module scanpci: vendor="The XFree86 Project"
compiled for 4.1.0, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.4
(II) UnloadModule: "scanpci"
(II) Unloading /usr/X11R6/lib/modules/libscanpci.a
(II) Host-to-PCI bridge:
(II) PCI-to-ISA bridge:
(II) PCI-to-PCI bridge:
(II) PCI-to-PCI bridge:
(II) Bus 0: bridge is at (0:0:0), (-1,0,0), BCTRL: 0x08 (VGA_EN is set)
(II) Bus 0 I/O range:
[0] -1 0x00000000 - 0x0000ffff (0x10000) IX[b]
(II) Bus 0 non-prefetchable memory range:
[0] -1 0x00000000 - 0xffffffff (0x0) MX[b]
(II) Bus 0 prefetchable memory range:
[0] -1 0x00000000 - 0xffffffff (0x0) MX[b]
(II) Bus 1: bridge is at (0:1:0), (0,1,1), BCTRL: 0x08 (VGA_EN is set)
(II) Bus 1 I/O range:
(II) Bus 1 non-prefetchable memory range:
[0] -1 0xfc900000 - 0xfe9fffff (0x2100000) MX[b]
(II) Bus 1 prefetchable memory range:
[0] -1 0xdff00000 - 0xefefffff (0x10000000) MX[b]
(II) Bus 2: bridge is at (0:30:0), (0,2,2), BCTRL: 0x02 (VGA_EN is cleared)
(II) Bus 2 I/O range:
[0] -1 0x0000d000 - 0x0000dfff (0x1000) IX[b]
(II) Bus 2 non-prefetchable memory range:
[0] -1 0xfea00000 - 0xfeafffff (0x100000) MX[b]
(II) Bus 2 prefetchable memory range:
(II) Bus -1: bridge is at (0:31:0), (0,-1,0), BCTRL: 0x08 (VGA_EN is set)
(II) Bus -1 I/O range:
(II) Bus -1 non-prefetchable memory range:
(II) Bus -1 prefetchable memory range:
(--) PCI:*(1:0:0) NVidia unknown chipset (0x0288) rev 161, Mem @ 0xfd000000/24, 0xe0000000/27, BIOS @ 0xfe9e0000/17
(II) Addressable bus resource ranges are
[0] -1 0x00000000 - 0xffffffff (0x0) MX[b]
[1] -1 0x00000000 - 0x0000ffff (0x10000) IX[b]
(II) OS-reported resource ranges:
[0] -1 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[1] -1 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[2] -1 0x000f0000 - 0x000fffff (0x10000) MX[b]
[3] -1 0x000c0000 - 0x000effff (0x30000) MX[b]
[4] -1 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[5] -1 0x0000ffff - 0x0000ffff (0x1) IX[b]
[6] -1 0x00000000 - 0x000000ff (0x100) IX[b]
(II) Active PCI resource ranges:
[0] -1 0xfeaff400 - 0xfeaff47f (0x80) MX[b]
[1] -1 0xfeaff800 - 0xfeafffff (0x800) MX[b]
(II) Active PCI resource ranges after removing overlaps:
[0] -1 0xfeaff400 - 0xfeaff47f (0x80) MX[b]
[1] -1 0xfeaff800 - 0xfeafffff (0x800) MX[b]
(II) OS-reported resource ranges after removing overlaps with PCI:
[0] -1 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[1] -1 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[2] -1 0x000f0000 - 0x000fffff (0x10000) MX[b]
[3] -1 0x000c0000 - 0x000effff (0x30000) MX[b]
[4] -1 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[5] -1 0x0000ffff - 0x0000ffff (0x1) IX[b]
[6] -1 0x00000000 - 0x000000ff (0x100) IX[b]
(II) All system resource ranges:
[0] -1 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[1] -1 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
(II) LoadModule: "dbe"
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="The XFree86 Project"
compiled for 4.1.0, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "GLcore"
(WW) Warning, couldn't open module GLcore
(II) UnloadModule: "GLcore"
(EE) Failed to load module "GLcore" (module does not exist, 0)
(II) LoadModule: "dri"
(II) Loading /usr/X11R6/lib/modules/extensions/libdri.a
(II) Module dri: vendor="The XFree86 Project"
compiled for 4.1.0, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.1
(II) Loading sub module "drm"
(II) LoadModule: "drm"
(II) Loading /usr/X11R6/lib/modules/linux/libdrm.a
(II) Module drm: vendor="The XFree86 Project"
compiled for 4.1.0, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension XFree86-DRI
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.6111
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension GLX
(II) LoadModule: "extmod"
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="The XFree86 Project"
compiled for 4.1.0, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension FontCache
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) LoadModule: "v4l"
(II) Loading /usr/X11R6/lib/modules/drivers/linux/v4l_drv.o
(II) Module v4l: vendor="The XFree86 Project"
compiled for 4.1.0, module version = 0.0.1
ABI class: XFree86 Video Driver, version 0.4
(II) LoadModule: "vga"
(II) Loading /usr/X11R6/lib/modules/drivers/vga_drv.o
(II) Module vga: vendor="The XFree86 Project"
compiled for 4.1.0, module version = 4.0.0
Module class: XFree86 Video Driver
ABI class: XFree86 Video Driver, version 0.4
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
compiled for 4.1.0, module version = 1.0.0
Module class: XFree86 XInput Driver
ABI class: XFree86 XInput driver, version 0.2
(II) v4l driver for Video4Linux
(II) VGA: Generic VGA driver (version 4.0) for chipsets: generic
(II) Primary Device is: PCI 01:00:0
(--) Assigning device section with no busID to primary device
(--) Chipset generic found
(II) resource ranges after xf86ClaimFixedResources() call:
[0] -1 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[1] -1 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[2] -1 0x000f0000 - 0x000fffff (0x10000) MX[b]
(II) resource ranges after probing:
[0] -1 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[1] -1 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[2] -1 0x000f0000 - 0x000fffff (0x10000) MX[b]
(II) Setting vga for screen 0.
(**) VGA(0): Depth 16, (--) framebuffer bpp 16
(==) VGA(0): RGB weight 565
(==) VGA(0): Default visual is TrueColor
(==) VGA(0): Using gamma correction (1.0, 1.0, 1.0)
(==) VGA(0): videoRam: 256 kBytes.
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/X11R6/lib/modules/libvgahw.a
(II) Module vgahw: vendor="The XFree86 Project"
compiled for 4.1.0, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.4
(--) VGA(0): Pixel clocks available:
(--) VGA(0): pixel clocks: 25.280 28.322 25.460 25.460
(II) VGA(0): CustomConfiguration: Using hsync value of 63.90 kHz
(II) VGA(0): CustomConfiguration: Using vrefresh value of 60.00 Hz
(II) VGA(0): Not using default mode "800x600" (insufficient memory for mode)
(II) VGA(0): Not using default mode "800x600" (insufficient memory for mode)
(II) VGA(0): Not using default mode "800x600" (insufficient memory for mode)
(II) VGA(0): Not using default mode "800x600" (insufficient memory for mode)
(II) VGA(0): Not using default mode "1024x768" (insufficient memory for mode)
(WW) VGA(0): Mode pool is empty
(==) VGA(0): Virtual size is 320x200 (pitch 320)
(**) VGA(0): Built-in mode "Generic 320x200 default mode": 12.6 MHz (scaled from 25.2 MHz), 31.5 kHz, 70.2 Hz (VScan)
(II) VGA(0): Modeline "Generic 320x200 default mode" 12.59 320 336 384 400 200 206 207 224 vscan 2 -hsync +vsync
(==) VGA(0): DPI set to (75, 75)
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/X11R6/lib/modules/libfb.a
(II) Module fb: vendor="The XFree86 Project"
compiled for 4.1.0, module version = 1.0.0
ABI class: XFree86 ANSI C Emulation, version 0.1
(II) do I need RAC? No, I don't.
(II) resource ranges after preInit:
[0] 0 0xe0000000 - 0xe7ffffff (0x8000000) MS[b]
[1] 0 0xfd000000 - 0xfdffffff (0x1000000) MS[b]
[2] -1 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
........
........


Fatal server error:
AddScreen/ScreenInit failed for driver 0
ratnarajesh is offline   Reply With Quote
Old 08-17-04, 05:20 PM   #4
LordMorgul
Electrical Engineer
 
LordMorgul's Avatar
 
Join Date: Dec 2002
Location: San Luis Obispo, CA
Posts: 872
Default Re: RedHat Enterprise WS 2.1 and Nvidia 980 Quadro 4 XGL

Alright, it appears you have some configuration problems (hopefully easy to fix), I should have had you post the config at the same time. If you post your /etc/X11/XF86Config-4 I may be able to help you sort through this.

Two things are definitely wrong, you should remove Load "dri" from the extensions, and you should set the video driver to 'nvidia'. The screen configuration may need changes as well.
__________________
"..the triumph of evil is for good men to do nothing." (Edmond Burke)
nVIDIA video driver RPMs for Fedora :: see yum repo at livna.org.
LordMorgul is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Choosing The Right GPU To Take Adobe Workflows To The Max News Archived News Items 0 05-29-12 05:40 PM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 06:48 PM
NVidia Drivers HowTo for RedHat 8.0 needed eduardp NVIDIA Linux 10 10-04-02 03:59 AM

All times are GMT -5. The time now is 09:57 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.