Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-18-04, 05:16 PM   #1
s4FiR
Registered User
 
Join Date: Aug 2004
Posts: 5
Talking NFORCE-0283 and SuSE9.1

hi all

i managed to install the new nforce drivers and modprobed the nvsound module and lsmod lists it.
still i´m wondering whether the nvsound module is used because lsmod also lists the old i810 driver which runs on nforce cipsets.
when i delete the card with yast sound module and modprobe nvsound module i hear no sound.
my question is if the nvsound module is the only module needed to enable sound and if yes what should i do to activate it?
s4FiR is offline   Reply With Quote
Old 08-19-04, 12:56 AM   #2
bdogg
Registered User
 
Join Date: Aug 2004
Posts: 2
Default Re: NFORCE-0283 and SuSE9.1

You need to load the OSS sound module 'sound.ko'. If you don't have this module, recompile and make sure to select 'Open Sound System (DEPRECATED)' under Device Drivers -> Sound -> Open Sound System so you can select 'OSS Sound Modules'. You don't need to select anything else under Open Sound System for it to work.

Then just make sure whatever app you're using is configured to use OSS and you should get audio out of /dev/dsp via nvsound.

On a side note, if anyone has managed to get nvsound to work with ALSA OSS emulation, I'd love to hear about it.
bdogg is offline   Reply With Quote
Old 08-19-04, 12:05 PM   #3
s4FiR
Registered User
 
Join Date: Aug 2004
Posts: 5
Thumbs up Re: NFORCE-0283 and SuSE9.1

thanks bdogg everything went fine
sound is bumping and now i even see information in nvmixer app
how do i load oss sound module at startup?
i imagine something like this alias sound-slot-0 sound!
if i wrong correct me please
about that alsa emulation thing when i find anything out i´ll let you know
s4FiR is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:00 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.