Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-24-04, 09:43 PM   #1
chrisgaskins
Registered User
 
Join Date: Aug 2004
Posts: 5
Unhappy nvsound - GForce3 - Debian - 2.6.8

Ok,

First, let me admit that I know nothing about sound under linux. So, please bear with these newbie questions... <grin>

I have downloaded, compiled, and installed the nvidia platform drivers for IA32 linux. I have nvnet working great. nvsound is loaded, but I don't get any sound at all. The nvmixer does give me an error when every I try to set the volume. Gnome does not see the sound card or play any sounds.

What else do I have to do? Do I need ALSA or OSS? If so what parts? I have never seen the nvidia sould card on the list of support sound cards.

Here is the output from dmesg:

Nvsound: Nvidia Audio Init Module, 19:58:11 Aug 22 2004 version 1.0-0
ACPI: PCI interrupt 0000:00:06.0[A] -> GSI 20 (level, low) -> IRQ 20
PCI: Setting latency timer of device 0000:00:06.0 to 64
Nvsound: NVIDIA CK8S Audio found at IO 0xe400 and 0xe800, IRQ 14
Nvsound: Aci_device dff3e800 Apu_device 00000000
Nvsound: DEV MIXER 16 DEV AUDIO 3
NET: Registered protocol family 10
Disabled Privacy Extensions on device c0477c20(lo)
IPv6 over IPv4 tunneling driver
NVRM: AGPGART: unable to set MTRR write-combining
NVRM: not using NVAGP, AGPGART is loaded!!
NVRM: AGPGART: unable to set MTRR write-combining
NVRM: not using NVAGP, AGPGART is loaded!!
eth1: no IPv6 routers present
Nvsound: Set format as 10
Nvsound: Unable to change the Playback SampleRate, set back to 48000
Nvsound: Nvaudio_release
Nvsound: Set format as 8
Nvsound: Unable to change the Playback SampleRate, set back to 48000
Nvsound: Nvaudio_release
Nvsound: Set format as 10
Nvsound: Nvaudio_release
Nvsound: Set format as 10
Nvsound: Nvaudio_release
Nvsound: Set format as 10
Nvsound: Nvaudio_release
Nvsound: Set format as 10
Nvsound: Nvaudio_release
Nvsound: Set format as 10
Nvsound: Nvaudio_release
Nvsound: Set format as 10


Any assistance or guidance would be appreciated.

Thank you,
Chris
chrisgaskins is offline   Reply With Quote
Old 08-25-04, 03:57 AM   #2
s4FiR
Registered User
 
Join Date: Aug 2004
Posts: 5
Lightbulb Re: nvsound - GForce3 - Debian - 2.6.8

have you already tried to turn off acpi in bios and give boot options acpi=off and noapic that worked for me
then i just manually loaded the oss driver: as root modprobe sound and then modprobe nvsound
make sure with lsmod that there aren´t any other sound modules loaded otherwise remove them with rmmod <modulename> as root
hopefully soon
s4FiR is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with a GeForce4 MX 440 under Debian Iainuki NVIDIA Linux 1 09-24-02 09:27 PM
Debian Woody 3.0r0 and Problems with Geforce drivers vogt NVIDIA Linux 3 09-09-02 02:07 PM
Riva TNT 2 - Debian (Woody) chipset problem sindra NVIDIA Linux 4 08-26-02 03:21 AM
nvidea drivers on 2.4.18 Debian (3.0 woody) thor NVIDIA Linux 2 08-20-02 02:51 PM

All times are GMT -5. The time now is 08:49 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.