Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-25-04, 06:13 PM   #1
wlm2048
Registered User
 
Join Date: Aug 2004
Posts: 3
Default Yet another dead X

Hi all,
I am having the "nvidia drivers cause X to hang" issue.

My hardware is an HP zd7260us laptop, which uses a go5700 card.

Software is:
gentoo distro
xorg-x11-6.7.0-r2
nvidia-kernel && glx 6111 (opengl-update'd also) and yes, I have removed/re-emerged for each different attempt.
I have tried lots of kernels and options:
stock from kernel.org 2.6.7 w/ no SMP, no USB, no ACPI, no ieee1394, no 4k, etc. all the way to (currently) 2.6.8-r1 w/ all the stuff turned on.

Symptoms are always the same:
Using 'Driver "nvidia"' causes the machine to max CPU on the X process (and ksoftirqd if SMP is enabled)
I get no video at all.
I can ssh in to the machine and kill -9 X, but still have no video. It takes a reboot to get a display back.
It works fine with the "nv" driver, just slow (oh, and there is no xv extension, but that's a different known issue w/ xorg)
I have tried all NvAGP options w/ all the different kernels, and nothing changed.
I have tried all resolutions (640x480 -> 1680x1050) also with no success.

I'll attach my xorg.conf, and if anyone is interested, my .config and/or my nvidia-bug-report.

Any help would be appreciated.

Thanks,
Bill
Attached Files
File Type: txt xorg_conf.txt (2.8 KB, 119 views)
wlm2048 is offline   Reply With Quote
Old 08-25-04, 06:54 PM   #2
drumz
Registered User
 
Join Date: Jun 2004
Posts: 39
Default Re: Yet another dead X

You aren't the only one with this problem. I've posted here, on the gentoo lists, and sent a bug report to nvidia. Nada.

Others who have had the same card chipset as us(5700) have tried other cards with the SAME EXACT SETTINGS and they work. It appears that it may be a problem specific to our cards.

I'm currently waiting on a coworker to get his cards (a 5700 ultra) to see if it works for him (same box, same os (gentoo)) then swap cards. Another coworker has the same exact box and a 5700 ultra and it's working for him under the latest Suse (amd64).

Alternatively, if you allow the card to revert to 'pci mode', you'll get decent 3d performance but slow 2d screen refreshes. But at least it's somewhat usable (although not what we paid for).

It's disappointing to me that nvidia isn't responding to this issue or at least pointing out the error somewhere else that's causing the problem.

Drumz
drumz is offline   Reply With Quote
Old 08-25-04, 07:08 PM   #3
wlm2048
Registered User
 
Join Date: Aug 2004
Posts: 3
Default Re: Yet another dead X

Quote:
Originally Posted by drumz
You aren't the only one with this problem. I've posted here, on the gentoo lists, and sent a bug report to nvidia. Nada.
Yep, I've found your posts which at least let me know I wasn't doing something completely wrong.

Quote:
Originally Posted by drumz
Alternatively, if you allow the card to revert to 'pci mode', you'll get decent 3d performance but slow 2d screen refreshes. But at least it's somewhat usable (although not what we paid for).

It's disappointing to me that nvidia isn't responding to this issue or at least pointing out the error somewhere else that's causing the problem.

Drumz
How do I configure it to go into pci mode? I thought that was one of the NvAGP settings, and I have tried 0-3 there with no luck. Of course, slow 2D at max res would not be very nice. As it is, with the nv driver it isn't *bad*, but I picked an nvidia powered laptop so it would be fast.

Oh well.

-Bill
wlm2048 is offline   Reply With Quote
Old 08-25-04, 07:17 PM   #4
drumz
Registered User
 
Join Date: Jun 2004
Posts: 39
Default Re: Yet another dead X

In your "device" section you should use:

Option "NvAGP" "1"

What's supposed to happen is it will try to use nvidia's built in agp support, but because you have agp support compiled into the kernel (at least I do, I'm on amd 64) it 'fails' because it can't use it and defaults over to PCI mode. This can be verified by using the nvidia-settings app, or examining your /proc/drivers/nvidia/agp/* files. I'm also using xorg, but that shouldn't make a difference.
drumz is offline   Reply With Quote
Old 08-26-04, 01:27 PM   #5
wlm2048
Registered User
 
Join Date: Aug 2004
Posts: 3
Default Re: Yet another dead X

Not even that got it to work... only difference was I could not ssh in; it seemed the machine was hard locked. Hooray for reiser

Thanks for the help though.

(And yeah, this post was mainly a bump)

-Bill
wlm2048 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dead Space 3 + Hitman kills nuns bob saget Gaming Central 6 05-31-12 02:33 PM
Midweek Madness - Dead Island 60% off News Archived News Items 0 05-22-12 06:30 PM
Super Team-Up! The Left 4 Dead / Payday Crossover News Archived News Items 0 05-21-12 06:30 AM

All times are GMT -5. The time now is 10:03 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.