Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-31-04, 09:38 PM   #1
ggambett
Registered User
 
Join Date: Aug 2004
Posts: 20
Default Segfault inside driver, GF4MX 61.11

I'm getting a segfault using OpenGL, inside the driver :
Code:
#0  0x4049942f in memcpy () from /lib/libc.so.6
#1  0x40be17fc in _nv001155gl () from /usr/local/lib/libGLcore.so.1
#2  0x40a1dd34 in _nv000028gl () from /usr/local/lib/libGL.so.1
#3  0x830c408b in ?? ()
Cannot access memory at address 0x424448b
This is with drivers 61.11 just installed. Was doing almost the same with 44.96.

The app is a game I'm developing so I can offer some additional info. There is a terrain which uses ROAM, so the triangle count is variable and view-dependent, as is the segfault (it doesn't happen always, it depends on where the camera is). Besides, this started happening when I added a specific model to the scene. Removing the model stops the segfault. Keeping the model and removing the terrain stops the segfault. Keeping the terrain and using a model with similar index counts stops the segfault.

As far as I could see, when the segfault happened, the terrain engine was using 4097 vertexes in a vertex buffer (and about 21K indices in an index buffer - and yes, I have more than 4097 vertexes allocated). Not every time I used 4097 vertexes it crashed though. Is there any low limit in the size of the vertex or index buffers that I may be hitting?
ggambett is offline   Reply With Quote
Old 08-31-04, 09:54 PM   #2
ggambett
Registered User
 
Join Date: Aug 2004
Posts: 20
Default Re: Segfault inside driver, GF4MX 61.11

More details...
System is Athlon XP 1800+, 512 MB RAM, Kernel 2.4.20, XFree86-4.2.0-72. Logs attached.
Attached Files
File Type: txt XF86Config.txt (3.5 KB, 105 views)
File Type: txt XFree86_0_log.txt (33.1 KB, 118 views)
ggambett is offline   Reply With Quote
Old 09-01-04, 03:43 AM   #3
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Segfault inside driver, GF4MX 61.11

If you can, please provide a simple test case that reproduces the crash.
zander is offline   Reply With Quote
Old 09-01-04, 08:52 AM   #4
ggambett
Registered User
 
Join Date: Aug 2004
Posts: 20
Default Re: Segfault inside driver, GF4MX 61.11

Quote:
Originally Posted by zander
If you can, please provide a simple test case that reproduces the crash.
Unfortunately, I can't - even when I make subtle changes (rendering the terrain at slightly lower quality) the bug goes away, so I think the conditions to trigger it are quite specific.

I could upload the whole project precompiled, you could be able to debug inside the driver code (which I can't). Do you want me to do that?
ggambett is offline   Reply With Quote
Old 09-01-04, 09:07 AM   #5
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Segfault inside driver, GF4MX 61.11

That would help; please send a bug report with all relevant information to linux-bugs@nvidia.com (including X/nvidia-bug-report log files, configuration details, ...).
zander is offline   Reply With Quote
Old 09-01-04, 09:31 AM   #6
ggambett
Registered User
 
Join Date: Aug 2004
Posts: 20
Default Re: Segfault inside driver, GF4MX 61.11

Thank you, I'll do that. Just in case you can't reproduce it, will it help if I also include a core dump?
ggambett is offline   Reply With Quote
Old 09-01-04, 09:57 AM   #7
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Segfault inside driver, GF4MX 61.11

Please do.
zander is offline   Reply With Quote
Old 09-02-04, 08:52 PM   #8
ggambett
Registered User
 
Join Date: Aug 2004
Posts: 20
Default Re: Segfault inside driver, GF4MX 61.11

An update : I found and fixed a bug inside the terrain engine of the rendering engine I'm using, and I'm pretty sure this was the cause of the segfault. I'm really sorry. Shall I delete this thread?
ggambett is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM

All times are GMT -5. The time now is 05:02 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.