Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-10-04, 09:01 AM   #1
WhiteAngel
Registered User
 
Join Date: Aug 2002
Location: Slovenia
Posts: 3
Default unable to load module glx

Three days ago, my Xfree86 4.3.0 stopped working. When running X, I get a short 3-time flicker of the screen and then a black screen. I ssh-ed on my machine and commented the Load "glx" line in XFreee86Config-4. On gdm restart, X were running fine then, but of course I didn't get any accelleration. The funiest thing is that when looking into X log file, I only get a signal 11 after the GLX load.

I have Gf2mx w/ 32MB of ram on PCI and Pentium II 333Mhz on ABit 440LX and 256MB of ram.

I have Debian unstable, using 6111 version of GPU drivers and xserver-xfree86-4.3.0.dfsg.1-7 package. I compiled the Linux 2.6.8.1 kernel with gcc-3.3.4, but it doesn't work on 2.6.7 compiled with gcc-3.3 as well.

Anyone have similar problems?

relevant /var/log/XFree86.0.log info:
...
(II) LoadModule: "nvidia"
(II) Loading /usr/X11R6/lib/modules/drivers/nvidia_drv.o
(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.6111
Module class: XFree86 Video Driver
...
(II) NVIDIA X Driver 1.0-6111 Tue Jul 27 07:56:22 PDT 2004
(II) NVIDIA Unified Driver for all NVIDIA GPUs
(II) Primary Device is: PCI 00:0f:0
(--) Assigning device section with no busID to primary device
(--) Chipset NVIDIA GPU found
(II) resource ranges after xf86ClaimFixedResources() call:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[5] -1 0 0xf9000000 - 0xf9000fff (0x1000) MX[b]
[6] -1 0 0xf9001000 - 0xf90010ff (0x100) MX[b]
[7] -1 0 0xe0000000 - 0xdfffffff (0x0) MX[b]O
[8] -1 0 0xf0000000 - 0xf7ffffff (0x8000000) MX[b](B)
[9] -1 0 0xf8000000 - 0xf8ffffff (0x1000000) MX[b](B)
[10] -1 0 0xf9002000 - 0xf9002fff (0x1000) MX[b](B)
[11] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[12] -1 0 0x00000000 - 0x000000ff (0x100) IX[b]
[13] -1 0 0x00006700 - 0x000067ff (0x100) IX[b]
[14] -1 0 0x00006600 - 0x00006607 (0x8) IX[b]
[15] -1 0 0x00006500 - 0x0000651f (0x20) IX[b]
[16] -1 0 0x00006400 - 0x0000641f (0x20) IX[b]
[17] -1 0 0x0000f000 - 0x0000f00f (0x10) IX[b]
(II) resource ranges after probing:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[5] -1 0 0xf9000000 - 0xf9000fff (0x1000) MX[b]
[6] -1 0 0xf9001000 - 0xf90010ff (0x100) MX[b]
[7] -1 0 0xe0000000 - 0xdfffffff (0x0) MX[b]O
[8] -1 0 0xf0000000 - 0xf7ffffff (0x8000000) MX[b](B)
[9] -1 0 0xf8000000 - 0xf8ffffff (0x1000000) MX[b](B)
[10] -1 0 0xf9002000 - 0xf9002fff (0x1000) MX[b](B)
[11] 0 0 0x000a0000 - 0x000affff (0x10000) MS[b]
[12] 0 0 0x000b0000 - 0x000b7fff (0x8000) MS[b]
[13] 0 0 0x000b8000 - 0x000bffff (0x8000) MS[b]
[14] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[15] -1 0 0x00000000 - 0x000000ff (0x100) IX[b]
[16] -1 0 0x00006700 - 0x000067ff (0x100) IX[b]
[17] -1 0 0x00006600 - 0x00006607 (0x8) IX[b]
[18] -1 0 0x00006500 - 0x0000651f (0x20) IX[b]
[19] -1 0 0x00006400 - 0x0000641f (0x20) IX[b]
[20] -1 0 0x0000f000 - 0x0000f00f (0x10) IX[b]
[21] 0 0 0x000003b0 - 0x000003bb (0xc) IS[b]
[22] 0 0 0x000003c0 - 0x000003df (0x20) IS[b]
(II) Setting vga for screen 0.
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/X11R6/lib/modules/libvgahw.a
(II) Module vgahw: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.6
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NoLogo" "true"
(**) NVIDIA(0): Option "IgnoreDisplayDevices" "DFP, TV"
(--) NVIDIA(0): Linear framebuffer at 0xF0000000
(--) NVIDIA(0): MMIO registers at 0xF8000000
(II) NVIDIA(0): NVIDIA GPU detected as: GeForce2 MX/MX 400
(--) NVIDIA(0): VideoBIOS: 03.11.00.18.00
(--) NVIDIA(0): Interlaced video modes are not supported on this GPU
(--) NVIDIA(0): VideoRAM: 32768 kBytes
(II) NVIDIA(0): Connected display device(s): CRT-0
(--) NVIDIA(0): Display device CRT-0: maximum pixel clock at 8 bpp: 350 MHz
(--) NVIDIA(0): Display device CRT-0: maximum pixel clock at 16 bpp: 350 MHz
(--) NVIDIA(0): Display device CRT-0: maximum pixel clock at 32 bpp: 300 MHz
(II) Loading sub module "ddc"
(II) LoadModule: "ddc"
(II) Reloading /usr/X11R6/lib/modules/libddc.a
(WW) NVIDIA(0): The user specified HorizSync "31.000-75.000" has been adjusted
(WW) NVIDIA(0): to "31.000-70.000" (the intersection with EDID-specified
(WW) NVIDIA(0): HorizSync "30.000-70.000")
(II) NVIDIA(0): Generic Monitor: Using hsync range of 31.00-70.00 kHz
(II) NVIDIA(0): Generic Monitor: Using vrefresh range of 50.00-95.00 Hz
(II) NVIDIA(0): Clock range: 12.00 to 300.00 MHz
(II) NVIDIA(0): Not using default mode "1024x768" (bad mode clock/interlace/doublescan)
(II) NVIDIA(0): Not using default mode "512x384" (bad mode clock/interlace/doublescan)
(WW) (1152x864,Generic Monitor) mode clock 108MHz exceeds DDC maximum 100MHz
(WW) (1280x960,Generic Monitor) mode clock 108MHz exceeds DDC maximum 100MHz
...
(**) NVIDIA(0): Validated modes for display device CRT-0:
(**) NVIDIA(0): Default mode "1024x768": 94.5 MHz, 68.7 kHz, 85.0 Hz
(**) NVIDIA(0): Default mode "800x600": 56.3 MHz, 53.7 kHz, 85.1 Hz
(**) NVIDIA(0): Default mode "640x480": 36.0 MHz, 43.3 kHz, 85.0 Hz
(**) NVIDIA(0): Mode "1024x768/85Hz": 98.9 MHz, 70.2 kHz, 85.5 Hz
(**) NVIDIA(0): Default mode "1024x768": 78.8 MHz, 60.1 kHz, 75.1 Hz
(**) NVIDIA(0): Default mode "1024x768": 75.0 MHz, 56.5 kHz, 70.1 Hz
(**) NVIDIA(0): Default mode "1024x768": 65.0 MHz, 48.4 kHz, 60.0 Hz
(**) NVIDIA(0): Default mode "832x624": 57.3 MHz, 49.7 kHz, 74.6 Hz
(**) NVIDIA(0): Default mode "800x600": 49.5 MHz, 46.9 kHz, 75.0 Hz
(**) NVIDIA(0): Default mode "800x600": 50.0 MHz, 48.1 kHz, 72.2 Hz
(**) NVIDIA(0): Default mode "800x600": 40.0 MHz, 37.9 kHz, 60.3 Hz
(**) NVIDIA(0): Default mode "800x600": 36.0 MHz, 35.2 kHz, 56.2 Hz
(**) NVIDIA(0): Default mode "640x480": 31.5 MHz, 37.5 kHz, 75.0 Hz
(**) NVIDIA(0): Default mode "640x480": 31.5 MHz, 37.9 kHz, 72.8 Hz
(**) NVIDIA(0): Default mode "640x480": 25.2 MHz, 31.5 kHz, 60.0 Hz
(**) NVIDIA(0): Default mode "720x400": 35.5 MHz, 37.9 kHz, 85.0 Hz
(**) NVIDIA(0): Default mode "640x400": 31.5 MHz, 37.9 kHz, 85.1 Hz
(**) NVIDIA(0): Default mode "640x350": 31.5 MHz, 37.9 kHz, 85.1 Hz
(**) NVIDIA(0): Default mode "512x384": 47.2 MHz, 68.7 kHz, 85.0 Hz (D)
(**) NVIDIA(0): Default mode "512x384": 39.4 MHz, 60.1 kHz, 75.1 Hz (D)
(**) NVIDIA(0): Default mode "512x384": 37.5 MHz, 56.5 kHz, 70.1 Hz (D)
(**) NVIDIA(0): Default mode "512x384": 32.5 MHz, 48.4 kHz, 60.0 Hz (D)
(**) NVIDIA(0): Default mode "416x312": 28.6 MHz, 49.7 kHz, 74.7 Hz (D)
(**) NVIDIA(0): Default mode "400x300": 28.1 MHz, 53.7 kHz, 85.3 Hz (D)
(**) NVIDIA(0): Default mode "400x300": 24.8 MHz, 46.9 kHz, 75.1 Hz (D)
(**) NVIDIA(0): Default mode "400x300": 25.0 MHz, 48.1 kHz, 72.2 Hz (D)
(**) NVIDIA(0): Default mode "400x300": 20.0 MHz, 37.9 kHz, 60.3 Hz (D)
(**) NVIDIA(0): Default mode "400x300": 18.0 MHz, 35.2 kHz, 56.3 Hz (D)
(**) NVIDIA(0): Default mode "320x240": 18.0 MHz, 43.3 kHz, 85.2 Hz (D)
(**) NVIDIA(0): Default mode "320x240": 15.8 MHz, 37.5 kHz, 75.0 Hz (D)
(**) NVIDIA(0): Default mode "320x240": 15.8 MHz, 37.9 kHz, 72.8 Hz (D)
(**) NVIDIA(0): Default mode "320x240": 12.6 MHz, 31.5 kHz, 60.1 Hz (D)
(**) NVIDIA(0): Default mode "320x200": 15.8 MHz, 37.9 kHz, 85.3 Hz (D)
(**) NVIDIA(0): Default mode "320x175": 15.8 MHz, 37.9 kHz, 85.3 Hz (D)
(II) NVIDIA(0): Virtual screen size determined to be 1024 x 768
(--) NVIDIA(0): Display dimensions: (280, 210) mm
(--) NVIDIA(0): DPI set to (92, 92)
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/X11R6/lib/modules/libfb.a
(II) Module fb: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 ANSI C Emulation, version 0.2
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Loading /usr/X11R6/lib/modules/libramdac.a
(II) Module ramdac: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.6
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC? No, I don't.
(II) resource ranges after preInit:
[0] 0 0 0xf0000000 - 0xf7ffffff (0x8000000) MX[b]
[1] 0 0 0xf8000000 - 0xf8ffffff (0x1000000) MX[b]
[2] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[3] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[4] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[5] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[6] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[7] -1 0 0xf9000000 - 0xf9000fff (0x1000) MX[b]
[8] -1 0 0xf9001000 - 0xf90010ff (0x100) MX[b]
[9] -1 0 0xe0000000 - 0xdfffffff (0x0) MX[b]O
[10] -1 0 0xf0000000 - 0xf7ffffff (0x8000000) MX[b](B)
[11] -1 0 0xf8000000 - 0xf8ffffff (0x1000000) MX[b](B)
[12] -1 0 0xf9002000 - 0xf9002fff (0x1000) MX[b](B)
[13] 0 0 0x000a0000 - 0x000affff (0x10000) MS[b](OprD)
[14] 0 0 0x000b0000 - 0x000b7fff (0x8000) MS[b](OprD)
[15] 0 0 0x000b8000 - 0x000bffff (0x8000) MS[b](OprD)
[16] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[17] -1 0 0x00000000 - 0x000000ff (0x100) IX[b]
[18] -1 0 0x00006700 - 0x000067ff (0x100) IX[b]
[19] -1 0 0x00006600 - 0x00006607 (0x8) IX[b]
[20] -1 0 0x00006500 - 0x0000651f (0x20) IX[b]
[21] -1 0 0x00006400 - 0x0000641f (0x20) IX[b]
[22] -1 0 0x0000f000 - 0x0000f00f (0x10) IX[b]
[23] 0 0 0x000003b0 - 0x000003bb (0xc) IS[b](OprU)
[24] 0 0 0x000003c0 - 0x000003df (0x20) IS[b](OprU)
(II) NVIDIA(0): Setting mode "1024x768"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(**) Option "dpms"
(**) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(==) RandR enabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension LBX
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing extension GLX

*** If unresolved symbols were reported above, they might not
*** be the reason for the server aborting.

Fatal server error:
Caught signal 11. Server aborting


When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to submit@bugs.debian.org.
WhiteAngel is offline   Reply With Quote
Old 09-10-04, 06:22 PM   #2
whig
550Ti
 
Join Date: Jan 2004
Location: New Zealand
Posts: 854
Default Re: unable to load module glx

Just a guess: a recent package may have installed non-nvidia modules. Re-run the nvidia driver installer - that will remove conflicting modules.
whig is offline   Reply With Quote
Old 09-12-04, 05:13 PM   #3
WhiteAngel
Registered User
 
Join Date: Aug 2002
Location: Slovenia
Posts: 3
Default Re: unable to load module glx

Yeah, I found out that I had as you mentioned a wierd glx library installed. I replaced the one with the original Debian ones (the same as nvidia's) and it works fine now.
WhiteAngel is offline   Reply With Quote
Old 12-17-04, 03:27 AM   #4
cgltower
Registered User
 
Join Date: Jul 2004
Posts: 4
Default Re: unable to load module glx

How did you do that /could you explain? I have exact same error, but all files seem to be in place. If i disable GLX in XF86config-4 file, then X starts. But i need GLX for games!
cgltower is offline   Reply With Quote
Old 12-17-04, 08:17 AM   #5
WhiteAngel
Registered User
 
Join Date: Aug 2002
Location: Slovenia
Posts: 3
Default Re: unable to load module glx

Well, you must have the same version nvidia kernel module and the same version nvidia-glx modules for X. That was my problem.

I removed both the nvidia kernel module (mine is at /lib/modules/2.6.9/nvidia/nvidia.ko) and nvidia-glx module (/usr/X11R6/lib/modules/drivers/nvidia_drv.o). I downloaded the kernel module from Debian repository, extracted it to the kernel source path and recompiled a kernel with make-kpkg modules (compiles kernel modules - only nvidia was present in my situation). After installing the newly created nvidia-module-version-of-kernel-something deb, apt allowed me to install the nvidia-glx as well (which is unique (or should be) for all the kernel versions and platforms). I made sure that nvidia kernel module is loaded at startup (edit /etc/modules and add nvidia if it's not present yet). I tried modprobe nvidia and it worked. I restarted X and it worked too. glx was loaded fine.
WhiteAngel is offline   Reply With Quote
Old 12-17-04, 08:23 AM   #6
Lithorus
Registered User
 
Lithorus's Avatar
 
Join Date: Sep 2004
Posts: 783
Default Re: unable to load module glx

Unless you are using the debianized nvidia driver there is little reason to even install the nvidia-glx package. I would even recommend not to install it. nvidia-glx provides a startup script which will link libGL.so.1 to the nvidia GLX, but this already done under the manual installtion of the nvidia driver. If the nvidia-glx is too old it will link the wrong version of GLX.

As you can see in the file list there is nothing in it which isn't already provided with the nvidia installer :
Quote:
nvidia-glx: etc/default/nvidia-glx
nvidia-glx: etc/init.d/nvidia-glx
nvidia-glx: usr/X11R6/lib/libXvMCNVIDIA.so.1
nvidia-glx: usr/X11R6/lib/libXvMCNVIDIA.so.1.0.6629
nvidia-glx: usr/X11R6/lib/libXvMCNVIDIA_dynamic.so.1
nvidia-glx: usr/X11R6/lib/modules/drivers/nvidia_drv.o
nvidia-glx: usr/X11R6/lib/modules/extensions/libglx.so
nvidia-glx: usr/X11R6/lib/modules/extensions/libglx.so.1.0.6629
nvidia-glx: usr/bin/nvidia-bug-report.sh
nvidia-glx: usr/lib/libGL.so.1
nvidia-glx: usr/lib/libGL.so.1.0.6629
nvidia-glx: usr/lib/libGLcore.so.1
nvidia-glx: usr/lib/libGLcore.so.1.0.6629
nvidia-glx: usr/lib/libnvidia-tls.so.1
nvidia-glx: usr/lib/libnvidia-tls.so.1.0.6629
nvidia-glx: usr/lib/nvidia/libnvidia-tls.so.1.0.6629
nvidia-glx: usr/lib/nvidia/tls_test
nvidia-glx: usr/lib/nvidia/tls_test_dso.so
nvidia-glx: usr/share/bug/nvidia-glx/script
nvidia-glx: usr/share/doc/nvidia-glx/NVIDIA_Changelog.gz
nvidia-glx: usr/share/doc/nvidia-glx/README.Debian
nvidia-glx: usr/share/doc/nvidia-glx/README.gz
nvidia-glx: usr/share/doc/nvidia-glx/changelog.Debian.gz
nvidia-glx: usr/share/doc/nvidia-glx/copyright
nvidia-glx: usr/share/doc/nvidia-glx/examples/XF86Config.sample.gz
nvidia-glx: usr/share/lintian/overrides/nvidia-glx
Lithorus is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
173.14.34 -- Xorg 1.12.1 & 1.11.4, glx module fails to load mereset NVIDIA Linux 17 06-10-12 01:24 AM
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 01:44 PM
Glx mrbig1344 NVIDIA Linux 7 09-30-02 06:45 AM
Error messages... HELP!!!! Imperito NVIDIA Linux 3 09-24-02 10:46 PM
GForce drivers installed...but dont work tomfullery NVIDIA Linux 6 09-22-02 08:23 AM

All times are GMT -5. The time now is 10:25 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.