Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-05-04, 09:24 PM   #1
Magicdev
Registered User
 
Join Date: Sep 2004
Posts: 5
Default no screen after logout

Hello I'm running Linux WS 3.0 with kernel ver. 2.4.21-20.ELsmp
and Nvidia drivers for my 4200 Ti vid card.
My puter has been fine for a while until last night, I updated 157 packages from Redhat, they released um all at one time.
I also updated my Nvidia drivers to the latest ver. 61111

My problem is when I use "log out" to shut down xserver and go to the cmd prompt my screen goes blank and my monitor goes click, indicated no signal from the vid card. I know Linux is still there because I type reboot and it does or I type startx and it does. I have goooooogled this till it's dead.
Anyone have any idea what I can try?

I'm soooo lost now
Magicdev is offline   Reply With Quote
Old 09-08-04, 06:33 AM   #2
intersite
James
 
Join Date: Sep 2004
Location: UK
Posts: 3
Default Re: no screen after logout

I too am getting this, using Fedora Core 1, custom 2.6.7 kernel and BFG Ultra 6800 OC with latest 6111 driver. The machine boots fine (level 3, console), I go into X with "startx", then when I exit X Windows to go back to the console, there a 3 horizontal lines across the screen 1 at the top, 1 in the middle and one near the bottom. The console is useless and I have to hit the reset button.

This is so annoying as when my machine restarts, it has to re-mirror my RAID setup which can take an hour or so.

When are NVidia going to sort this out?
intersite is offline   Reply With Quote
Old 09-11-04, 10:00 AM   #3
cyco
GF4 Ti4200 | nforce2 chip
 
Join Date: Sep 2004
Posts: 17
Default Re: no screen after logout

Same here, using the following:
* Abit NF7 v2.0 mainboard w/ nforce2 chipset
* GeForce4 TI 4200 graphics card
* Athlon XP-M 2500+
* Fedora Core 2
* (1) Kernel 2.6.8-1.521.stk16 or
* (2) same w/o agpgart support compiled in
* Option "NvAGP" is set to "1"

When using kernel (1), everything works fine except the performance is very poor (got about 5-10 fps in torcs). That kernel cannot load nvidia's agp since agpgart is enabled, that's why the performance is that bad.

Using kernel (2), performance is great (about 110 fps in torcs, nvagp is used), but when leaving my desktop environment (kde here), the screen goes blank and the system locks up.

Any clues on this?

Last edited by cyco; 09-11-04 at 10:28 AM.
cyco is offline   Reply With Quote
Old 09-13-04, 08:39 AM   #4
Magicdev
Registered User
 
Join Date: Sep 2004
Posts: 5
Talking Re: no screen after logout

Has anyone got a clue how to fix this yet?
Any ideas to try
Magicdev is offline   Reply With Quote
Old 09-14-04, 04:01 AM   #5
AndreasI
Registered User
 
Join Date: Sep 2004
Posts: 2
Unhappy Re: no screen after logout

I got a similar problem after installng FC2 on my DELL laptop (inspiron 2650). After logout
when the x-server shuts down the display flickers. I can see the text as it shuts down though. Doubt its good for the display.


Card:
GeForce2 Go

Kernel:
2.6.5-1.358

Should I install new drivers.
AndreasI is offline   Reply With Quote
Old 09-14-04, 06:43 AM   #6
AndreasI
Registered User
 
Join Date: Sep 2004
Posts: 2
Default Re: no screen after logout

Updated the driver. This at least got the 3D working (which wasn't working before).

Still problem with the logout though.
AndreasI is offline   Reply With Quote
Old 09-14-04, 10:52 AM   #7
intersite
James
 
Join Date: Sep 2004
Location: UK
Posts: 3
Angry Re: no screen after logout

..and there was me thinking this was just my BFG 6800 Ultra OC playing up!

I built up a new machine (lower spec., lower RAM) than the machine I have my 6800 in at the weekend.

BUT, I installed a Nvidia 5600 128MB (Gainward) in the machine and left the machine running kernel 2.4 (the Ultra 6800 machine uses kernel 2.6.7).

I then cranked up X using the 5600 with the 6111 drivers.

..I then exit X and. . . I get a lock - just like with the 6800 card, but the screen has lots of weird symbols in green all over the console.

I can type a "shutdown now -h" command blindly into the ruined console and make it shutdown, but what a pain in the neck this is turning out to be.

..So Nvidia - your 6111 drivers are broken in kernel 2.4, 2.6 with the 5600 and the 6800 cards...

PLEASE start looking into this - a Google hunt reveals masses of people with this problem. Its time it got sorted.
intersite is offline   Reply With Quote
Old 09-15-04, 05:44 PM   #8
Magicdev
Registered User
 
Join Date: Sep 2004
Posts: 5
Default Re: no screen after logout

shameless bumb
Magicdev is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
RHEL 5.6 .nvidia-settings-rc settings un-applied on screen lock bluziff NVIDIA Linux 1 06-14-12 05:12 AM
Black screen after switching between graphical virtual consoles five times rrr-wtf NVIDIA Linux 1 05-21-12 04:40 PM
Stubborn screen res problem Alpsoandso NVIDIA Linux 6 05-03-12 06:00 PM
Toshiba Sat 1950 screen setup beaulieu NVIDIA Linux 7 06-13-03 03:17 PM
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 06:48 PM

All times are GMT -5. The time now is 02:12 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.