Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-15-04, 02:57 AM   #1
law
Registered User
 
Join Date: Jul 2004
Posts: 5
Default Gfroce Ti 4200 Twinview wont work

hi,

i have tryed to get my "new" geforce ti 4200 to work with my tv. but only one device is alway active.

if i enable this 2 options only my tv works.

Code:
Option      "MetaModes" "CRT-0: 1280x1024,  TV-0: 640x480"
#       Option      "TVStandard" "PAL-B"
#       Option      "ConnectedMonitor" "CRT, TV"
if i this able them only my monitor works

here is my whole xorg.conf

Code:
# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
 Identifier     "single head configuration"
# Identifier     "TwinView"
# Screen      0  "Screen0" 0 0
 Screen         "Screen0"
 InputDevice    "Mouse0" "CorePointer"
 InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database.  Note, this is the name of the 
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
	RgbPath      "/usr/X11R6/lib/X11/rgb"
	FontPath     "unix/:7100"
EndSection

Section "Module"
	Load  "dbe"
	Load  "extmod"
	Load  "fbdevhw"
	Load  "glx"
# edit by me
#	Load  "dri"
	Load  "GLcore"
	Load  "record"
	Load  "freetype"
	Load  "type1"
	Load  "v4l"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#	Option	"Xleds"		"1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
#	Option	"XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#	Option	"XkbModel"	"pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#	Option	"XkbModel"	"microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#	Option	"XkbLayout"	"de"
# or:
#	Option	"XkbLayout"	"de"
#	Option	"XkbVariant"	"nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#	Option	"XkbOptions"	"ctrl:swapcaps"
# Or if you just want both to be control, use:
#	Option	"XkbOptions"	"ctrl:nocaps"
#
	Identifier  "Keyboard0"
	Driver      "keyboard"

	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "de"
	Option	    "XkbVariant" "nodeadkeys"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "IMPS/2"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "no"
EndSection

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
	Identifier  "DevInputMice"
	Driver      "mouse"
	Option	    "Protocol" "IMPS/2"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "no"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor 1280x1024"
	HorizSync    31.5 - 79.0
	VertRefresh  50.0 - 90.0
	Option	    "dpms"
EndSection

Section "Device"

	Driver      "nvidia"
	Identifier  "Videocard0"
#	Driver      "nv"
	VendorName  "Videocard vendor"
	BoardName   "NVIDIA GeForce 4 (generic)"
# edit by me
#	Option	    "TwinView" "true"
#	Option	    "TwinViewOrientation" "Clone"
#	Option	    "SecondMonitorHorizSync" "30-50"
#	Option	    "SecondMonitorVertRefresh" "60"
#	Option	    "SecondConnectedMonitor" "TV"
#	Option      "MetaModes" "CRT-0: 1280x1024,  TV-0: 640x480"
#	Option	    "TVStandard" "PAL-B"
#	Option	    "ConnectedMonitor" "CRT, TV"
#	Option      "TVOutFormat" "COMPOSITE"
#	Option      "NODDC" "true"

EndSection

Section "Screen"
 Identifier "Screen0"
 Device     "Videocard0"
 Monitor    "Monitor0"
 DefaultDepth     24
 SubSection "Display"
  Depth     24
  Modes    "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
 EndSubSection
EndSection

#edit by me
Section "DRI"
 Group        0
 Mode         0666
EndSection
i am using fedora core 2 perhabs someone can help me. or is there an good howto in the inet?
law is offline   Reply With Quote
Old 09-15-04, 03:02 AM   #2
comag
Registered User
 
comag's Avatar
 
Join Date: Sep 2004
Posts: 54
Default Re: Gfroce Ti 4200 Twinview wont work

try CRT-0 or CRT-1 instead of CRT and remove the CRT-0 and TV-0 things from the Metamodes

here is my part:
Code:
    	Option 	    "SecondMonitorHorizSync" "30-50"
    	Option 	    "SecondMonitorVertRefresh" "60"	
   	Option 	    "TVOutFormat" "COMPOSITE"
   	Option 	    "TVStandard" "PAL-G"
	Option	    "TVOverScan" "1.0"	
	Option	    "ConnectedMonitor" "CRT-1, TV-0"
    	Option 	    "TwinViewOrientation" "Clone"
	Option	    "MetaModes" "1280x1024, 800x600@1280x1024"
__________________
Fedora Core 4 (2.6.17) on an x86_64
Geforce 6600GT
comag is offline   Reply With Quote
Old 09-15-04, 03:28 AM   #3
law
Registered User
 
Join Date: Jul 2004
Posts: 5
Default Re: Gfroce Ti 4200 Twinview wont work

juhu thank you it works, but on my tv now i only see the upper left corner of my workspace. how is it possible to see the whole desktop?

Last edited by law; 09-15-04 at 03:45 AM.
law is offline   Reply With Quote
Old 09-15-04, 02:30 PM   #4
comag
Registered User
 
comag's Avatar
 
Join Date: Sep 2004
Posts: 54
Default Re: Gfroce Ti 4200 Twinview wont work

i got the same problem and i think its only possible if TV and CRT have the same resolution.
but i use tv-out only for videos-playback and if you install nvtv the screen will auto-fullscreen the video-overlay on xine. (using "xine -T nvtv").

dunno if you can do it easier, but here is my way:
-- INSTALLATION
- download and install nvtv (includes nvtv and nvtvd)
- compile xine-ui with nvtvsimple support (watch configure messages)

-- PLAYBACK
- start nvtvd
- start "xine -T nvtv"
- start playback -> choose fullscreen (tv will switch to video-overlay)
__________________
Fedora Core 4 (2.6.17) on an x86_64
Geforce 6600GT
comag is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Multiseat X with two cards: used to work, now segfaulting Artefact2 NVIDIA Linux 10 06-26-12 05:22 PM
Twinview? ghorsepower NVIDIA Linux 2 10-11-02 12:46 PM
XF86Config for a Quadro4 without TwinView? Twirlip NVIDIA Linux 1 10-09-02 10:36 AM
How do I configure TwinView on Dell Inspiron rutgerclaes NVIDIA Linux 6 08-01-02 03:20 AM

All times are GMT -5. The time now is 07:04 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.