Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-15-04, 12:56 PM   #1
fanon
Registered User
 
Join Date: Sep 2004
Posts: 2
Unhappy NVIDIA GeForce4 440 Go problems on Toshiba Satellite 5105-S501

My laptop is suffering from what seems to be the not-too-uncommon "half-inch black bar on the right side of the screen." My problem is that I've searched many a forum, tried most of the solutions (which I'll post below), and none of them have worked.

A little about my laptop: I'm running Gentoo, and use Xorg, not XFree. During the install, I did emerge nvidia_kernel and nvidia_glx. My video bios revision is 04.17.00.41.c5. My laptop (a Toshiba Satellite 5105-S501) has a p4 processor.

Most of the solutions I've come across involve passing along the option "options nvidia NVreg_SoftEDIDs=0 NVreg_Mobile=2". When I ran Debian/Woody, something along these lines worked to fix this problem, although it's been so long now, I don't really remember. This option is still sitting in my /etc/modules.conf for good measure, although it seems not to work. Perhaps I just need to pass it different values, although I'm not sure what those would be. I also tried "ignoreEDIDs" "true", which gave me a full screen, but it was entirely white.

Any other hardware specs can be found at http://linux.toshiba-dme.co.jp/linux...?model=PS511U-

Any help would be greatly appreciated. I can live with things as they are, but I'd really rather not. I like having my entire screen used.

Here is my /etc/X11/xorg.conf* section for input devices:
*(Most of the stuff in here is just copied right out of the backup XF86Config-4 file that I saved as a backup from when I was running Debian).


# ************************************************** ********************
# Input devices
# ************************************************** ********************

# ************************************************** ********************
# Core keyboard's InputDevice section
# ************************************************** ********************


Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
Option "XkbDisable"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/psaux"
Option "Protocol" "PS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Generic Mouse"
Driver "mouse"
Option "SendCoreEvents" "true"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "Device"
Identifier "nvidia GeForce4"
Driver "nvidia"
BusID "PCI:01:00:0"
Option "NoLogo" "true"
Option "DigitalVibrance" "4"
# Option "UseFBDev" "true"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
HorizSync 31.5-90
VertRefresh 59-75
#Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nvidia GeForce4"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 16
Modes "1280x1024"
#Modes "1600x1200" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024"
#Modes "1600x1200" "1400x1050" "1280x1024"
#"1152x864" "1024x768" "800x600" "640x480"
EndSubSection

Option "TwinView"
Option "TwinViewOrientation" "Core"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Generic Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection
fanon is offline   Reply With Quote
Old 09-16-04, 01:16 PM   #2
fanon
Registered User
 
Join Date: Sep 2004
Posts: 2
Default Re: NVIDIA GeForce4 440 Go problems on Toshiba Satellite 5105-S501

bump
fanon is offline   Reply With Quote
Old 09-16-04, 02:04 PM   #3
matjaz
Registered User
 
Join Date: Apr 2003
Posts: 11
Default Re: NVIDIA GeForce4 440 Go problems on Toshiba Satellite 5105-S501

There seems to be a bug with the 6xxx series of the driver and toshiba laptops that really has no solution. It seems u are going to have to be stuck with the black strip until nvidia decides to fix the driver. There have been several posts about this issue with more info here:
http://www.nvnews.net/vbulletin/showthread.php?t=32997.

Hope this helps,
Matt
matjaz is offline   Reply With Quote
Old 04-23-05, 06:27 PM   #4
bugfood
Registered User
 
Join Date: May 2003
Posts: 19
Default Re: NVIDIA GeForce4 440 Go problems on Toshiba Satellite 5105-S501

There's another thread here:
http://www.nvnews.net/vbulletin/showthread.php?t=43577

...and, good news for anyone else with a toshiba 5105-S501 - I finally made mine work right:
http://www.nvnews.net/vbulletin/showpost.php?p=594857
bugfood is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rumor regarding lack of 680 availability ViN86 Rumor Mill 6 05-09-12 05:48 PM
Toshiba Satellite 1955/S801, GeForce4 440 Go azaroth NVIDIA Linux 2 01-01-03 09:19 PM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-02-02 12:58 AM
Problems with a GeForce4 MX 440 under Debian Iainuki NVIDIA Linux 1 09-24-02 10:27 PM
nVidia Geforce4 440 Go 1400x1050 problem moreinf NVIDIA Linux 10 09-16-02 01:25 PM

All times are GMT -5. The time now is 03:23 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.