Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-17-04, 09:38 AM   #1
uyu
Registered User
 
Join Date: Sep 2004
Posts: 4
Question Xorg 6.8.1 + 6111 problems, libnvidia-tls.so.1

I recently compiled Xorg 6.8.1 on debian/unstable, kernel 2.6.8.1-ck8
Some xmms opengl visualization plugins fail to load with the error:

libnvidia-tls.so.1: cannot handle TLS data.


I'have uninstalled and reinstalled the 6111 driver. No change. I have a Geforce3 Ti200.

$ glxinfo | grep string
server glx vendor string: NVIDIA Corporation
server glx version string: 1.3
client glx vendor string: NVIDIA Corporation
client glx version string: 1.3
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce3/PCI/SSE/3DNOW!
OpenGL version string: 1.5.1 NVIDIA 61.11


$ egrep "^\(II\).*built-in extension" /var/log/Xorg.0.log
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension LBX
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE


/etc/X11/XF86Config has:

# NVIDIA
Section "Device"
Identifier "NV AGP"
VendorName "nvidia"
Driver "nvidia"
Option "NoLogo" "true"
Option "IgnoreDisplayDevices" "DFP, TV"
Option "ConnectedMonitor" "CRT"
Option "HWCursor" "Off"
Option "NvAgp" "1"
Option "IgnoreEDID" "1"
Option "RenderAccel" "true"
#Option "NoRenderExtension" "true"

EndSection


glxgears works but is horribly slow; 4-5 fps in 1600x1200
but if i set

__GL_SYNC_TO_VBLANK=1
__GL_DEFAULT_LOG_ANISO=1
__GL_FSAA_MODE=0


i get at least 70-80 fps.

Is driver 6111 just not yet compatible with Xorg 6.8.1?
uyu is offline   Reply With Quote
Old 09-17-04, 10:26 AM   #2
Cartman
Registered User
 
Join Date: Jun 2004
Posts: 52
Default Re: Xorg 6.8.1 + 6111 problems, libnvidia-tls.so.1

Wait for next driver update.
Cartman is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with 173.14.35 and xorg 1.12 joedoe NVIDIA Linux 4 07-09-12 02:11 PM
173.14.34 -- Xorg 1.12.1 & 1.11.4, glx module fails to load mereset NVIDIA Linux 17 06-10-12 01:24 AM

All times are GMT -5. The time now is 03:40 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.