Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-18-04, 04:06 AM   #1
mrkaczor
Registered User
 
Join Date: Sep 2004
Posts: 23
Exclamation Mandrake 10, Geforce4mx440, 61.11 installed but strange GL problems ... PLIZ help!

I have Mandrake 10 community (kernel 2.6.3-4)
Geforce 4 mx 440
K7S5A (AC 97 sound)
Athlon XP2000+
256 DDR pc2-133

I had 61.06 drivers and Gl was working good, UT2004 had 60-70 fps, after i changed to 61.11 the strange problems occured:
- first i have problem with rivafb - i solved it (with add-this-kernell)
- than strange things started to happening, UT 9fps, glxgears:
"110 frames in 5.0 seconds = 22.000 FPS".
- whan i tried to back to 61.06 some errors showed, so now i am on 61.11 that dont work, every program that uses GL is a little bit laaaaaagish but is works with no errors ... i think that GL is emulated ...

I have even reinstall the system but that gives nothing ... ive installed 61.11 and they was working ( tuxracer goes great) but after couple of restarts the same problem.

Tha strangest thing is that 61.11 was working right after reinstalling the system and they stoped after sometime ... i dont wana to reinstall it another time ... its not windows :-P.

Now couple of logs:

-----------------------------------

XF86Config-4:
"
...
Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection
...
Section "Device"
Identifier "device1"
VendorName "nVidia Corporation"
BoardName "NVIDIA GeForce4 (generic)"
Driver "nvidia"
Option "DPMS"
Option "NvAGP" "3"
EndSection
...
"
my comment: Ive tried all NvAGP 0,1,2,3 ...

-----------------------------------

XFree86.0.log:
"
...
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.6111
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension GLX
(II) LoadModule: "nvidia"
(II) Loading /usr/X11R6/lib/modules/drivers/nvidia_drv.o
(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.6111
Module class: XFree86 Video Driver
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
Module class: XFree86 XInput Driver
ABI class: XFree86 XInput driver, version 0.4
(II) v4l driver for Video4Linux
(II) NVIDIA X Driver 1.0-6111 Tue Jul 27 07:56:22 PDT 2004
(II) NVIDIA Unified Driver for all NVIDIA GPUs
(II) Primary Device is: PCI 01:00:0
(--) Assigning device section with no busID to primary device
(--) Chipset NVIDIA GPU found
(II) resource ranges after xf86ClaimFixedResources() call:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
...
[16] -1 0 0x0000dc00 - 0x0000dcff (0x100) IX[b]
[17] -1 0 0x0000ff00 - 0x0000ff0f (0x10) IX[b]
(II) resource ranges after probing:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
...
[21] 0 0 0x000003b0 - 0x000003bb (0xc) IS[b]
[22] 0 0 0x000003c0 - 0x000003df (0x20) IS[b]
(II) Setting vga for screen 0.
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/X11R6/lib/modules/libvgahw.a
(II) Module vgahw: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.6
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NvAGP" "3"
(--) NVIDIA(0): Linear framebuffer at 0xC8000000
(--) NVIDIA(0): MMIO registers at 0xCE000000
(II) NVIDIA(0): NVIDIA GPU detected as: GeForce4 MX 440 with AGP8X
(--) NVIDIA(0): VideoBIOS: 04.18.20.13.00
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(II) NVIDIA(0): Detected AGP rate: 4X
(--) NVIDIA(0): VideoRAM: 65536 kBytes
(II) NVIDIA(0): Connected display device(s): CRT-0, TV-0
(WW) NVIDIA(0): Multiple displays connected, but only one display allowed;
(WW) NVIDIA(0): using first display
(--) NVIDIA(0): Display device CRT-0: maximum pixel clock at 8 bpp: 350 MHz
(--) NVIDIA(0): Display device CRT-0: maximum pixel clock at 16 bpp: 350 MHz
(--) NVIDIA(0): Display device CRT-0: maximum pixel clock at 32 bpp: 350 MHz
(II) Loading sub module "ddc"
(II) LoadModule: "ddc"
(II) Loading /usr/X11R6/lib/modules/libddc.a
(II) Module ddc: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.6
(II) Loading sub module "int10"
(II) LoadModule: "int10"
(II) Loading /usr/X11R6/lib/modules/linux/libint10.a
(II) Module int10: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.6
(II) NVIDIA(0): Primary V_BIOS segment is: 0xc000
(II) NVIDIA(0): monitor1: Using hsync range of 30.00-70.00 kHz
(II) NVIDIA(0): monitor1: Using vrefresh range of 50.00-160.00 Hz
(II) NVIDIA(0): Clock range: 12.00 to 350.00 MHz
(II) NVIDIA(0): Not using default mode "1152x864" (width too large for virtual size)
(II) NVIDIA(0): Not using default mode "1280x960" (width too large for virtual size)
(II) NVIDIA(0): Not using default mode "1280x960" (width too large for virtual size)
..............
(WW) NVIDIA(0): Not using mode "700x525" (height 1050 is larger than
(WW) NVIDIA(0): EDID-specified maximum 1024)
(WW) NVIDIA(0): Not using mode "768x576":
(WW) NVIDIA(0): horizontal sync width (846 - 832 = 14) not a multiple of 8
(WW) NVIDIA(0): Not using mode "576x384":
(WW) NVIDIA(0): horizontal sync start (589) not a multiple of 8
(WW) NVIDIA(0): Not using mode "360x200":
(WW) NVIDIA(0): horizontal sync start (378) not a multiple of 8
(**) NVIDIA(0): Validated modes for display device CRT-0:
(**) NVIDIA(0): Default mode "1024x768": 94.5 MHz, 68.7 kHz, 85.0 Hz
(**) NVIDIA(0): Default mode "1024x768": 78.8 MHz, 60.1 kHz, 75.1 Hz
(**) NVIDIA(0): Default mode "1024x768": 75.0 MHz, 56.5 kHz, 70.1 Hz
(**) NVIDIA(0): Default mode "1024x768": 65.0 MHz, 48.4 kHz, 60.0 Hz
(**) NVIDIA(0): Default mode "1024x768": 44.9 MHz, 35.5 kHz, 87.0 Hz (I)
(**) NVIDIA(0): Default mode "832x624": 57.3 MHz, 49.7 kHz, 74.6 Hz
(**) NVIDIA(0): Mode "1024x480": 65.0 MHz, 48.4 kHz, 85.9 Hz
(**) NVIDIA(0): Default mode "800x600": 56.3 MHz, 53.7 kHz, 85.1 Hz
(**) NVIDIA(0): Default mode "800x600": 49.5 MHz, 46.9 kHz, 75.0 Hz
(**) NVIDIA(0): Default mode "800x600": 50.0 MHz, 48.1 kHz, 72.2 Hz
(**) NVIDIA(0): Default mode "800x600": 40.0 MHz, 37.9 kHz, 60.3 Hz
(**) NVIDIA(0): Default mode "800x600": 36.0 MHz, 35.2 kHz, 56.2 Hz
(**) NVIDIA(0): Mode "768x576": 63.1 MHz, 61.6 kHz, 100.0 Hz
(**) NVIDIA(0): Default mode "640x512": 54.0 MHz, 64.0 kHz, 60.0 Hz (D)
(**) NVIDIA(0): Default mode "640x480": 36.0 MHz, 43.3 kHz, 85.0 Hz
....
(**) NVIDIA(0): Default mode "320x175": 15.8 MHz, 37.9 kHz, 85.3 Hz (D)
(--) NVIDIA(0): Display dimensions: (280, 210) mm
(--) NVIDIA(0): DPI set to (92, 92)
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/X11R6/lib/modules/libfb.a
(II) Module fb: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 ANSI C Emulation, version 0.2
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Loading /usr/X11R6/lib/modules/libramdac.a
(II) Module ramdac: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.6
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC? No, I don't.
(II) resource ranges after preInit:
[0] 0 0 0xc8000000 - 0xcbffffff (0x4000000) MX[b]
[1] 0 0 0xce000000 - 0xceffffff (0x1000000) MX[b]
[2] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[3] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[4] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[5] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[6] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[7] -1 0 0xcfffdf00 - 0xcfffdfff (0x100) MX[b]
[8] -1 0 0xcffff000 - 0xcfffffff (0x1000) MX[b]
[9] -1 0 0xcfffe000 - 0xcfffefff (0x1000) MX[b]
[10] -1 0 0xd0000000 - 0xcfffffff (0x0) MX[b]O
[11] -1 0 0xcfee0000 - 0xcfefffff (0x20000) MX[b](B)
[12] -1 0 0xc8000000 - 0xcbffffff (0x4000000) MX[b](B)
[13] -1 0 0xce000000 - 0xceffffff (0x1000000) MX[b](B)
[14] 0 0 0x000a0000 - 0x000affff (0x10000) MS[b](OprD)
[15] 0 0 0x000b0000 - 0x000b7fff (0x8000) MS[b](OprD)
[16] 0 0 0x000b8000 - 0x000bffff (0x8000) MS[b](OprD)
[17] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[18] -1 0 0x00000000 - 0x000000ff (0x100) IX[b]
[19] -1 0 0x0000d400 - 0x0000d4ff (0x100) IX[b]
[20] -1 0 0x0000d800 - 0x0000d83f (0x40) IX[b]
[21] -1 0 0x0000dc00 - 0x0000dcff (0x100) IX[b]
[22] -1 0 0x0000ff00 - 0x0000ff0f (0x10) IX[b]
[23] 0 0 0x000003b0 - 0x000003bb (0xc) IS[b](OprU)
[24] 0 0 0x000003c0 - 0x000003df (0x20) IS[b](OprU)
(II) NVIDIA(0): Setting mode "1024x768"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(**) Option "dpms"
(**) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(==) RandR enabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension LBX
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing extension GLX
(II) Keyboard "Keyboard1" handled by legacy driver
(**) Option "Protocol" "ExplorerPS/2"
(**) Mouse1: Protocol: "ExplorerPS/2"
(**) Option "CorePointer"
(**) Mouse1: Core Pointer
(**) Option "Device" "/dev/mouse"
(**) Mouse1: Emulate3Buttons, Emulate3Timeout: 50
(**) Option "ZAxisMapping" "6 7"
(**) Mouse1: ZAxisMapping: buttons 6 and 7
(**) Mouse1: Buttons: 7
(II) XINPUT: Adding extended input device "Mouse1" (type: MOUSE)
(II) XINPUT: Adding extended input device "NVIDIA Event Handler" (type: Other)
(II) Mouse1: ps2EnableDataReporting: succeeded
SetClientVersion: 0 7
GetModeLine - scrn: 0 clock: 94500
GetModeLine - hdsp: 1024 hbeg: 1072 hend: 1168 httl: 1376
vdsp: 768 vbeg: 769 vend: 772 vttl: 808 flags: 5
GetModeLine - scrn: 0 clock: 94500
GetModeLine - hdsp: 1024 hbeg: 1072 hend: 1168 httl: 1376
vdsp: 768 vbeg: 769 vend: 772 vttl: 808 flags: 5
GetModeLine - scrn: 0 clock: 94500
GetModeLine - hdsp: 1024 hbeg: 1072 hend: 1168 httl: 1376
vdsp: 768 vbeg: 769 vend: 772 vttl: 808 flags: 5
SwitchToMode - scrn: 0 clock: 36000
hdsp: 640 hbeg: 696 hend: 752 httl: 832
vdsp: 480 vbeg: 481 vend: 484 vttl: 509 flags: 10
Checking against clock: 94500 (94500)
hdsp: 1024 hbeg: 1072 hend: 1168 httl: 1376
vdsp: 768 vbeg: 769 vend: 772 vttl: 808 flags: 5
...
Checking against clock: 36000 (36000)
hdsp: 640 hbeg: 696 hend: 752 httl: 832
vdsp: 480 vbeg: 481 vend: 484 vttl: 509 flags: 10
(II) NVIDIA(0): Setting mode "640x480"
SwitchToMode - Succeeded
GetModeLine - scrn: 0 clock: 36000
GetModeLine - hdsp: 640 hbeg: 696 hend: 752 httl: 832
vdsp: 480 vbeg: 481 vend: 484 vttl: 509 flags: 10
GetModeLine - scrn: 0 clock: 36000
GetModeLine - hdsp: 640 hbeg: 696 hend: 752 httl: 832
vdsp: 480 vbeg: 481 vend: 484 vttl: 509 flags: 10
SwitchToMode - scrn: 0 clock: 94500
hdsp: 1024 hbeg: 1072 hend: 1168 httl: 1376
vdsp: 768 vbeg: 769 vend: 772 vttl: 808 flags: 5
Checking against clock: 94500 (94500)
hdsp: 1024 hbeg: 1072 hend: 1168 httl: 1376
vdsp: 768 vbeg: 769 vend: 772 vttl: 808 flags: 5
(II) NVIDIA(0): Setting mode "1024x768"
SwitchToMode - Succeeded
"

I know its long ... but i have linux only for couple of mounths and I am still a n00b ... and i didnt know what is important here ...

-----------------------------------------

ldd glxgears:
"
linux-gate.so.1 => (0xffffe000)
libGL.so.1 => /usr/lib/libGL.so.1 (0x40027000)
libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x4008f000)
libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x4009e000)
libpthread.so.0 => /lib/tls/libpthread.so.0 (0x40180000)
libm.so.6 => /lib/tls/libm.so.6 (0x40190000)
libc.so.6 => /lib/tls/libc.so.6 (0x401b3000)
libGLcore.so.1 => /usr/lib/libGLcore.so.1 (0x402fb000)
libnvidia-tls.so.1 => /usr/lib/tls/libnvidia-tls.so.1 (0x409d3000)
libdl.so.2 => /lib/libdl.so.2 (0x409d6000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
"

they all loks like Nvidia ones ... i chceck all of them and they have date of installing kernel module .. .todays date (18/09/2004).

i had SDL and GLX errors (no GL using app started, all gived errors) earlier but they dissapeared after reinstalling the system and installing 61.11 ...

help people ... if U can point me to some tread on this or other forums plese do ... I am looking for the sollution for a week now ... on this forum especialy ... and noone had the same problem , similar problems was solved buy when i tried that solutions they didnt work for me ... PLIZ help man!

if U need some more informations write what kind of ... and how to get them and I will post them here

Last edited by mrkaczor; 09-18-04 at 04:56 AM.
mrkaczor is offline   Reply With Quote
Old 09-18-04, 07:45 AM   #2
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: Mandrake 10, Geforce4mx440, 61.11 installed but strange GL problems ... PLIZ help!

Hi,

please post your log, when the error happens again. What you have posted looks nice and ok, but how does it look, when you have stuttering gl and glx errors?
What does dmesg tell you about agp? What says /proc/driver/nvidia/status?
energyman76b is offline   Reply With Quote
Old 09-18-04, 08:14 AM   #3
mrkaczor
Registered User
 
Join Date: Sep 2004
Posts: 23
Default Re: Mandrake 10, Geforce4mx440, 61.11 installed but strange GL problems ... PLIZ help

i have played with ld for couple of minutes Ive putted line:
/usr/lib
then i get couple of errors so i removed it and now any application using GL dont wana start, tuxracer said:
"Xlib: extension "XiG-SUNDRY-NONSTANDARD" missing on display ":0.0"."
glxgears starts but 40 fps ...
and status:
"
cat /proc/driver/nvidia/agp/status
Status: Enabled
Driver: AGPGART
AGP Rate: 4x
Fast Writes: Disabled
SBA: Disabled
"

and cat /proc/driver/nvidia/cards/0
"
Model: GeForce4 MX 440 with AGP8X
IRQ: 5
Video BIOS: 04.18.20.13.00
Card Type: AGP
"

Ive reinstalled a driver and the same ...

xdpyinfo:
"
name of display: :0.0
version number: 11.0
vendor string: Mandrake Linux (XFree86 4.3, patch level 29mdk)
vendor release number: 40300001
XFree86 version: 4.3.0.1
maximum request size: 4194300 bytes
motion buffer size: 256
bitmap unit, bit order, padding: 32, LSBFirst, 32
image byte order: LSBFirst
number of supported pixmap formats: 7
supported pixmap formats:
depth 1, bits_per_pixel 1, scanline_pad 32
depth 4, bits_per_pixel 8, scanline_pad 32
depth 8, bits_per_pixel 8, scanline_pad 32
depth 15, bits_per_pixel 16, scanline_pad 32
depth 16, bits_per_pixel 16, scanline_pad 32
depth 24, bits_per_pixel 32, scanline_pad 32
depth 32, bits_per_pixel 32, scanline_pad 32
keycode range: minimum 8, maximum 255
focus: window 0x2600005, revert to PointerRoot
number of extensions: 30
BIG-REQUESTS
DOUBLE-BUFFER
DPMS
Extended-Visual-Information
FontCache
GLX
LBX
MIT-SCREEN-SAVER
MIT-SHM
MIT-SUNDRY-NONSTANDARD
NV-CONTROL
NV-GLX
RANDR
RENDER
SECURITY
SHAPE
SYNC
TOG-CUP
X-Resource
XC-APPGROUP
XC-MISC
XFree86-Bigfont
XFree86-DGA
XFree86-Misc
XFree86-VidModeExtension
XInputExtension
XKEYBOARD
XTEST
XVideo
XVideo-MotionCompensation
default screen number: 0
number of screens: 1
"

what more logs U want?

Last edited by mrkaczor; 09-18-04 at 08:50 AM.
mrkaczor is offline   Reply With Quote
Old 09-18-04, 08:57 AM   #4
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: Mandrake 10, Geforce4mx440, 61.11 installed but strange GL problems ... PLIZ help!

first,
"Xlib: extension "XiG-SUNDRY-NONSTANDARD" missing on display ":0.0"."

can safely be ignored, that is only important for XiG users.

second, please make a 'glxinfo' when your performance is ok, and one when not, or only one, when your system is always slow.
energyman76b is offline   Reply With Quote
Old 09-18-04, 11:38 AM   #5
mrkaczor
Registered User
 
Join Date: Sep 2004
Posts: 23
Default Re: Mandrake 10, Geforce4mx440, 61.11 installed but strange GL problems ... PLIZ help

name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.3
server glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig,
GLX_SGIX_pbuffer, GLX_SGI_video_sync, GLX_SGI_swap_control
client glx vendor string: NVIDIA Corporation
client glx version string: 1.3
client glx extensions:
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_visual_info,
GLX_EXT_visual_rating, GLX_EXT_import_context, GLX_SGI_video_sync,
GLX_NV_swap_group, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
GLX_SGI_swap_control, GLX_NV_float_buffer
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig,
GLX_SGIX_pbuffer, GLX_SGI_video_sync, GLX_SGI_swap_control,
GLX_ARB_get_proc_address
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce4 MX 440 with AGP8X/AGP/SSE/3DNOW!
OpenGL version string: 1.5.1 NVIDIA 61.11
OpenGL extensions:
GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_point_parameters,
GL_ARB_point_sprite, GL_ARB_shader_objects, GL_ARB_shading_language_100,
GL_ARB_texture_compression, GL_ARB_texture_cube_map,
GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
GL_ARB_texture_env_dot3, GL_ARB_texture_mirrored_repeat,
GL_ARB_transpose_matrix, GL_ARB_vertex_buffer_object,
GL_ARB_vertex_program, GL_ARB_vertex_shader, GL_ARB_window_pos,
GL_S3_s3tc, GL_EXT_texture_env_add, GL_EXT_abgr, GL_EXT_bgra,
GL_EXT_blend_color, GL_EXT_blend_minmax, GL_EXT_blend_subtract,
GL_EXT_clip_volume_hint, GL_EXT_compiled_vertex_array,
GL_EXT_draw_range_elements, GL_EXT_fog_coord, GL_EXT_multi_draw_arrays,
GL_EXT_packed_pixels, GL_EXT_paletted_texture, GL_EXT_pixel_buffer_object,
GL_EXT_point_parameters, GL_EXT_rescale_normal, GL_EXT_secondary_color,
GL_EXT_separate_specular_color, GL_EXT_shared_texture_palette,
GL_EXT_stencil_wrap, GL_EXT_texture_compression_s3tc,
GL_EXT_texture_cube_map, GL_EXT_texture_edge_clamp,
GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
GL_EXT_texture_filter_anisotropic, GL_EXT_texture_lod,
GL_EXT_texture_lod_bias, GL_EXT_texture_object, GL_EXT_vertex_array,
GL_IBM_rasterpos_clip, GL_IBM_texture_mirrored_repeat,
GL_KTX_buffer_region, GL_NV_blend_square, GL_NV_fence,
GL_NV_fog_distance, GL_NV_light_max_exponent, GL_NV_packed_depth_stencil,
GL_NV_pixel_data_range, GL_NV_point_sprite, GL_NV_register_combiners,
GL_NV_texgen_reflection, GL_NV_texture_env_combine4,
GL_NV_texture_rectangle, GL_NV_vertex_array_range,
GL_NV_vertex_array_range2, GL_NV_vertex_program, GL_NV_vertex_program1_1,
GL_SGIS_generate_mipmap, GL_SGIS_multitexture, GL_SGIS_texture_lod,
GL_SUN_slice_accum
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x21 24 tc 0 32 0 r y . 8 8 8 0 0 24 8 16 16 16 16 0 0 None
0x22 24 dc 0 32 0 r y . 8 8 8 0 0 24 8 16 16 16 16 0 0 None
0x23 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 0 0 None
0x24 24 tc 0 32 0 r . . 8 8 8 0 0 24 8 16 16 16 16 0 0 None
0x25 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 0 0 None
0x26 24 tc 0 32 0 r y . 8 8 8 0 0 16 0 16 16 16 16 0 0 None
0x27 24 tc 0 32 0 r y . 8 8 8 8 0 16 0 16 16 16 16 0 0 None
0x28 24 tc 0 32 0 r . . 8 8 8 0 0 16 0 16 16 16 16 0 0 None
0x29 24 tc 0 32 0 r . . 8 8 8 8 0 16 0 16 16 16 16 0 0 None
0x2a 24 tc 0 32 0 r y . 8 8 8 0 0 0 0 16 16 16 16 0 0 None
0x2b 24 tc 0 32 0 r y . 8 8 8 8 0 0 0 16 16 16 16 0 0 None
0x2c 24 tc 0 32 0 r . . 8 8 8 0 0 0 0 16 16 16 16 0 0 None
0x2d 24 tc 0 32 0 r . . 8 8 8 8 0 0 0 16 16 16 16 0 0 None
0x2e 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 0 0 None
0x2f 24 dc 0 32 0 r . . 8 8 8 0 0 24 8 16 16 16 16 0 0 None
0x30 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 0 0 None
0x31 24 dc 0 32 0 r y . 8 8 8 0 0 16 0 16 16 16 16 0 0 None
0x32 24 dc 0 32 0 r y . 8 8 8 8 0 16 0 16 16 16 16 0 0 None
0x33 24 dc 0 32 0 r . . 8 8 8 0 0 16 0 16 16 16 16 0 0 None
0x34 24 dc 0 32 0 r . . 8 8 8 8 0 16 0 16 16 16 16 0 0 None
0x35 24 dc 0 32 0 r y . 8 8 8 0 0 0 0 16 16 16 16 0 0 None
0x36 24 dc 0 32 0 r y . 8 8 8 8 0 0 0 16 16 16 16 0 0 None
0x37 24 dc 0 32 0 r . . 8 8 8 0 0 0 0 16 16 16 16 0 0 None
0x38 24 dc 0 32 0 r . . 8 8 8 8 0 0 0 16 16 16 16 0 0 None

this is glxinfo when system is ok .. .ut2004 80fps .. glxgears 667fps ... tuxracer works fine ... so whats wrong? ...

i just reinstall the system to make good glxinfo ;-) i dont have bad glxinfo but it looks the same to me no errors at all ... but i know it will crash after couple of times ...
mrkaczor is offline   Reply With Quote
Old 09-18-04, 11:54 AM   #6
mrkaczor
Registered User
 
Join Date: Sep 2004
Posts: 23
Default Re: Mandrake 10, Geforce4mx440, 61.11 installed but strange GL problems ... PLIZ help

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!THE MOST MEGA ROTFLOL OCURRED!!!!!!!!!!!!!!!!!!!!!!!!!!!!

my problem is seti :-)

if seti is running all is luggish ... thats why GL works but jummpy ... nothing is wrong with libs, paths or kernell !!!!!!!!!

just stupid SETI and stupid USER !!!!!

hehehehehehe ;-)

i was looking for some errors for abourt 3 weeks and now i find that it was seti !!!
wehen its not working all works fine glxgears 8.8 fps
when not working glxgears 622 fps ...


MEGA LOL !!!!!!!!

do u know how to make seti to use only unused resources?

thx for care ..... and remember allways look for the easiest solutions :-)
mrkaczor is offline   Reply With Quote
Old 09-18-04, 03:15 PM   #7
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: Mandrake 10, Geforce4mx440, 61.11 installed but strange GL problems ... PLIZ help!

Hi,

with kernel 2.4 you can renice seti to +19 or so and it will not suck much performance anymore.

With 2.6 nice is not really working. Overeager processes, that try to hog cpu-cycles are punished, while others get cpu-time boni.
When you nice/renice a process, everything can happen ;o)
energyman76b is offline   Reply With Quote
Old 09-18-04, 03:27 PM   #8
bms20
Registered User
 
Join Date: Mar 2003
Posts: 46
Default Re: Mandrake 10, Geforce4mx440, 61.11 installed but strange GL problems ... PLIZ help!

Check your setup carefully! I found that Mandrake 10 left the X11 software opengl driver in the directory /usr/X11R6/lib - This caused major havoc. I had texture mapping problems all over the place with Doomsday (which I compiled).

I would recommend removing any libGL.so files under /usr/X11R6/lib and /usr/X11R6/lib/tls - once I did this I had the performance I expected again.

Be sure to back the files up before messing around though!
bms20 is offline   Reply With Quote

Old 09-19-04, 02:08 AM   #9
mrkaczor
Registered User
 
Join Date: Sep 2004
Posts: 23
Default Re: Mandrake 10, Geforce4mx440, 61.11 installed but strange GL problems ... PLIZ help!

reniceing didnt give results ... hmmm strange ...

the only thing that lower my preformance is runned seti, when i kill it preformance is as good as never before ... becouse of 61.11 :-)
mrkaczor is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandrake 8.2 Nvidia src.rpm problems Mr_Malcontent NVIDIA Linux 8 09-11-02 09:53 PM
Problems with Mandrake and NVidia drivers..... xMonoxide187x NVIDIA Linux 2 08-22-02 01:55 PM

All times are GMT -5. The time now is 01:25 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.