Go Back   nV News Forums > Linux Support Forums > General Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-07-02, 04:55 AM   #1
SadMac
Registered User
 
Join Date: Nov 2002
Location: Upper Ramsbottom, England
Posts: 3
Send a message via ICQ to SadMac
Default New(ish) nforce version 0246 driver building fails on debian woody

I'm trying to build the latest nforce drivers (0246) on a debian woody box with an MSI K7N-420D.

I'm using GCC '2.95.4'.

The following messages are produced when compiling:

Code:
yellowbox:/usr/src/nforce# make
make -C  nvnet
make[1]: Entering directory `/usr/src/nforce/nvnet'
cc -c -DLINUX -DMODULE -DEXPORT_SYMTAB -D__KERNEL__ -O -Wstrict-prototypes -DCONFIG_PM  -fno-strict-aliasing -mpreferred-stack-boundary=2 -march=i686 -falign-functions=4 -DMODULE -I/lib/modules/2.4.19/build/include   -DMODVERSIONS -include /lib/modules/2.4.19/build/include/linux/modversions.h nvnet.c
cc1: Invalid option `-falign-functions=4'
make[1]: *** [nvnet.o] Error 1
make[1]: Leaving directory `/usr/src/nforce/nvnet'
make: *** [nvnet_make] Error 2
Now this error makes me think there's either something wrong with my GCC or that the Makefile is wrong. Has anyone else had this problem and fixed it, or anyone know what to do about it?
SadMac is offline   Reply With Quote
Old 11-07-02, 05:02 AM   #2
SadMac
Registered User
 
Join Date: Nov 2002
Location: Upper Ramsbottom, England
Posts: 3
Send a message via ICQ to SadMac
Default

Hmm. Solved my own problem by looking at the old version of the driver source. For some reason NVidia has used -falign instead of -malign. So I just changed one to the other. I think someone better change this on the download.
SadMac is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 01:44 PM
GForce drivers installed...but dont work tomfullery NVIDIA Linux 6 09-22-02 08:23 AM
Need help to get the X to work on my Acer TravelMate 630 knchee NVIDIA Linux 16 09-19-02 10:16 PM
RH7.3 and nForce - can't find the module dmw400 NVIDIA Linux 4 08-05-02 12:14 PM

All times are GMT -5. The time now is 08:45 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.