Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-07-02, 01:37 PM   #1
justinr3
Guest
 
Posts: n/a
Default RH 8 & Twinview window spanning!!

I have successfully set up the nvidia drivers on my RedHat 8 installation and both my monitors are working "correctly." My problem is that many dialogue boxes and such pop up in the dead center of both screens (spanning across both). This isnt really a problem, but just really annoying. I looked in the README file that came with the nvidia drivers and it said in the F.A.Q's that the driver supports 'xinerama' and window spanning should not be a problem. ???

If you have any info on fixing this, please let me know!

B.T.W. I am using a Gainward Ti4200 (dual head) and my XF86Config is posted below

--------------------------

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"

# Option "AutoRepeat" "500 5"

# when using XQUEUE, comment out the above line, and uncomment the
# following line
# Option "Protocol" "Xqueue"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
#Option "XkbVariant" ""
#Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

#


Section "Monitor"
Identifier "Monitor0"
VendorName "Sony"
ModelName "HMD-400"
HorizSync 30-86
VertRefresh 48-120
Option "dpms"


EndSection

Section "Device"
# no known options
Identifier "NVIDIA GeForce 4 (generic)"
Driver "nvidia"
VendorName "NVIDIA GeForce 4 (generic)"
BoardName "NVIDIA GeForce 4 (generic)"

#BusID
EndSection

Section "Screen"
Identifier "Screen0"
Device "NVIDIA GeForce 4 (generic)"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView"
Option "SecondMonitorHorizSync" "30-86"
Option "SecondMonitorVertRefresh" "48-120"
Option "MetaModes" "1280x1024,1280x1024"
Option "TwinViewOrientation" "LeftOf"
Option "ConnectedMonitor" "crt,crt"
Option "NoLogo"

Subsection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubsection

EndSection

Section "DRI"
Mode 0666
EndSection
  Reply With Quote
Old 11-08-02, 03:05 PM   #2
justinr3
Guest
 
Posts: n/a
Default

bumpage
  Reply With Quote
Old 11-08-02, 07:12 PM   #3
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Somewhere in your file (probably in the Screen section), you can add *something* like Option "Xinerama" "on" to enable Xinerama. Check the nVidia README under the "driver options" section for details on where to put it and what it's called.

This won't work, though, unless your window manager supports Xinerama. Qt (and therefore KDE) can, if you enable it when you compile Qt, but there are warnings that it causes problems with RedHat 6.2, so I don't know whether the version of Qt you have installed has Xinerama support. Of course, that only matters if you use KDE, but I don't know about other window managers or desktop environments, so... yeah.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 11-22-02, 02:17 AM   #4
topaz99
Guest
 
Posts: n/a
Default Xinerama Support For Driver Not Xserver

To fix the problem with windows popping up in the gutter, make sure you have xinerama enabled for the nvidia driver, it should be enabled by default.
Section "Screen"
Option "NoTwinViewXineramaInfo" false
EnSection

But the Xinerama option for the xserver should be disabled. Either comment out what you have or make it false.
Section "ServerFlags"
Option "Xinerama" false
EndSection

If you did this and you still have problems, check /var/log/XFree86.0.log and check for yourself.

And if that doesn't help, it's possible your window manager just doesn't handle xinerama info. In which case deal with it until they implement it, or get a new one.
  Reply With Quote
Old 11-25-02, 04:11 PM   #5
chuckberg
Registered User
 
Join Date: Nov 2002
Posts: 1
Default

I have the same problem, with the 3123 drivers on a quad card("Quadro4 200/400NVS", which the system thinks is two dual cards), on Redhat 8. I am trying to use three monitors, in xinerama mode. The first two (sharing a TwinView) act like one screen, with no xinerama boundary between them, and the third one acts separate. I'm pretty sure the problem is not my window manager, because xdpyinfo -ext XINERAMA reports two heads, one 2560x1024, and one 1280x1024.

If I disable Xinerama in the ServerFlags section, I am given two screens, :0.0 is 2560x1024 on the first two monitors, :0.1 is 1280x1024 on the third monitor.

From the documentation, it appears to be behaving as if NoTwinViewXinerama is set, however it is not. Whether I explicitly set this to true or false has no effect.
chuckberg is offline   Reply With Quote
Old 02-18-03, 01:42 AM   #6
drag
Registered User
 
Join Date: Feb 2003
Posts: 2
Default

I don't think its a problem with your x windows setup, it's a problem with your window manager. Even with 2 monitors it is still just one desktop. Change the defualts of your wm so that new windows are spawned in the up right hand or left hand or randomly, just something other than dead center of the desktop
drag is offline   Reply With Quote
Old 02-18-03, 02:48 PM   #7
qjm
Registered User
 
Join Date: Dec 2002
Posts: 4
Default

Well I do not have problems with window spanning.

using RH8.0 without disabling xinerama stuff in /etc/X11/XF86Config. IE:
Option "NoTwinViewXineramaInfo" "true"
which is the default.

I use KDE + KDM -- I just told it to query Xinerama in the KDE configuration [default is NOT to query this]-- now the login box and KDE-login stuff happen in the center of one of the screens, not spanning.

HTH,
Q.
qjm is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Twinview? ghorsepower NVIDIA Linux 2 10-11-02 12:46 PM
XF86Config for a Quadro4 without TwinView? Twirlip NVIDIA Linux 1 10-09-02 10:36 AM
Suse Linux 8.0 - Geforce 4 TwinView TA00 NVIDIA Linux 8 08-30-02 03:24 AM
Twinview with TV-out karlaugust NVIDIA Linux 10 08-28-02 04:20 PM
How do I configure TwinView on Dell Inspiron rutgerclaes NVIDIA Linux 6 08-01-02 03:20 AM

All times are GMT -5. The time now is 04:01 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.