Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-28-04, 09:29 PM   #1
lpsi2000
Registered User
 
Join Date: Sep 2004
Posts: 3
Default Dual Monitor with xorg, Nvidia won't work.

I have tried various changes from search on this forum and others for the past few weeks and nothing seems to work with my GeForce FX 5600 for the Dual Monitor configuration. With the current configuration, KDE starts an load on the Left Monitor and the right Monitor just shows flashing garbage with various colors. This machine was running fine under Windows XP, however I am trying to make the switch to Linux

I am running Gentoo Linux on a P4 3Ghz, 2GB RAM, 200GB HD
xorg 6.7.0, Nvidia-kernel 1.0.5336, KDE 3.3.0

Your help will be greatly appreciated

TIA:

Below is my xorg.conf and the attachement is the xorg.log

Section "Module"
Load "dbe" # Double buffer extension
SubSection "extmod"
Option "omit xfree86-dga" # don't initialise the DGA extension
EndSubSection

Load "type1"
Load "speedo"
Load "freetype"
Load "glx"
Load "dri"

EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "/usr/share/fonts/misc/"
FontPath "/usr/share/fonts/TTF/"
FontPath "/usr/share/fonts/Speedo/"
FontPath "/usr/share/fonts/Type1/"
FontPath "/usr/share/fonts/CID/"
FontPath "/usr/share/fonts/75dpi/"
FontPath "/usr/share/fonts/100dpi/"
FontPath "/usr/share/fonts/local/"
# FontPath "/usr/share/fonts/TrueType/"
# FontPath "/usr/share/fonts/freefont/"

EndSection

Section "ServerFlags"

EndSection

Section "InputDevice"

Identifier "Keyboard1"
Driver "Keyboard"

Option "AutoRepeat" "500 30"
Option "XkbRules" "xorg"
Option "XkbModel" "microsoft"
Option "XkbLayout" "us"

EndSection

Section "InputDevice"

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"

Option "Emulate3Buttons" "Yes"

EndSection

Section "Monitor"

Identifier "Planar0"
HorizSync 31.5 - 82.0
VertRefresh 50-100

EndSection

Section "Monitor"

Identifier "Planar1"
HorizSync 31.5 - 82.0
VertRefresh 50-100

EndSection

Section "Device"
Identifier "Standard VGA"
VendorName "Unknown"
BoardName "Unknown"
Driver "vga"
EndSection

Section "Device"
Identifier "Nvidia0"
Driver "nv"
BusID "PCI:1:0:0"
Option "NvAGP" "1"
EndSection

Section "Device"
Identifier "Nvidia1"
Driver "nv"
BusID "PCI:1:0:0"
Option "NvAGP" "1"
EndSection

Section "Screen"
Identifier "Screen 0"
Device "Nvidia0"
Monitor "Planar0"
DefaultDepth 16

Subsection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 16
Modes "1400x1050" "1600x1024" "1280x1024" "1024x768" "800x600" "640x480" "1152x864" "1024x768" "1024x768"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
EndSection

Section "Screen"
Identifier "Screen 1"
Device "Nvidia1"
Monitor "Planar1"
DefaultDepth 16

Subsection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 16
Modes "1400x1050" "1600x1024" "1280x1024" "1024x768" "800x600" "640x480" "1152x864" "1024x768" "1024x768"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
EndSection

Section "ServerLayout"
Identifier "Simple Layout"
Screen 0 "Screen 0" 0 0
Screen 1 "Screen 1" RightOf "Screen 0"
InputDevice "Mouse1" "CorePointer"
InputDevice "Keyboard1" "CoreKeyboard"

EndSection
Attached Files
File Type: txt Xorg.log.txt (38.7 KB, 163 views)

Last edited by lpsi2000; 09-29-04 at 07:08 AM.
lpsi2000 is offline   Reply With Quote
Old 09-29-04, 08:47 AM   #2
mctylr
Registered User
 
Join Date: Sep 2004
Location: Ontario, Canada
Posts: 14
Default Re: Dual Monitor with xorg, Nvidia won't work.

You are using 'nv', the open source nvidia driver, not maintained by Nvidia inc. I have never had any luck getting that to support dual (or multiple) displays.

I would suggest installing the NVIDIA binary drivers (typically you want these drivers <http://www.nvidia.com/object/linux_display_ia32_1.0-6111.html>). Then change your xorg config file to use 'nvidia' rather than 'nv' and that should work for you.
mctylr is offline   Reply With Quote
Old 09-29-04, 06:35 PM   #3
lpsi2000
Registered User
 
Join Date: Sep 2004
Posts: 3
Default Re: Dual Monitor with xorg, Nvidia won't work.

Thank you for replying, however when I use the "nvidia" instead of "nv", my system seems to freeze. I can not see what is happening because the monitors are blank (black) and I can not switch console, kill X (CRTL+ALT+BSpace), or do anything except for a hard reboot. I also try to ssh to machine from another machine but no luck no response.
lpsi2000 is offline   Reply With Quote
Old 09-29-04, 09:58 PM   #4
lpsi2000
Registered User
 
Join Date: Sep 2004
Posts: 3
Default Re: Dual Monitor with xorg, Nvidia won't work.

Okay, I got the latest driver and now I am able to get one monitor running using "nvidia" instead of the "nv" which I am using to the create this reply but the other one is blank.

I am going to try some of the stuff I was trying before but if anyone has any additional ideas, please let me know.

Attached is both my current xorg.conf and xorg.log
Attached Files
File Type: txt Xorg.log.txt (27.8 KB, 174 views)
File Type: txt xorg.txt (3.3 KB, 207 views)
lpsi2000 is offline   Reply With Quote
Old 10-04-04, 02:34 PM   #5
mctylr
Registered User
 
Join Date: Sep 2004
Location: Ontario, Canada
Posts: 14
Default Re: Dual Monitor with xorg, Nvidia won't work.

Section "Device"
Identifier "Nvidia0"
Driver "nvidia"
BusID "PCI:1:0:0"
Option "NvAGP" "1"
Screen 0
EndSection

Section "Device"
Identifier "Nvidia1"
Driver "nvidia"
BusID "PCI:1:0:0"
Option "NvAGP" "1"
Screen 1
EndSection

Not certain but you may need to change this as well:

Section "ServerLayout"
Identifier "Simple Layout"
Screen 0 "Screen 0" 0 0
Screen 1 "Screen 1" RightOf "Screen 0"
InputDevice "Mouse1" "CorePointer"
InputDevice "Keyboard1" "CoreKeyboard"
EndSection

I believe that should do it for you.
mctylr is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
GTX 460M, Xorg 1.12, nvidia driver 295.49, linux 3.3.5-1-ARCH and NVRM Xid 44 elsifaka NVIDIA Linux 0 05-14-12 08:48 AM
295.40 Drivers and Xorg 1:7.6+12 HIGH cpu usage norrland NVIDIA Linux 2 05-13-12 09:11 AM

All times are GMT -5. The time now is 03:44 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.