Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-01-04, 11:31 AM   #1
Greisby
Registered User
 
Join Date: Oct 2004
Posts: 1
Default Configure xfree / xorg for two X terminals

Hi!

I'm trying to configure my linux to have two users on my PC.
I found those links:
http://www.faqs.org/docs/Linux-HOWTO...ser-HOWTO.html
http://cambuca.ldhs.cetuc.puc-rio.br/multiuser/
http://www.itsopen.net/projects/x-hack/
http://disjunkt.com/dualhead/

I tried to have 2 layouts, 1 per display and enable them separately, but I was unable to start the one the the second display.

Did anyone succed in such a config?
I attached my xorg.conf & the Xorg.log

Any help is welcomed!
Attached Files
File Type: txt xorg.conf.txt (10.0 KB, 173 views)
File Type: txt Xorg.0.log.txt (25.7 KB, 149 views)
Greisby is offline   Reply With Quote
Old 10-01-04, 06:04 PM   #2
_tf_
scriptfoo warrior
 
_tf_'s Avatar
 
Join Date: Apr 2003
Location: here
Posts: 117
Default Re: Configure xfree / xorg for two X terminals

hi

here is my dualhead-config that worked ok.
maybe you have to change the busid and leave out
the wacom bits.


cheers
lars


Code:
# Xorg configuration

Section "ServerLayout"
	Identifier  "dual head configuration"
	Screen 0        "Screen0"
	Screen 1        "Screen1" rightOf "Screen0"
	InputDevice    "Mouse0"
	InputDevice    "Keyboard0"
	InputDevice    "cursor"
	InputDevice    "wacom"
	InputDevice    "eraser"
EndSection

Section "Files"
	RgbPath     "/usr/X11R6/lib/X11/rgb"
	FontPath     "unix/:7100"
EndSection

Section "Module"
	Load  "dbe"
	Load  "extmod"
	Load  "fbdevhw"
	Load  "glx"
	Load  "record"
	Load  "freetype"
	Load  "type1"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "keyboard"
	Option	    "CoreKeyboard"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "de"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "CorePointer"
	Option	    "Protocol" "IMPS/2"
	Option	    "Device" "/dev/input/mouse1"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
	Identifier  "cursor"
	Driver      "wacom"
	Option	    "SendCoreEvents"
	Option	    "Device" "/dev/input/event1"
	Option	    "Type" "cursor"
	Option	    "Mode" "relative"
	Option	    "Speed" "3.0"
	Option	    "USB" "on"
	Option	    "Threshold" "10"
EndSection

Section "InputDevice"
	Identifier  "wacom"
	Driver      "wacom"
	Option	    "SendCoreEvents"
	Option	    "Device" "/dev/input/event1"
	Option	    "Type" "stylus"
	Option	    "Mode" "absolute"
	Option	    "USB" "on"
	Option	    "Tilt" "on"
	Option	    "Threshold" "10"
EndSection

Section "InputDevice"
	Identifier  "eraser"
	Driver      "wacom"
	Option	    "SendCoreEvents"
	Option	    "Device" "/dev/input/event1"
	Option	    "Type" "eraser"
	Option	    "Mode" "absolute"
	Option	    "USB" "on"
	Option	    "Tilt" "on"
	Option	    "Threshold" "10"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Iiyama"
	ModelName    "Vision Master Pro 510"
	HorizSync    30.0 - 130.0
	VertRefresh  50.0 - 160.0
	Option	     "dpms"
EndSection

Section "Monitor"
	Identifier   "TV0"
	VendorName   "x"
	ModelName    "x TVset"
	HorizSync    30.0 - 50.0
	VertRefresh  60
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "nvidia"
	VendorName  "NVIDIA"
	BoardName   "NVIDIA GeForce4 Ti 4200"
	BusID	     "PCI:3:0:0"
	Screen	     0
	Option	    "NoLogo" "on"
	Option	    "CursorShadow" "on"
	Option	    "CursorShadowAlpha" "30"
	Option	    "RenderAccel" "on"
	#Option	    "NvEmulate" "30"
	#Option	    "TwinView"
	#Option	    "TwinViewOrientation" "clone"
	#Option	    "TVStandard" "PAL-B"
	#Option	    "TVOutFormat" "COMPOSITE"
	#Option	    "SecondMonitorHorizSync" "30-50"
	#Option	    "SecondMonitorVertRefresh" "60"
	#Option	    "MetaModes" "1600x1200,800x600; 1280x1024,800x600; 1024x768,800x600; 800x600,800x600; 640x480,640x480"
EndSection

Section "Device"
	Identifier  "Videocard1"
	Driver      "nvidia"
	VendorName  "NVIDIA"
	BoardName   "NVIDIA GeForce4 Ti 4200"
	BusID	      "PCI:3:0:0"
	Screen	     1
	Option	    "NoLogo" "on"
	Option	    "CursorShadow" "on"
	Option	    "CursorShadowAlpha" "30"
	Option	    "RenderAccel" "on"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor     "Monitor0"
	DefaultDepth      24
	SubSection "Display"
		Viewport  0 0
		Depth     24
		Modes    "1600x1200" "1400x1050" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "Screen"
	Identifier "Screen1"
	Device     "Videocard1"
	Monitor     "TV0"
	DefaultDepth      24
	SubSection "Display"
		Viewport  1 0
		Depth     24
		Modes    "800x600" "640x480"
	EndSubSection
EndSection
__________________
"My mortgage rate was cut in half after I replied to spam
using Fedora!" raves Bo Battipaglia.
_tf_ is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
173.14.34 -- Xorg 1.12.1 & 1.11.4, glx module fails to load mereset NVIDIA Linux 17 06-10-12 01:24 AM
295.40 Drivers and Xorg 1:7.6+12 HIGH cpu usage norrland NVIDIA Linux 2 05-13-12 09:11 AM

All times are GMT -5. The time now is 07:31 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.