Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-28-04, 01:02 PM   #1
Sir Dragon
Registered User
 
Join Date: Sep 2004
Posts: 3
Default Driver 1.0-6111 /Mandrake 10

Hi everyone,

I've have dowloaded the NVIDIA driver 1.0-6111 and install it as described in the README file. Everything seems to be fine as it could be checked in the /var/log/nvidia-insaller.log file. But when I start the X server with the init 5 command I got an ugly and big login manager, bigger than anything my screen can deal with. So after I ran into kde things went worst. Menu bar icon tips are displayed with a huge font, desktop icon are also big and so are the tips. So I had to modify the XF86Config-4 file to switch back the load "nvidia" line to load "nv". Things are better at this point but a few core with kde. But I cannot use nvidia driver without running into display problems. and I have to switch back to nv driver after rebooting.

I have a 2.6 GHz Intel motherboard and I run a Mandrake 10 Official.
kernel 2.6.3-7mdk
Graphic card is a leadtek A250 GeForce4 Ti 4200

$ cat /proc/driver/nvidia/cards/0
Model: GeForce4 Ti 4200
IRQ: 11
Video BIOS: ??.??.??.??.??
Card Type: AGP

I tried to run with load "nvidia", after init 3, the following command
$ startx -- -logverbose 5
and get after the usual introduction :
(==) Log file : "/var/log/XFree86.0.log", Time : ...
(==) Using config file: "/etc/X11/XF86Config-4"
Using vt 7
(II) Initializing extension GLX
waiting for X server to shutdown

But when running in X mode, with load "nvidia", I got an error with GLX !!
$ tail /var/log/mdkkdm.log
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Wed Sep 22 18:59:00 2004
(==) Using config file: "/etc/X11/XF86Config-4"
Using vt 7
(EE) Failed to initialize GLX extension (NVIDIA X driver not found)
Loading required GL library /usr/X11R6/lib/libGL.so.1.4.502
ASSERT: "!_name.isEmpty()" in kinstance.cpp (91)
Loading required GL library /usr/X11R6/lib/libGL.so.1.4.502
SetClientVersion: 0 7

and a few command I run
$ ldd `which glxgears`
linux-gate.so.1 => (0xffffe000)
libGL.so.1 => /usr/lib/libGL.so.1 (0x40019000)
libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x40093000)
libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x400a1000)
libpthread.so.0 => /lib/tls/libpthread.so.0 (0x40183000)
libm.so.6 => /lib/tls/libm.so.6 (0x40193000)
libc.so.6 => /lib/tls/libc.so.6 (0x401b6000)
libGLcore.so.1 => /usr/lib/libGLcore.so.1 (0x402fe000)
libnvidia-tls.so.1 => /usr/lib/tls/libnvidia-tls.so.1 (0x409d7000)
libdl.so.2 => /lib/libdl.so.2 (0x409d9000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

$ locate libGL
/usr/lib/libGL.so.1.0.6111
/usr/lib/libGLcore.so.1.0.6111
/usr/lib/libGL.la
/usr/lib/libGL.so.1
/usr/lib/libGL.so
/usr/lib/libGLcore.so.1
/usr/X11R6/lib/libGLU.so.1.3.502
/usr/X11R6/lib/libGLU.so.1
/usr/X11R6/lib/libGLw.a
/usr/X11R6/lib/libGLU.la
/usr/X11R6/lib/libGLU.so

What is wrong, I checked that every file listed in Appendice C of the installer README is where it must be and also checked the creation date to ensure that files came from the installer.

Can someone help me to get things going the way they must go ?

Thanks.
Attached Files
File Type: txt XFree86.0.log.txt (27.3 KB, 131 views)
File Type: zip mdkkdm.zip (5.1 KB, 139 views)
Sir Dragon is offline   Reply With Quote
Old 09-28-04, 02:16 PM   #2
skinny_p
Registered User
 
Join Date: Dec 2003
Location: France
Posts: 8
Default Re: Driver 1.0-6111 /Mandrake 10

hi
Try this, add
Option "IgnoreEDID" "1"
in Section "Device"
skinny_p is offline   Reply With Quote
Old 09-29-04, 01:51 PM   #3
Sir Dragon
Registered User
 
Join Date: Sep 2004
Posts: 3
Default Re: Driver 1.0-6111 /Mandrake 10

Wow ! At least it works ! Everything is okey for now, my desktop has returned to a normal behavior. How simple and efficient is that simple added line, even if I don't know what it means but I can see it is related to messages in the X log file. Got to learn more about X11 mystery.

Thanks a lot for your Help.
Sir Dragon is offline   Reply With Quote
Old 09-30-04, 05:31 AM   #4
crac
Registered User
 
Join Date: Sep 2004
Posts: 49
Default Re: Driver 1.0-6111 /Mandrake 10

this option turns the feature off, that monitors can send their prefered settings directly to the graphics card. with that option enabled, your settings can be overridden ...
crac is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nouveau X.Org Driver Finally Releases Version 1.0 News Archived News Items 0 06-18-12 06:30 PM
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 06:48 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-01-02 11:58 PM
GForce drivers installed...but dont work tomfullery NVIDIA Linux 6 09-22-02 08:23 AM

All times are GMT -5. The time now is 02:55 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.