Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-30-04, 03:51 PM   #1
bliff
Registered User
 
Join Date: Sep 2004
Posts: 4
Default Sig 11 on 61.11 drivers, 2.6.8+ kernel

Hi,

I've searched this board and tried almost every suggestion to get the accelerated nVidia drivers to work. At best it simply dies after startx with a sig11, no errors in the log or to stderr. The vanilla "nv" driver works fine, and the "nvidia" drivers works ok when I do "opengl-update xfree86" but obviously i end up with unaccellerated 3D.

I'm now using a hacked kernel 2.6.9-rc2-bk15, though I tried vanilla 2.6.8.1, and gentoo's modified 2.6.8 kernel. The system is clean, I just installed it 2 days ago from stage1. I'm using XFree86.

Here is my kernel config, XF86Config and X log file. I believe the card is PCI, so I have not toyed with AGPGART stuff. I'm reasonably sure that the problem must relate to the various library symbolic links, (and I have no /usr/lib/tls directory, tho I have no idea what that means anyway, just been reading posts).

If anyone has ideas, I'm at the end of my leash and about to suffer along with unaccelerated 3D. ( )
Attached Files
File Type: txt XF86Config.txt (14.5 KB, 129 views)
File Type: txt XFree86.0.log.txt (24.0 KB, 152 views)
File Type: txt config-2.6.9.current.txt (24.5 KB, 175 views)
bliff is offline   Reply With Quote
Old 09-30-04, 06:47 PM   #2
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Sig 11 on 61.11 drivers, 2.6.8+ kernel

Code:
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.5336
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension GLX
(II) LoadModule: "nvidia"
(II) Loading /usr/X11R6/lib/modules/drivers/nvidia_drv.o
(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.6111
Module class: XFree86 Video Driver
This looks like an installation problem, note that the two modules have different versions.
zander is offline   Reply With Quote
Old 10-01-04, 11:05 AM   #3
bliff
Registered User
 
Join Date: Sep 2004
Posts: 4
Default Re: Sig 11 on 61.11 drivers, 2.6.8+ kernel

Wow, didn't even see it. Turned out there was a bunch of old stuff that got installed there, (undoubtedly by either opengl-update or some old emerge). I deleted the nvidia directory under the X11R6 hierarchy, reran the nvidia installer and voila, accelerated 3D.

Thanks for the help!
bliff is offline   Reply With Quote
Old 10-01-04, 11:31 AM   #4
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: Sig 11 on 61.11 drivers, 2.6.8+ kernel

Hi,

bliff, you are...

NEVER USE THE INSTALLER WITH GENTOO

NEVER!
Your problem above happened, because you used the installer on gentoo. And you will hit a lot more over time, because there is more to remove then /usr/lib/opengl/nvidia.

Congratulations, you have almost borked you installation. Please, use only the ebuild, the next time you install gentoo. The latest drivers are always in the tree, most of the time with important patches.
But you are so smart, to force an alien installer to throw some files into the system.

You should run glxinfo, I bet there are more errors.

And next time, think twice. Thank you
energyman76b is offline   Reply With Quote
Old 10-01-04, 11:44 AM   #5
bliff
Registered User
 
Join Date: Sep 2004
Posts: 4
Default Re: Sig 11 on 61.11 drivers, 2.6.8+ kernel

glxinfo returns no errors, I scrubbed the X11 directory clean based on the XF86log output. I used the nvidia installer because the emerge'd drivers weren't working. I don't really like package utilities as a rule and tend to use them only for core system stuff anyway.

Rather than troll the boards why don't you ask one of the moderators to put this on a README or something. Berating people who don't know any better isn't helpful.
bliff is offline   Reply With Quote
Old 10-01-04, 11:59 AM   #6
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: Sig 11 on 61.11 drivers, 2.6.8+ kernel

and did you scrub the includes too?
and the modules?
energyman76b is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Random crashes, NVRM Xid messages Iesos NVIDIA Linux 90 10-04-12 03:27 AM
Corrupted display - 302.17 - Dell Precision T3500 (G98 [Quadro NVS 295]) gbailey NVIDIA Linux 1 06-27-12 10:24 AM
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 04:51 AM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
Crash when logout from X TGL NVIDIA Linux 10 09-13-02 08:22 PM

All times are GMT -5. The time now is 11:26 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.