Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-04-04, 07:42 AM   #1
GiP
Registered User
 
Join Date: Sep 2004
Posts: 3
Default Kernel BUG! (6111 + 2.6.8-1.521smp on FC2)

Hi,

I have ten similar machines running Fedora Core 2 with kernel 2.6.8-1.521smp (they are dual Xeon). Sometime I find one stuck and I can only switch it off and on to restart it. Possibly related is the problem that sometimes X stops and once it even rebooted the machine. What I found in the log is this:

Oct 4 13:47:27 tria kernel: kernel BUG at mm/page_alloc.c:792!
Oct 4 13:47:27 tria kernel: invalid operand: 0000 [#1]
Oct 4 13:47:27 tria kernel: SMP
Oct 4 13:47:27 tria kernel: Modules linked in: snd_pcm_oss snd_mixer_oss snd_in
tel8x0 snd_ac97_codec snd_pcm snd_timer snd_page_alloc gameport snd_mpu401_uart
snd_rawmidi snd_seq_device snd soundcore nvidia(U) nfs lockd parport_pc lp parpo
rt autofs4 sunrpc e1000 floppy sg scsi_mod microcode dm_mod uhci_hcd ehci_hcd bu
tton battery asus_acpi ac ext3 jbd
Oct 4 13:47:27 tria kernel: CPU: 2
Oct 4 13:47:27 tria kernel: EIP: 0060:[<02140502>] Tainted: P
Oct 4 13:47:27 tria kernel: EFLAGS: 00013256 (2.6.8-1.521smp)
Oct 4 13:47:27 tria kernel: EIP is at __free_pages+0x20/0x4c
Oct 4 13:47:27 tria kernel: eax: 00000000 ebx: 00000000 ecx: 0342bc00 edx
: 0342bc00
Oct 4 13:47:27 tria kernel: esi: 3fc6fcf0 edi: 00000010 ebp: 00000000 esp
: 3fc6fce8
Oct 4 13:47:27 tria kernel: ds: 007b es: 007b ss: 0068
Oct 4 13:47:27 tria kernel: Process X (pid: 2332, threadinfo=3fc6f000 task=374b
93f0)
Oct 4 13:47:27 tria kernel: Stack: 035d7198 0211a5a9 036489b8 03710b18 2a61aac0
00000010 2a61aac0 00000010
Oct 4 13:47:27 tria kernel: 022080c6 00000010 00000010 3fc6fd60 3fc6fed8
43238d1c 434f3e20 00000010
Oct 4 13:47:27 tria kernel: 3fc6fd60 410b2200 00000010 00000041 41716980
434f3e20 432375fe 3fc6fe80
Oct 4 13:47:27 tria kernel: Call Trace:
Oct 4 13:47:27 tria kernel: [<0211a5a9>] global_flush_tlb+0xe9/0xf3
Oct 4 13:47:27 tria kernel: [<022080c6>] agp_allocate_memory+0x8c/0x93
Oct 4 13:47:27 tria kernel: [<43238d1c>] KernAllocAGPPages+0x6c/0x167 [nvidia]
Oct 4 13:47:27 tria kernel: [<432375fe>] nv_alloc_pages+0xb9/0x310 [nvidia]
Oct 4 13:47:27 tria kernel: [<43096a5b>] _nv004819rm+0x4b/0x88 [nvidia]
Oct 4 13:47:27 tria kernel: [<43078882>] _nv001629rm+0x6e/0x78 [nvidia]
Oct 4 13:47:27 tria kernel: [<43078841>] _nv001629rm+0x2d/0x78 [nvidia]
Oct 4 13:47:27 tria kernel: [<4305b8d2>] _nv006380rm+0x16/0x3c [nvidia]
Oct 4 13:47:27 tria kernel: [<4306d1ca>] _nv001734rm+0x36/0xe0 [nvidia]
Oct 4 13:47:27 tria kernel: [<43062799>] _nv001226rm+0x121/0x138 [nvidia]
Oct 4 13:47:27 tria kernel: [<4305ba3e>] _nv006349rm+0xaa/0xd8 [nvidia]
Oct 4 13:47:27 tria kernel: [<4307fe9d>] _nv002132rm+0x31/0x48 [nvidia]
Oct 4 13:47:27 tria kernel: [<4306dbe6>] _nv001659rm+0x26/0x2c [nvidia]
Oct 4 13:47:27 tria kernel: [<4307872e>] _nv001633rm+0x12/0x18 [nvidia]
Oct 4 13:47:27 tria kernel: [<4305f0fa>] _nv003453rm+0x86/0xd8 [nvidia]
Oct 4 13:47:27 tria kernel: [<4307e1c5>] rm_change_res_mode+0x69/0x8c [nvidia]
Oct 4 13:47:27 tria kernel: [<4307eefb>] _nv001139rm+0x16b/0x4b8 [nvidia]
Oct 4 13:47:27 tria kernel: [<02158793>] rw_vm+0x2df/0x331
Oct 4 13:47:27 tria kernel: [<4307e147>] rm_ioctl+0x23/0x38 [nvidia]
Oct 4 13:47:27 tria kernel: [<43236514>] nv_kern_ioctl+0x31c/0x367 [nvidia]
Oct 4 13:47:27 tria kernel: [<0216d078>] sys_ioctl+0x23d/0x2a0
Oct 4 13:47:27 tria kernel: [<0215a97b>] filp_close+0x59/0x5f
Oct 4 13:47:27 tria kernel: [<0215aa21>] sys_close+0xa0/0xd3
Oct 4 13:47:27 tria kernel: Code: 0f 0b 18 03 01 f6 2e 02 f0 83 41 04 ff 0f 98
c0 84 c0 74 16
Oct 4 13:48:42 tria kdm: :0[27276]: Cannot connect to :0, giving up
Oct 4 13:48:42 tria kdm[2180]: Display :0 cannot be opened
Oct 4 13:48:42 tria kdm[2180]: Unable to fire up local display :0; disabling.

Is this a known problem? Is there a fix?

Any help?

Thanks.

Ciao,
GiP
GiP is offline   Reply With Quote
Old 10-04-04, 08:49 AM   #2
uberpenguin
BISCUIT HAMMER
 
Join Date: Apr 2003
Location: Georgia, USA
Posts: 18
Send a message via AIM to uberpenguin Send a message via Yahoo to uberpenguin
Default Re: Kernel BUG! (6111 + 2.6.8-1.521smp on FC2)

I have had ongoing similar problems with my SMP Pentium III (Coppermine) + VIA KT133A chipset machine (running FC2, but I've had the problems since Red Hat 8 era when I got this video card). The same problem happens with both nvidia cards I have laying around (a GeForce 2 TI and a GeForce FX 5200). I'll try to capture a kernel log sometime; the end result is the same: total hard lock of the machine. I've tried just about everything in the past to get this to stop, but nothing seems to work (although some things, such as switching driver versions, seem to help some). In the end, the system will still hard lock at random times; normally if a heavy GLX app is running, but sometimes during 'normal' everyday 2d usage.

-uberpenguin
uberpenguin is offline   Reply With Quote
Old 10-04-04, 08:51 AM   #3
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Kernel BUG! (6111 + 2.6.8-1.521smp on FC2)

@GiP: does the problem persist if you use the builtin NvAGP driver instead of AGPGART?
zander is offline   Reply With Quote
Old 10-04-04, 10:38 AM   #4
GiP
Registered User
 
Join Date: Sep 2004
Posts: 3
Default Re: Kernel BUG! (6111 + 2.6.8-1.521smp on FC2)

Quote:
Originally Posted by zander
@GiP: does the problem persist if you use the builtin NvAGP driver instead of AGPGART?
I tried but it didn't even start. I don't remember exactly what happened but I got en error saying that NvAGP could not be started or gave an error or something. Maybe I did something wrong what is the exact procedure? Is it enough to set Option "NvAGP" "1" or do I need to do something else to disable AGPGART?

Ciao,
GiP
GiP is offline   Reply With Quote
Old 10-04-04, 10:46 AM   #5
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Kernel BUG! (6111 + 2.6.8-1.521smp on FC2)

@GiP: you need to make sure that the Linux AGPGART module isn't loaded. If that doesn't work, please post the error message.
zander is offline   Reply With Quote
Old 10-04-04, 10:55 AM   #6
allabulle
Registered User
 
Join Date: Oct 2004
Posts: 1
Default Re: Kernel BUG! (6111 + 2.6.8-1.521smp on FC2)

I'm having the same problem. I'm on a dual AMD Athlon MP 2.4+, gForce FX5700. Seems to me that it is nothing related with our CPU but nvidia kernel module instead.
Any suggestions will be welcome.
allabulle is offline   Reply With Quote
Old 10-04-04, 11:20 AM   #7
GiP
Registered User
 
Join Date: Sep 2004
Posts: 3
Default Re: Kernel BUG! (6111 + 2.6.8-1.521smp on FC2)

Quote:
Originally Posted by zander
@GiP: you need to make sure that the Linux AGPGART module isn't loaded. If that doesn't work, please post the error message.
Well I checked on the machine and it seems that AGPGART is not running at all even when X is up, at least it doesn't appear in "lsmod". But dmesg says
NVRM: not using NVAGP, AGPGART is loaded!!
so maybe it's not a module but it's part of the kernel and that means with this kernel I cannot do that. Maybe someone else that has the same problem can check this, as for me it's difficult to build an ad hoc kernel.

Ciao,
GiP
GiP is offline   Reply With Quote
Old 10-04-04, 01:25 PM   #8
uberpenguin
BISCUIT HAMMER
 
Join Date: Apr 2003
Location: Georgia, USA
Posts: 18
Send a message via AIM to uberpenguin Send a message via Yahoo to uberpenguin
Default Re: Kernel BUG! (6111 + 2.6.8-1.521smp on FC2)

Quote:
Originally Posted by allabulle
I'm having the same problem. I'm on a dual AMD Athlon MP 2.4+, gForce FX5700. Seems to me that it is nothing related with our CPU but nvidia kernel module instead.
Any suggestions will be welcome.
It isn't CPU related; I ran my same machine perfectly stably for about 6 months before I put an nvidia card in it... I have resigned myself to not run the nvidia module except when I absolutely need GLX apps like Blender... It sucks because the 2d performance lags, but what can I do? Every time I've brought this up nobody wants to try and fix it... Although at this point I'm suspecting it may be some issue with the nvidia module not being SMP safe.

-uberpenguin
uberpenguin is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Random crashes, NVRM Xid messages Iesos NVIDIA Linux 90 10-04-12 03:27 AM
Corrupted display - 302.17 - Dell Precision T3500 (G98 [Quadro NVS 295]) gbailey NVIDIA Linux 1 06-27-12 10:24 AM
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 04:51 AM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
Crash when logout from X TGL NVIDIA Linux 10 09-13-02 08:22 PM

All times are GMT -5. The time now is 06:33 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.