Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-12-02, 02:38 AM   #1
Noz
Registered User
 
Join Date: Nov 2002
Location: France
Posts: 5
Unhappy Help! Problems with linux 7.3

Sorry for my bad english. I'll try to explain my problems.
I have a GeForce4 and want to install the
Linux Display Driver Version: 1.0-3123.
I run Nv chooser and have to download
NVIDIA_GLX-1.0-3123.i386.rpm and
NVIDIA_kernel-1.0-3123.src.rpm.
then I try to run
rpmbuild --rebuild NVIDIA_kernel-1.0-3123.src.rpm
and get the following messages:
Installing NVIDIA_kernel-1.0-3123.src.rpm
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.14581
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd /usr/src/redhat/BUILD
+ rm -rf NVIDIA_kernel-1.0-3123
+ /bin/gzip -dc /usr/src/redhat/SOURCES/NVIDIA_kernel-1.0-3123.tar.gz
+ tar -xf -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd NVIDIA_kernel-1.0-3123
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chown -Rhf root .
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chgrp -Rhf root .
+ /bin/chmod -Rf a+rX,g-w,o-w .
+ exit 0
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.14581
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd NVIDIA_kernel-1.0-3123
+ set +e
++ rpm -q --queryformat '%{VERSION}' rpm
+ RPMVERSION=4.0.4
++ echo 4.0.4
++ awk -F . '{print $1;}'
+ RPMMAJOR=4
++ echo 4.0.4
++ awk -F . '{print $2;}'
+ RPMMINOR=0
++ echo 4.0.4
++ awk -F . '{print $3;}'
+ RPMPATCH=4
+ '[' 4 -le 3 -a 0 -le 0 -a 4 -lt 4 ']'
+ make NVdriver
echo \#define NV_COMPILER \"`cc -v 2>&1 | tail -1`\" > nv_compiler.h
cc -c -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -Wpointer-arith -Wcast-qual -Wno-multichar -O -MD -D__KERNEL__ -DMODULE -D_LOOSE_KERNEL_NAMES -DNTRM -D_GNU_SOURCE -DRM_HEAPMGR -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=3123 -DNV_UNIX -DNV_LINUX -DNVCPU_X86 -I. -I/usr/src/linux/include -Wno-cast-qual nv.c
In file included from /usr/include/linux/vmalloc.h:8,
from nv-linux.h:57,
from nv.c:14:
/usr/include/asm/pgtable.h:17:24: asm/fixmap.h: Aucun fichier ou répertoire de ce type
In file included from nv-linux.h:60,
from nv.c:14:
/usr/include/linux/delay.h:13:23: asm/delay.h: Aucun fichier ou répertoire de ce type
In file included from nv-linux.h:64,
from nv.c:14:
/usr/include/linux/interrupt.h:44:25: asm/hardirq.h: Aucun fichier ou répertoire de ce type
/usr/include/linux/interrupt.h:45:25: asm/softirq.h: Aucun fichier ou répertoire de ce type
In file included from nv.c:14:
nv-linux.h:68:75: asm/uaccess.h: Aucun fichier ou répertoire de ce type
In file included from /usr/include/linux/highmem.h:5,
from nv-linux.h:75,
from nv.c:14:
/usr/include/asm/pgalloc.h:6:24: asm/fixmap.h: Aucun fichier ou répertoire de ce type
In file included from nv-linux.h:111,
from nv.c:14:
/usr/include/linux/autoconf.h:1:2: #error Invalid kernel header included in userspace
make: *** [nv.o] Erreur 1
+ exit 0
Executing(%install): /bin/sh -e /var/tmp/rpm-tmp.86909
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd NVIDIA_kernel-1.0-3123
+ rm -f /tmp/files.lst
+ '[' -z '' ']'
++ uname -r
+ export TARGET_KERNEL=2.4.18-17.7.x
+ TARGET_KERNEL=2.4.18-17.7.x
+ '[' -d /lib/modules/2.4.18-17.7.x/kernel ']'
+ INSTALLPATH=/lib/modules/2.4.18-17.7.x/kernel/drivers/video
+ mkdir -p /var/tmp/NVIDIA_kernel-1.0//lib/modules/2.4.18-17.7.x/kernel/drivers/video
+ install -m 0444 NVdriver /var/tmp/NVIDIA_kernel-1.0//lib/modules/2.4.18-17.7.x/kernel/drivers/video
install: cannot stat `NVdriver': Aucun fichier ou répertoire de ce type
error: Bad exit status from /var/tmp/rpm-tmp.86909 (%install)


RPM build errors:
Bad exit status from /var/tmp/rpm-tmp.86909 (%install)


Can someone help me?

Thank you!
Noz is offline   Reply With Quote
Old 11-12-02, 07:06 AM   #2
Klaus-P
Registered User
 
Join Date: Aug 2002
Location: Germany
Posts: 134
Default

Try to install the complete kernel sources for your linux kernel 2.4.18-17.
Most linux distributions do not install this by default. So check this.
If you have not compiled your system kernel as yet and you have not installed the kernel source package explicitely, it's seems rather likely it's
not or not properly installed.

Et beaucoup de la fortune, je regrette, mon franais n'est pas trs bon aussi ;-).
Klaus-P is offline   Reply With Quote
Old 11-12-02, 08:19 AM   #3
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

One other thing; in the future, you might want to think about running LANG_save=$LANG ; export LANG=en before running your make command, to get the error messages in English, then export LANG=$LANG_save ; unset LANG_save to restore your native language. Perhaps Klaus-P can read German or French or whatever language that is, but personally, I can't. I believe that he's right, that you need kernel-source installed and configured first, but I can't tell for sure since I can't read some of the error messages.

Try installing kernel-source, and then try NVIDIA_kernel again, and if you get errors, see if posting them in English helps.

And by "linux 7.3" I assume you mean RedHat 7.3, correct? Linux 7.3 won't be out for another probably ten years at least, as the current stable version is about to become 2.6 or 3.0. Linux is the kernel, RedHat is what is versioned at 7.3.
__________________
Registered Linux User #219692

Last edited by bwkaz; 11-12-02 at 08:32 AM.
bwkaz is offline   Reply With Quote
Old 11-13-02, 07:05 AM   #4
Noz
Registered User
 
Join Date: Nov 2002
Location: France
Posts: 5
Smile Thank you!

Thank you very much both for your answer. I install kernel-source and then had no problem to build. I was able to install the package. Now my screen look realy better!

Merci beaucoup!

Noz

PS: Effectivelly, I meant 'readhat linux 7.3' I must have wrote too fast
Noz is offline   Reply With Quote
Old 11-13-02, 12:43 PM   #5
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

OK, glad that it works!
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with Asus A7N266VM - nVidia - Linux emmjanex NVIDIA Linux 3 09-29-02 11:52 PM
red hat 7.3 driver problems please help war18 NVIDIA Linux 7 09-16-02 12:25 PM
Suse8, Linux 2.4.19 Problems Alexander NVIDIA Linux 5 08-23-02 02:50 AM
nVidia drivers + Red Hat Linux 7.3 Error404 NVIDIA Linux 17 08-16-02 11:34 AM
NVIDIA Drivers + Linux 7.3 Works once then quits Yupper3d NVIDIA Linux 3 08-01-02 04:03 AM

All times are GMT -5. The time now is 07:39 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.