Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-23-04, 05:35 AM   #1
littleendian
Registered User
 
Join Date: Jan 2004
Posts: 5
Unhappy twinview: garbage on CRT

Hi,

I only see garbage on my CRT (Highscreen MS 17s). I know the image is sent to the CRT because the color of the "garbage" shown on the CRT changes when the color of the image on my laptop LCD changes (the desktop is extended to the left, so for xorg it works). I bet it has something to do with the order of the displays because I have to say "RightOf", but the CRT is actually on the LEFT side of my notebook (so it should be "LeftOf" if the LCD was Display 0, but I guess it's display 1 for some strange reason).

Hardware: Toshiba notebook, nVidia GeForce4 460 32MB
Software: Gentoo GNU/Linux, nvidia 6111 drivers, kernel 2.6.9-mm1 (doesn't work with the older nvidia drivers so I have to use these bleeding-edge ones), xorg (latest version in portage), fluxbox (latest in portage)

Config:
Code:
Section "Extensions"
    Option "Composite" "Enable"
    Option "RENDER" "Enable"
EndSection

Section "Module"
    Load       "dbe"  	# Double buffer extension

    SubSection  "extmod"
      Option    "omit xfree86-dga"   # don't initialise the DGA extension
    EndSubSection

    Load       "freetype"
    Load       "type1"
    Load       "glx"
EndSection

Section "Files"
    RgbPath    "/usr/X11R6/lib/X11/rgb"

    FontPath   "/usr/share/fonts/local/"
    FontPath   "/usr/share/fonts/misc/"
    FontPath   "/usr/share/fonts/75dpi/:unscaled"
    FontPath   "/usr/share/fonts/100dpi/:unscaled"
    FontPath   "/usr/share/fonts/Speedo/"
    FontPath   "/usr/share/fonts/Type1/"
    FontPath   "/usr/share/fonts/75dpi/"
    FontPath   "/usr/share/fonts/100dpi/"

#    FontPath   "/usr/X11R6/lib/X11/fonts/local/"
#    FontPath   "/usr/X11R6/lib/X11/fonts/misc/"
#    FontPath   "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
#    FontPath   "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
#    FontPath   "/usr/X11R6/lib/X11/fonts/Speedo/"
#    FontPath   "/usr/X11R6/lib/X11/fonts/Type1/"
#    FontPath   "/usr/X11R6/lib/X11/fonts/75dpi/"
#    FontPath   "/usr/X11R6/lib/X11/fonts/100dpi/"

#custom:
    FontPath   "/usr/share/fonts/ttf/ja/mikachan/"
EndSection

Section "ServerFlags"
EndSection

Section "InputDevice"
    Identifier	"keyboard1"
    Driver	"keyboard"
    Option "AutoRepeat" "500 30"
    Option "XkbRules"	"xfree86"
    Option "XkbModel"	"pc105"
    Option "XkbLayout"	"de"
    Option "XkbVariant" "nodeadkeys"
    Option "RightAlt"   "ModeShift"
    Option "LeftAlt"    "Meta"
EndSection

Section "InputDevice"
    Identifier	"mouse1"
    Driver	"mouse"
    Option "Protocol"    "IMPS/2" #"Auto"
    Option "Device"      "/dev/mouse"
    Option "Buttons" "5"
    Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
    Identifier  "lcd"
    HorizSync   31.5 - 48.5
    VertRefresh 60
EndSection

Section "Monitor"
    Identifier  "crt"
    #HorizSync   30 - 95
    #VertRefresh 50-160
    HorizSync   30-50
    VertRefresh 60
EndSection

Section "Device"
    Identifier  "gf460"
    Driver      "nvidia"
    Option      "nologo"
    Option 	"RenderAccel" "true"
    Option 	"CursorShadow" "true"
     Option 	"CursorShadowAlpha" "60"
     Option 	"CursorShadowXOffset" "2"
     Option 	"CursorShadowYOffset" "2"
    Option 	"DigitalVibrance" "10"
    Option 	"HWCursor" "1"

    Option "TwinView" "true"
     Option "Metamodes" "1024x768,1024x768; 800x600,800x600; 640x480,640x480"
     #Option "SecondMonitorHorizSync" "30-90"
     #Option "SecondMonitorVertRefresh" "50-150"
     Option "SecondMonitorHorizSync" "30-50"
     Option "SecondMonitorVertRefresh" "60"
     Option "ConnectedMonitor" "dfp,crt"
     Option "TwinViewOrientation" "RightOf"
     Option "IgnoreEdid" "1"

     #Option "ConnectedMonitor" "DFP, TV"
     #Option "TVStandard" "PAL-B"
     #Option "TVOutFormat" "COMPOSITE" 
     #Option "TVOutFormat" "SVIDEO" 
     #Option "TVOverScan" "1.0"
EndSection

Section "Screen"
    Identifier  "lcd"
    Device      "gf460"
    Monitor     "lcd"
    DefaultDepth 24
    Subsection "Display"
        Depth       8
        Modes       "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       16
        Modes       "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       24
        Modes       "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       32
        Modes       "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
EndSection

Section "ServerLayout"
    Identifier  "default"
    Screen 	"lcd"
    InputDevice "mouse1" "CorePointer"
    InputDevice "keyboard1" "CoreKeyboard"
EndSection
I cannot attach the log file because your attachment button doesn't work with firefox and it would make the post too long... so I'll reply to this with the relevant parts of the log file
__________________
Decay is inherent within all compounded beings. With diligence strive on.
littleendian is offline   Reply With Quote
Old 10-23-04, 05:39 AM   #2
littleendian
Registered User
 
Join Date: Jan 2004
Posts: 5
Default Re: twinview: garbage on CRT

It turned out that the Manage Attachments button opened a new window, but I didn't see it because it opened it on the CRT screen (that only shows garbage)...

edit: Oh, I dunno if this is important but: My CRT screen says "No signal input". But that's just not true, as I said, I see the colors change, and if I reboot my notebook with the VGA cable still connected, the CRT screen is recognized as primary display and everything is displayed okay...
Attached Files
File Type: txt Xorg.0.log.txt (35.8 KB, 176 views)
__________________
Decay is inherent within all compounded beings. With diligence strive on.
littleendian is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
First monitor is black when going to virtual console, when using twinView zeBarbu NVIDIA Linux 2 09-07-03 09:35 PM
order of devices in TwinView mjh NVIDIA Linux 2 10-16-02 03:45 AM
Twinview with TV-out karlaugust NVIDIA Linux 10 08-28-02 04:20 PM
Dual Display with main CRT, and secondary TV-out BlackDogg NVIDIA Linux 3 08-10-02 09:52 AM
How do I configure TwinView on Dell Inspiron rutgerclaes NVIDIA Linux 6 08-01-02 03:20 AM

All times are GMT -5. The time now is 01:12 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.