Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-12-02, 06:47 PM   #1
Glenn
Registered User
 
Join Date: Nov 2002
Posts: 7
Default .tar.gz under redhat

I've totally exhausted all ideas trying to install .src.rpms for redhat 8.0 so please don't even go there.

Does anyone know to get .tar.gz to work under redhat 8.0. I get this error for the NVIDIA-kernel

...ld/include -Wno-cast-qual os-registry.c
In file included from nv-linux.h:75,
from os-registry.c:14:
/lib/modules/2.4.18-14/build/include/linux/highmem.h: In function `bh_kmap':
/lib/modules/2.4.18-14/build/include/linux/highmem.h:20: warning: pointer of type `void *' used in arithmetic
ld -r -o Module-linux nv.o os-interface.o os-registry.o
ld -r -o NVdriver Module-linux Module-nvkernel
Module-nvkernel: file not recognized: File truncated
make: *** [NVdriver] Error 1

Any suggestions, Do I have to modify the files?

Cheers
Glenn is offline   Reply With Quote
Old 11-13-02, 12:46 PM   #2
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default Re: .tar.gz under redhat

Quote:
Originally posted by Glenn
ld -r -o NVdriver Module-linux Module-nvkernel
Module-nvkernel: file not recognized: File truncated
Corrupted download perhaps? If you run the md5sum program on the .tar.gz file that you saved, does the output match the MD5sum posted on the driver download page?

What did you use to download it? Maybe try wget or something?
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 11-13-02, 01:00 PM   #3
Glenn
Registered User
 
Join Date: Nov 2002
Posts: 7
Default

Cheers, yes, they were different file sizes, but then I ran into this error:

nv.c:2929: parse error before ')' token
/usr/include/linux/highmem.h: At top level:
nv.c:155: storage size of `nv_fops' isn't known
nv.c:1037: storage size of `nv_vm_ops' isn't known
make: *** [nv.o] Error 1

Any suggestions?
Glenn is offline   Reply With Quote
Old 11-13-02, 04:44 PM   #4
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

That doesn't seem to be the full error message, but I notice that previously, /lib/modules/2.4.18-14/build/include/linux/highmem.h was being included, but now, just /usr/include/linux/highmem.h is being included. Are you sure that your kernel source is still installed? Did you change your kernel between tries?

Can you make >log.txt 2>&1 and then attach the log.txt file?
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 06:48 PM
nForce + RedHat 7.3 Success Story rtz NVIDIA Linux 47 02-15-03 02:20 AM
redhat 8 nforce network success cd21 NVIDIA Linux 2 10-07-02 08:48 PM
Redhat 8.0, no rpm, can't compile. Ironphil NVIDIA Linux 6 10-02-02 03:13 PM
Working RedHat 7.3 with Nvidia?? Be'Lal NVIDIA Linux 3 08-03-02 05:16 PM

All times are GMT -5. The time now is 05:41 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.