Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-06-04, 01:03 PM   #1
bulat
Registered User
 
Join Date: Nov 2004
Posts: 3
Default Black screen with nvidia 6629 driver

I downloaded and installed nvidia 6629 driver. When I start X, I get black screen with mouse cursor. I tried to reinstall driver and recompile kernel, but it didn't help. PLEASE, HELP!!!

I use:
Linux Mandrake 10.1 Community
kernel 2.6.9
videocard GeForce 4 MX 440 with AGP 8x.

Thanks.
bulat is offline   Reply With Quote
Old 11-06-04, 01:19 PM   #2
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Black screen with nvidia 6629 driver

Please submit a bug report with all relevant configuration (Xorg/XFree86) and log (Xorg/XFree86, nvidia-installer, nvidia-bug-report.sh) files to linux-bugs@nvidia.com.
zander is offline   Reply With Quote
Old 11-07-04, 03:16 AM   #3
fernandezm
Registered User
 
Join Date: Jan 2003
Posts: 12
Default Re: Black screen with nvidia 6629 driver

Same behavior here, in my 2 PC.
Driver: 6629 (6611 works perfect in both PCs).
XF86Config attached (it is the same config file for both PCs).
There were no problems compiling drivers.

The problem appears when X is starting: you get a black screen, a little garbage at the top left corner (just a few pixels), and the mouse cursor (at least I can move it). I tried modifiying a lot of parameters in XF86Config-4 settings, and nothing seems to work.
If the Nvidia logo at X start is enabled, I can see (from kdm login) fonts renderized, but no wallpaper or widget, and the Nvidia logo is not disappearing. It stays there as a 'background'.

Hardware details:
PC No. 1: Debian Sarge
Card: TNT2 NV5M64 (32MB AGP "Model 64/64 Pro")
Kernel: 2.6.8-1-686 (updated from debian's sarge repository)
Processor: Pentium III 733 Mhz
Motherboard: Soyo 6VBA (VIA Apollo Pro133x Chipset)
X Server: XFree86 4.3 (Debian Sarge updated)

PC No. 2ebian Sid
Card: nVidia Corporation NV18 [GeForce4 MX 440 AGP 8x]
Kernel: 2.6.9-1-k7 (updated from debian's sid repository)
Processor: AMD Athlon 1.4 Ghz Thunderbird core
Motherboard: Asus A7V8X-X (Via KT400 chipset)
X Server: XFree86 4.3 (Debian Sid updated, same subversion as Sarge's PC)
Attached Files
File Type: txt XF86Config-4.txt (3.4 KB, 792 views)
fernandezm is offline   Reply With Quote
Old 11-07-04, 06:27 AM   #4
zhak
Registered User
 
zhak's Avatar
 
Join Date: Apr 2003
Posts: 12
Default Re: Black screen with nvidia 6629 driver

I have exactly the same problem on my Riva TNT2 with this driver. Something wrong with that version...
__________________
>zhak<
zhak is offline   Reply With Quote
Old 11-07-04, 10:00 AM   #5
moreejt
Registered User
 
Join Date: Aug 2004
Posts: 4
Default Re: Black screen with nvidia 6629 driver

I have compaq R3140US laptop with Geforce Go 32M. The latest driver also gives me problems. 6111 worked pretty good. The PROBLEM is that the LCD is trashed no matter what I try. But the vga out works fine. I have used many differenent X confs to test out different things. Note: THE lcd also gets trashed if I try to use both the monitor and the lcd at the same time (NOT twinview) just plugging both in. that has been happening with all the drivers I try. see
http://www.nvnews.net/vbulletin/show...208#post412208.

My kernel is 2.6.7. Should I only be trying out newer kernels? everyone else seems to be trying out 10.
moreejt is offline   Reply With Quote
Old 11-07-04, 02:09 PM   #6
maxresch
Geforce FX 5600 XT
 
Join Date: Oct 2003
Location: Krems, Austria
Posts: 17
Send a message via ICQ to maxresch
Default Re: Black screen with nvidia 6629 driver

Same problem.

X starts up and the screen is black. I can use the mouse, type something, start apps but the screen is black.

I tried out
Option "nvagp" "0" this switchs agp completly off (and fast 3D Graphics). This solves the preoblem somehow (but not realy: in gdm the otions windows aren't shown).

My System

NVidia GeForce 440MX 128MB
AMD Athlon XP 2200
AGP Chipset (Via ??? KT400) using the via_agp kernelmodule)

SuSE 9.1
Kernel 2.6.9 (+Framebuffer, Bootspalsh Patches)

for more info please ask me.
maxresch is offline   Reply With Quote
Old 11-07-04, 02:23 PM   #7
tnt_user
Registered User
 
Join Date: Nov 2004
Posts: 1
Default Re: Black screen with nvidia 6629 driver

I have the same problem. NV5M64 [RIVA TNT2 Model 64/Model 64 Pro] (rev 15). If I disable agpgart to NvAgp "0" I can at least see the login manager. I can log in but as soon as the desktop starts it crashes. With agpgart It seems Im in the enviroment yet its all black.
Attached Files
File Type: txt Xorg.0.log.txt (31.0 KB, 600 views)
tnt_user is offline   Reply With Quote
Old 11-08-04, 01:48 AM   #8
666_1337
Registered User
 
Join Date: Dec 2003
Posts: 28
Send a message via ICQ to 666_1337
Default Re: Black screen with nvidia 6629 driver

Same problem - but I don't even get a cursor displayed - with gffx6800gt.
__________________
Athlon-XP 3000+, 2560 Megaoctets Ram, KT600, GeForce FX 6800 GT, Sound Blaster Audigy 2 ZS, BCM5788 Ethernet Adapter

Linux 2.6.9-mm1 ( gcc 3.4.3, glibc cvs 20041021 ), X.Org 6.8.1, nVidia Detonator 1.0.6629
Windows XP with Service Pack 2, nVidia Detonator `Forceware` 66.81
666_1337 is offline   Reply With Quote

Old 11-08-04, 01:53 AM   #9
mtvoid
Registered User
 
Join Date: Jan 2004
Location: Delhi, India
Posts: 14
Exclamation Re: Black screen with nvidia 6629 driver

I'm seeing the same symptoms as fernandezm described, I too have a TNT2/M64.
I'm using kernel 2.6.9 with framebuffer enabled. I tried changing "NvAGP" to 0, then at least some stuff other than the mouse-cursor is also drawn. (Using Nvidia's own agp driver doesn't change anything either, only disabling agp does). Still nothing in the background is refreshed, and there are a lot of artifacts on the screen.
mtvoid is offline   Reply With Quote
Old 11-08-04, 04:50 PM   #10
maxresch
Geforce FX 5600 XT
 
Join Date: Oct 2003
Location: Krems, Austria
Posts: 17
Send a message via ICQ to maxresch
Default Re: Black screen with nvidia 6629 driver

I think this has something to do with the new Composite Extension Support introduced in 6629.

*ONLY* my opinion. This *NEED NOT* to be the real reason.

(Composite Extension: I'v also disabled this but it has no effect)
maxresch is offline   Reply With Quote
Old 11-08-04, 04:57 PM   #11
comag
Registered User
 
comag's Avatar
 
Join Date: Sep 2004
Posts: 54
Default Re: Black screen with nvidia 6629 driver

try

Option "IgnoreEDID" "1"
Option "UseEdidFreqs" "0"
Option "HWCursor" "0"

or play with these settings
__________________
Fedora Core 4 (2.6.17) on an x86_64
Geforce 6600GT
comag is offline   Reply With Quote
Old 11-08-04, 05:24 PM   #12
mr-k
Registered User
 
Join Date: Nov 2004
Location: PL
Posts: 6
Default Re: Black screen with nvidia 6629 driver

I have the same problem with my TNT2 M64, kernel 2.6.9, comag's given options dont change enything. Also 6611 work good.
mr-k is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
[9800gt] Xorg black screen after installing nvidia driver HacKurx NVIDIA Linux 1 06-07-12 02:29 PM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 09:35 PM
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 07:48 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 09:49 AM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-02-02 12:58 AM

All times are GMT -5. The time now is 09:09 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.