Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-16-04, 09:02 AM   #61
strutter79
Registered User
 
Join Date: Nov 2004
Posts: 13
Default Re: Black screen with nvidia 6629 driver

Hi

I downloaded the 6629 version of the nvidia drivers.
I have to say you that they run fine in my Linux system, even with
my TNT2 Vanta graphics card. So i think the problem is not related with old
graphics cards not supported anymore...

System:
Mandrake Linux 10.1 Official
Kernel 2.6.7-2
Using Xorg 0.611.7

AMD Athlon 1.0 GHZ Thunderbird
ASUS A7V133-C MOBO
256 MB RAM
NVIDIA 16 MB TNT2 Vanta Graphics Card

Oskar.
strutter79 is offline   Reply With Quote
Old 11-16-04, 01:09 PM   #62
muttoni
Registered User
 
Join Date: Sep 2004
Posts: 5
Arrow Re: Black screen with nvidia 6629 driver

Ive noticed this kind of problem in my 2 PCs:

-------------------------------------------------------------------
PC1:
Athlon TBird 1333 MHz
MB: Asus A7M266
Videocard: Asus GeForce2 GTS V7700 32MB

Problems:

1) X initialization now is very slow... (just X server /usr/X11/bin/X) it appears that nvidia driver is trying to detect some kind of display....
2) Some artifact like vertical red bars over the screen it X start/restart (kdm logout)
3) When I resize the screen (CTRL ALT +/-) the computer (mouse, keyboard, screen) stop responding for about 2 secounds... after resize....

-------------------------------------------------------------------
PC2:
Athlon Slot 600 MHz
MB: Asus K7M
Videocard: Riva TNT2 M64 - 16MB

Problem:

1) the driver is unusable at this machine... like many people in this tread said above, elements like background, mouse, icons, menus are not displaying/clearing properly... very ugly.... i tried everthing, like disabling AGP, glx, changing video memory type in os-registry.c.... nothing works.

-------------------------------------------------------------------

** Software settings for both PCs:
Base: Slackware linux 10.0 hightly customized
Kernel 2.6.10 compiled
X.org 6.8.1 compiled
NVIDIA driver 6629 (compiled, of course)
gcc 3.4.2 also compiled !
glibc 2.3.3 not compiled

i've also noted that open-source nv driver is much faster to initialize (X start quickly)... but nobody note things like it... just crazy people like me

I (we) hope that nvidia guys correct that bug!

Leonardo Muttoni -- from Brasil - sorry for my bad english, people...

ps: bush is a people killer
muttoni is offline   Reply With Quote
Old 11-17-04, 11:04 AM   #63
eax
hello
 
eax's Avatar
 
Join Date: Nov 2004
Location: ⊕
Posts: 10
Unhappy Re: Black screen with nvidia 6629 driver

The latest upgrade in sid only changes the version number
There was a kernel-image upgrade too, but I don't know what it did (it's still 2.6.9-1-686).

Is there any new news on this issue, or are the people who suffer from this left in the dust?
__________________
BOFH excuse #439:
Hot Java has gone cold
eax is offline   Reply With Quote
Old 11-17-04, 09:04 PM   #64
codergeek42
Registered User
 
Join Date: Nov 2004
Posts: 1
Default Re: Black screen with nvidia 6629 driver

Happens to me as well...

System specs:
Gentoo Linux, XOrg X11R6.8
Riva TNT2 M64, 32 MB VRAM, 2x AGP
Athlon Thunderbird (1.2 GHz)
256 MB RAM

The 6111 drivers work wonderfully, however...
codergeek42 is offline   Reply With Quote
Old 11-20-04, 06:17 AM   #65
666_1337
Registered User
 
Join Date: Dec 2003
Posts: 28
Send a message via ICQ to 666_1337
Default Re: Black screen with nvidia 6629 driver

OK. I got 66.29 working now. This is what I did:
- emerged ( gentoo's package installer ) udev, hotplug and softplug
- made nvidia driver module be loaded at startup by adding `nvidia` to /etc/modules.autoload/2.6
- disabled defvs kernel support
- rebooted with recompiled kernel
I then got the message that my pointer ( /dev/usbmouse ) could not be accessed. So I linked /dev/input/mouse0 to /dev/usbmouse and everything is well now ( both NVAgp and agpgart work ).

NOTE: AGP Fastwrites are disabled by the BIOS at me.

glxgears works about +1% faster
__________________
Athlon-XP 3000+, 2560 Megaoctets Ram, KT600, GeForce FX 6800 GT, Sound Blaster Audigy 2 ZS, BCM5788 Ethernet Adapter

Linux 2.6.9-mm1 ( gcc 3.4.3, glibc cvs 20041021 ), X.Org 6.8.1, nVidia Detonator 1.0.6629
Windows XP with Service Pack 2, nVidia Detonator `Forceware` 66.81
666_1337 is offline   Reply With Quote
Old 11-20-04, 09:02 PM   #66
T-Sar-Goth
Friendly Dragon
 
T-Sar-Goth's Avatar
 
Join Date: Nov 2004
Posts: 2
Send a message via ICQ to T-Sar-Goth Send a message via AIM to T-Sar-Goth Send a message via MSN to T-Sar-Goth Send a message via Yahoo to T-Sar-Goth
Default Re: Black screen with nvidia 6629 driver

This problem seems to occur with only some nvidia cards.

Earlier today I bought a Geforce MX 4000 and had this problem. I've returned it and got a Geforce FX 5200 instead not changing anything else. It now works fine without any problems.

I'm running FC3 on an AMD64
T-Sar-Goth is offline   Reply With Quote
Old 11-21-04, 01:23 AM   #67
Roguestar191
Registered User
 
Join Date: Sep 2004
Posts: 28
Default Re: Black screen with nvidia 6629 driver

Hmm, I have a similar problem, but I think I may have found it.

(II) Module fbdevhw: vendor="X.Org Foundation"
compiled for 6.8.1, module version = 0.0.2
ABI class: X.Org Video Driver, version 0.7
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.6629
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1

Notice: the nvidia driver is compiled for XFree86 4.0.2 I believe, while I'm running X.Org6.8.1. Could this be a contributing factor?

Fedora Core 2. - Kernel 2.6.9 - (HacKedInTang)

(--) PCI:*(1:0:0) nVidia Corporation NV5 [RIVA TNT2/TNT2 Pro] rev 17, Mem @ 0xe4000000/24, 0xe6000000/25, BIOS @ 0xe5000000/16

My system was Redhat 9.0 upgraded to Fedora Core 2. Maybe when it upgraded some of the old XFree86 files were left behind that are messing up the nvidia installer?????
Roguestar191 is offline   Reply With Quote
Old 11-21-04, 09:12 AM   #68
T-Sar-Goth
Friendly Dragon
 
T-Sar-Goth's Avatar
 
Join Date: Nov 2004
Posts: 2
Send a message via ICQ to T-Sar-Goth Send a message via AIM to T-Sar-Goth Send a message via MSN to T-Sar-Goth Send a message via Yahoo to T-Sar-Goth
Default Re: Black screen with nvidia 6629 driver

I this driver with the MX 4000 I tried both using fbdevhw and not using i,t same result.It really does seem to be this driver on some hardware not other parts of Xorg or XFree86
T-Sar-Goth is offline   Reply With Quote

Old 11-21-04, 11:40 AM   #69
MrGreen
Registered User
 
Join Date: Sep 2004
Posts: 4
Default Re: Black screen with nvidia 6629 driver

I have MX440 with 6629 I get logo then I cannot log in (kdm) no mouse (PS/2)

Code:
 cat /proc/driver/nvidia/agp/card
Fast Writes:     Supported
SBA:             Supported
AGP Rates:       8x 4x
Registers:       0x1f000e1b:0x1f004302
Is there any news of a fix ?
MrGreen is offline   Reply With Quote
Old 11-22-04, 08:20 AM   #70
Romzes
Registered User
 
Join Date: Nov 2004
Posts: 2
Unhappy Re: Black screen with nvidia 6629 driver

Same problem in my 2 PC.
Driver: 6629
XFree86 Version 4.3.0.1 (Debian 4.3.0...)
Kernel 2.6.8 and kernel 2.6.9

Hardware details:
I tested:
TNT 16Mb AGP
TNT2 32 Mb AGP
Gf4 64Mb AGP8x
don't work black screen or white (with Nvidia and Debian logo if I use old config file) and mouse cursor.
X don't correct start.

6611 worked, but I do "apt-get upgrade" :-( I see that installed new x-window-system and nvidia-glx... reboot... and don't working now.
I installed nvidia 6629 - black screen and mouse cursor.
No errors in *.log
Romzes is offline   Reply With Quote
Old 11-22-04, 10:40 AM   #71
Romzes
Registered User
 
Join Date: Nov 2004
Posts: 2
Default Re: Black screen with nvidia 6629 driver

Gf4 64Mb AGP8x - done.
Reinstall 6629 + apt-get upgrade
But if I reboot:

Fatal server error:
Caught signal 11. Server aborting

reinstall again...?!

TNT and TNT2 on Intel440 don't work with 6629 :-(
Romzes is offline   Reply With Quote
Old 11-23-04, 12:04 PM   #72
LeSeb!
Registered User
 
Join Date: Nov 2004
Posts: 1
Lightbulb Re: Black screen with nvidia 6629 driver

Quote:
Originally Posted by Romzes
6611 worked, but I do "apt-get upgrade"
Hi all,

I had the same problem with revision 6629 of the nvidia drivers on my Debian (unstable) system.

You can revert back to 6111 (they worked / still work great for me !) :
1. Download debs from there : http://sebastien.phelep.free.fr/nvidia6111/.
2. Install them with dpkg -i
3. Mark them as hold within dselect so that they won't be upgraded to 6629 ...

That's how I did, and I'm back with working 6111 !

Hope this'll help.

Seb
LeSeb! is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
[9800gt] Xorg black screen after installing nvidia driver HacKurx NVIDIA Linux 1 06-07-12 01:29 PM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 06:48 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-01-02 11:58 PM

All times are GMT -5. The time now is 05:34 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.